Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-16-2012, 09:38 PM   #1
TiM801
Scooby Specialist
 
Member#: 289115
Join Date: Jul 2011
Chapter/Region: RMIC
Location: SLC
Vehicle:
2002 WRX
WRB

Default Cel P0442

Hey, so i have a CEL P0442 some sort of small leak? Not sure what it is.. or what it could be, my engine is pretty much stock, besides an intake. Anyone have any clues? I've tightened my gas cap.. /shrug If i ignore the CEL could it escalate to something more serious? It's more annoying than anything.. Thanks!
TiM801 is offline   Reply With Quote
Old 02-16-2012, 10:57 PM   #2
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

Look on the left side of your alternator and behind the power steering pump, its common for the lines there to pop off and cause that check engine light.
bhhamblin is offline   Reply With Quote
Old 02-16-2012, 11:36 PM   #3
Not-EWRX
Scooby Specialist
 
Member#: 158043
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC
Vehicle:
2013 Wrx Hatch
SWP

Default

This is the code from hell. You have a leak in your evap system somewhere. It could be anywhere from the gas cap, gas stem, gas tank, canister, or any of the like 50ft of evap lines between the engine and the back of the car. Good luck. Check the lines back by the canister as well.
Not-EWRX is offline   Reply With Quote
Old 02-17-2012, 01:53 AM   #4
TiM801
Scooby Specialist
 
Member#: 289115
Join Date: Jul 2011
Chapter/Region: RMIC
Location: SLC
Vehicle:
2002 WRX
WRB

Default

Damn, ok thanks I'll check it out...
TiM801 is offline   Reply With Quote
Old 02-17-2012, 08:39 AM   #5
TurboJunkie85
Scooby Specialist
 
Member#: 193412
Join Date: Nov 2008
Chapter/Region: RMIC
Vehicle:
1985 pumas.
white

Default

Check the lines that run on the passenger side of the intake manifold, zip tie them and then if that doesn't work. Look at the Lines under the passenger rear of the car that connect to the charcol can.
TurboJunkie85 is offline   Reply With Quote
Old 02-17-2012, 10:48 AM   #6
Develitate
Scooby Newbie
 
Member#: 134559
Join Date: Dec 2006
Chapter/Region: RMIC
Location: North Ogden
Vehicle:
2005 2.5 RS
PSM

Default

I've been dealing w/ this CEL the ENTIRE time I've owned my Subie. Taken it into the dealership 15+ times and they can never do anything for me. I bought a new gas cap, checked my lines and finally learned to live with it and bought a bluetooth OBD II sensor so I can turn off the CEL myself. Hopefully yours is an easy fix. If you find what the issue is on your car will you LMK?
Develitate is offline   Reply With Quote
Old 02-17-2012, 03:03 PM   #7
Not-EWRX
Scooby Specialist
 
Member#: 158043
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC
Vehicle:
2013 Wrx Hatch
SWP

Default

Quote:
Originally Posted by Develitate View Post
I've been dealing w/ this CEL the ENTIRE time I've owned my Subie. Taken it into the dealership 15+ times and they can never do anything for me. I bought a new gas cap, checked my lines and finally learned to live with it and bought a bluetooth OBD II sensor so I can turn off the CEL myself. Hopefully yours is an easy fix. If you find what the issue is on your car will you LMK?
How do you get your car to pass emissions? Mine wouldn't pass without out having readness on the Evap system.
Not-EWRX is offline   Reply With Quote
Old 02-18-2012, 11:36 AM   #8
Develitate
Scooby Newbie
 
Member#: 134559
Join Date: Dec 2006
Chapter/Region: RMIC
Location: North Ogden
Vehicle:
2005 2.5 RS
PSM

Default

In Weber County you're allowed to have 1 system "not ready" and they will still pass you.

Quote:
Originally Posted by Not-EWRX View Post
How do you get your car to pass emissions? Mine wouldn't pass without out having readness on the Evap system.
Develitate is offline   Reply With Quote
Old 02-20-2012, 12:56 AM   #9
Not-EWRX
Scooby Specialist
 
Member#: 158043
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC
Vehicle:
2013 Wrx Hatch
SWP

Default

Quote:
Originally Posted by Develitate View Post
In Weber County you're allowed to have 1 system "not ready" and they will still pass you.
Is it the same for salt lake? Holly hell that'd be lame.
Not-EWRX is offline   Reply With Quote
Old 02-17-2012, 11:33 AM   #10
TiM801
Scooby Specialist
 
Member#: 289115
Join Date: Jul 2011
Chapter/Region: RMIC
Location: SLC
Vehicle:
2002 WRX
WRB

Default

Yeah for sure...
TiM801 is offline   Reply With Quote
Old 02-17-2012, 02:23 PM   #11
Momosaurus WRX
Scooby Specialist
 
Member#: 214737
Join Date: Jun 2009
Location: South Ogden
Default

Most people don't know how to diag evap system codes. It's really not that hard, just a matter of plugging off the right lines and using a smoke tester.

Problems that it could be:
1) gas cap
2) vacuum lines under the passenger side of the intake manifold
3) a broken/cracked nipple that those vacuum lines go to
4) Lines going to charcoal canister. It's going to be a SMALL leak. So look for damaged lines/hoses.

It's not going to cause you any damage, it's just annoying. I've had this code come up on my 99 Legacy. It was for the sensor that is on the passenger side of the intake manifold that the vacuum lines go to, the nipple broke. And yes I know that I just restated what everybody else said. I just figured organization to problem areas might be nice.
Momosaurus WRX is offline   Reply With Quote
Old 02-19-2012, 03:59 PM   #12
zackl801
Scooby Specialist
 
Member#: 171753
Join Date: Feb 2008
Chapter/Region: RMIC
Vehicle:
2012 WRX
DGM

Default

cracked nipple
zackl801 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cel P0442 PorterFNU Newbies & FAQs 1 10-06-2009 06:52 PM
CEL P0442 stand up imma_stocker Texas Impreza Club Forum -- TXIC 6 11-04-2007 10:19 PM
CEL P0442 (evap small leak) + instable boost frederik Factory 2.0L Turbo Powertrain 4 10-20-2007 11:49 AM
Cel P0442 Rando Engine Management & Tuning 5 03-29-2006 10:14 PM
CEL P0442/P0457? (Help Needed) APSWRX1 Texas Impreza Club Forum -- TXIC 4 03-28-2006 02:16 PM


All times are GMT -4. The time now is 10:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.