Welcome to the North American Subaru Impreza Owners Club Friday October 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 03-31-2012, 05:52 AM   #1
Scooby Newbie
Member#: 289159
Join Date: Jul 2011
Chapter/Region: E. Canada
Location: Toronto, Canada
2007 Impreza 2.5i SE

Default Startin troubles. 07 2.5i

Hey dudes. So I jumped my car and it wouldn't idle properly I had to keep it driving for a bit to get an idle back without stalling. Then I parked it somewhere no where close to where I live. Then when I tried to crank it I got nothin. So I boosted it again but it just got weaker and weaker with each crank. Where do I start to diagnose. And can I fix it downtown. Hahaha.
jonclarke is offline   Reply With Quote
Old 03-31-2012, 07:48 AM   #2
Scooby Newbie
Member#: 261162
Join Date: Oct 2010
Chapter/Region: NESIC
Location: southern New Hampshire, USA
2000 Outback Sport


get a jump and get it home, check for CELs. was the alt light lit, or gauge reading low when running? check charging system anyways. if charge sys is good and battery isnt old as hell, make sure nothing that stays powered with key off got left on. barring that, you may have a short pulling down your voltage.

jeepnut_nh is offline   Reply With Quote
Old 03-31-2012, 04:51 PM   #3
Tony JDM
Scooby Specialist
Member#: 207532
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: NE WI
1999 Impreza 2.5RS
Rusty Black Diamond Pearl


I read the thread title as "starting trouble" (like starting shenanigans) and then read that you "jumped your car and now it doesn't idle and stalls." I thought you took your car off some sick jumps.
Tony JDM is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : 04 sti & 2006 2.5i TEIN coilovers, front & rear strut bars, i think fits 07 2.5i also smo0ve Suspension/Brakes/Handling 5 02-05-2012 12:00 PM
06 2.5i vs 07 2.5i boymk Newbies & FAQs 24 04-09-2008 04:07 PM
WTB: 2.5i Midpipe / 06/07 2.5i CAI Setup / Exhaust Shield deviantek NWIC Private Classifieds 3 08-17-2007 02:21 PM
WTT : 07 2.5i Hood - 06/07 STi Hood heretix. SWIC Private Classifieds 8 05-06-2007 03:20 PM
WTB: 06/07 STi Axle Back Muffler in Lacey/Tacoma Area for my 07 2.5i cwcouch22 North West Impreza Club Forum -- NWIC 0 04-11-2007 11:08 AM

All times are GMT -4. The time now is 08:25 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.