Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-15-2012, 06:54 PM   #1
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default What's this behind the passenger rear wheel. P0442 related

about a month ago, my check engine light came on. CEL read p0442 (EVAP leak (small)).


So today I was chasing it.

If I'm not mistaken, it's the fuel canister right? (sorry about the noob question)



If that hose is loose (the clean one), then that would be my problem. Any input would help!

Last edited by jakechup; 04-15-2012 at 07:07 PM.
jakechup is offline   Reply With Quote
Old 04-15-2012, 07:12 PM   #2
black_knight06
Scooby Specialist
 
Member#: 146718
Join Date: Apr 2007
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'06 OBP STi
'07 CGM Forester XT Ltd.

Default

Yup, that's part of the EVAP System for the emissions of your car. If it's loose, you should probably replace it since I don't think it's held on with anything except the friction between it and the nipple it fits over.
black_knight06 is offline   Reply With Quote
Old 04-15-2012, 07:21 PM   #3
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default



I would say it's loose. There was dirt in the crack between the nipple and the hose too.
jakechup is offline   Reply With Quote
Old 04-15-2012, 08:32 PM   #4
tooocool49723
Scooby Specialist
 
Member#: 67127
Join Date: Jul 2004
Chapter/Region: MWSOC
Location: Belleville, MI
Vehicle:
3.3 I <3/h8 my GF3
1.8-2.5-2.2-2.5-2.2-3.3

Default

Yup, evap is like an air filter for you gas tank. If there's a leak, it's a bad thing. Replace the hose, or fix the leak.

But yeah, Fuel canister, charcoal canister, EVAP canister, tomato tomaaato.
tooocool49723 is offline   Reply With Quote
Old 04-15-2012, 08:36 PM   #5
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default

Thanks, I'm going to replace this hose and then clear the ECU. If it doesn't come up. Problem solved.
jakechup is offline   Reply With Quote
Old 04-15-2012, 08:39 PM   #6
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default

How should I go about fixing this?

Last edited by jakechup; 04-15-2012 at 10:50 PM.
jakechup is offline   Reply With Quote
Old 04-16-2012, 11:05 AM   #7
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default

Bumpbumpbump
jakechup is offline   Reply With Quote
Old 04-16-2012, 03:41 PM   #8
atomicfire
Scooby Specialist
 
Member#: 136296
Join Date: Dec 2006
Chapter/Region: TXIC
Location: Midtown, Houston, TX
Vehicle:
2005 STi
OBP

Default

go to a junkyard and get replacement parts. Go to autozone and get a replacement hose. Go to dealership and get replacement hose. I listed your options from cheapest to most expensive.
atomicfire is offline   Reply With Quote
Old 04-16-2012, 03:41 PM   #9
atomicfire
Scooby Specialist
 
Member#: 136296
Join Date: Dec 2006
Chapter/Region: TXIC
Location: Midtown, Houston, TX
Vehicle:
2005 STi
OBP

Default

You can remove the evap system and disable the CEL's too. That's another (unrecommended) options
atomicfire is offline   Reply With Quote
Old 04-16-2012, 09:42 PM   #10
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default

Update: Noticed cracks on the end of that hose today when pulling it off. I'm going to replace it tomorrow. Thanks guys
jakechup is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What is this behind the grille andrewprime Newbies & FAQs 7 01-26-2011 09:55 PM
Fuel smell coming from passenger rear wheel well dauss Newbies & FAQs 5 02-18-2009 10:24 AM
What's up with the ghey amount of sexually related questions? Hotrodguru Off-Topic 37 05-21-2008 01:08 AM
Loud screeching/metal grinding noise from passenger rear wheel! ASpec818 Brakes, Steering & Suspension 7 02-17-2007 06:52 PM
black box behind passenger rear wheel danny8630 General Community 16 06-30-2005 04:43 PM


All times are GMT -4. The time now is 10:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.