Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Reviews > Dealership Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-17-2012, 04:21 PM   #1
DJ Catchem
Scooby Newbie
Member Sales Rating: (10)
 
Member#: 51107
Join Date: Dec 2003
Chapter/Region: NESIC
Location: Westmoreland, NH
Vehicle:
2008 Legacy GT Ltd
Silver

Default Subaru of Milford - NH - Buyer Beware

I almost hate to give these guys a bad writeup, as I did have a positive experience buying my wife's Forester there a few years back. Due to the interaction with the service department, though, I think it's important that people be aware of what they're getting into in general when shopping Milford for used cards.

Roughly two years ago, I traded my '06 WRX sedan in for an '08 Legacy GT Limited sedan. The mileage was correct, and the car looked pretty decent to my eyes (minus a few nicks and scratches), so I took a test drive.

Everything felt solid, save a slight pull to the right. I noted this with the salesman, and he assured me we'd get an alignment as part of the deal if it worked out.

I checked Carfax, and the car came back clean, so we went forward with the deal. I picked it up after work mid-week just before closing.

Sure enough, the drive home let me feel the car out a bit better, and it was still wandering to the right. I called the dealer back the next day, and they verified an alignment was performed, but the would re-do it if I brought the car back in.

Half a morning off and a Forester loaner (that I was promised over the phone, but nearly denied when I arrived because "it was needed for other customers as well" (!??!?!), and I had my car back at the end of the day. The shop manager was not able to provide the printout of the alignment Far less wander, but it was still slightly there. I chalked it up to the tires.

I picked up a nail in one not too long after, so I had a local shop put on a new set. I regularly rotated the tires, and noted that at 10K miles, the fronts were wearing on the front insides a bit aggressively.

By 16k, the tires were shot. Both fronts worn bare on the insides.

I just sourced another set of tires, and had a suspension shop do the mount/balance and an alignment. Halfway through, the tech reported that there was clear evidence that the front left of the car had been hit at some point, and the strut on that corner was bent to the point that it was physically unable to be set to factory specs.

If not for the two alignments done by the Milford techs, I'd chalk this up to bad luck with an un-reported minor accident, and my own fault for not going over the car with a fine-tooth comb myself. However, the shop there (and their ASE-Certified technicians) had at minimum two different opportunities to recognize and report the damage, and they chose to let it go instead and allow a car that couldn't be aligned to factory spec to leave the dealer. The equal severe inside wear on both tires seems to indicate the alignment was set to try to minimize the pull and provide a more stable ride.

Memory is a little fuzzy (and I'll check my receipts), but I believe the car left the dealer with a NH inspection sticker as well.

All in all...not impressed.

--->DJ

Last edited by DJ Catchem; 07-17-2012 at 04:30 PM.
DJ Catchem is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:53 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.