Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid West Subaru Owners Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid West Subaru Owners Club Forum -- MWSOC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-06-2012, 09:52 PM   #1
04STiowner84
Scooby Newbie
 
Member#: 332393
Join Date: Sep 2012
Vehicle:
04 WRX STi
Slvr

Exclamation Need Help (Green Connectors under driver dash)

Hey guys so heres the deal. I have an 04 STI and the previous owner decided to "RED NECK" rig a toggle switch up for those 2 green connectors that i so badly need in order to flash or even read my ECU. I have found the RL (red and lavender) wire but the crappy thing is, its been spliced to a black wire to the switch but i also have 2 black an red wires with male ends on them. If its possible could u please take a picture of yr connectors including wire color and locations of both wires so i can determine where this is all leading so i can fix this properly.
04STiowner84 is offline   Reply With Quote
Old 11-06-2012, 10:25 PM   #2
JarHarms
Scooby Specialist
 
Member#: 138994
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: DeKalb-ish, IL
Vehicle:
06 WRX Ltd SGM 6MT
02 Forester S

Default

The green B75 and B76 connectors that mate together -> I see RL to B75 connector (terminal slot 1) and BR to B76 connector (terminal slot 1) on the STI wiring diagram I have for the for the test connector. This wiring diagram is for a 2006-2007 MY but the same circuit colors may have been used on your 2004. Just keep in mind that the B76 circuit colors are different between STI/WRX/2.5i.
RL = red/blue stripe
BR = black/red stripe
I have a photo of the connectors but since its on a WRX the circuit colors are different RL and BY. So maybe not much use for you, sorry.

Last edited by JarHarms; 11-06-2012 at 10:35 PM.
JarHarms is offline   Reply With Quote
Old 11-08-2012, 08:48 AM   #3
Th3Franz
Scooby Specialist
 
Member#: 37146
Join Date: May 2003
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
2005 Legacy GT
Stage tree fitty

Default

why not just use the switch they installed? Switch closed = connected
Switch open = disconnected
Th3Franz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.