Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-15-2012, 05:37 PM   #1
wookieda
Scooby Newbie
 
Member#: 326265
Join Date: Jul 2012
Vehicle:
1996 GF8 WRX STI

Default rough idle after hitting wild animal

So i hit a coyote..


Poor thing didn't survive the impact..

anyway, since the incident, the car runs really rough.. I'm suspecting vacuum leak..(I really hope it is as simple as that).. or knicked fuel line? no leak or anything tho.

I took this vid of boost guage at idle..
https://www.youtube.com/watch?v=bRJ9...e_gdata_player

what do you guys think?
wookieda is offline   Reply With Quote
Old 11-15-2012, 09:11 PM   #2
legacydreamz
Scooby Specialist
 
Member#: 92423
Join Date: Jul 2005
Chapter/Region: Tri-State
Location: locked in the freezer
Vehicle:
2007 Honda CRV
still locked in freezer

Default

Looks like a hard enough impact to pop an already loose hose or finish off a dying sensor. Any codes?
legacydreamz is offline   Reply With Quote
Old 11-15-2012, 09:26 PM   #3
wookieda
Scooby Newbie
 
Member#: 326265
Join Date: Jul 2012
Vehicle:
1996 GF8 WRX STI

Default

I haven't looked for a code. i should, even tho no CEL yet..
wookieda is offline   Reply With Quote
Old 11-15-2012, 09:27 PM   #4
paulpat
Scooby Specialist
 
Member#: 237145
Join Date: Feb 2010
Chapter/Region: SCIC
Location: 562
Vehicle:
02 WRX
12 FXT

Default

Coyote ghost? Dirty Maf sensor soaked with blood? Fur in the iacv?

Can you log the car at all? Like with rom raider? I don't think there is any important thingsin that area besides electrical stuff. Maybe ur grounding a wire now and putting more load on the alternator?
paulpat is offline   Reply With Quote
Old 11-15-2012, 11:50 PM   #5
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

oooohhh....skipped tooth/teeth on the timing belt mebee!!!!!

happens like that sometimes
Uncle Scotty is offline   Reply With Quote
Old 11-16-2012, 04:16 PM   #6
wookieda
Scooby Newbie
 
Member#: 326265
Join Date: Jul 2012
Vehicle:
1996 GF8 WRX STI

Default

yeah i 'm not sure.. i have to see an adjuster for my insurance company as they will determine if i had infact hit an animal, not something else.. anyways they are going to be reluctant to fix the engile idle issue unless i can prove to them that this happend after hitting the animal.

Checked for vacuum leaks yesterday.. no leaks that i could find .. re-tightened all the rings and hoses. took off TMIC and re-tightened everything also. Thinking it could be something electrical.. besides the spark plugs/wires. it could be the coil pack :s

Ohhhh the fun never ends.
wookieda is offline   Reply With Quote
Old 11-16-2012, 04:46 PM   #7
AliBenn
NASIOC Supporter
 
Member#: 487
Join Date: Nov 1999
Chapter/Region: TXIC
Location: Greatwood/Sgrlnd
Vehicle:
1998 /2005 STunIcorn
Acadia Green RS-T

Default

as an insurance adjuster i will tell you this:
-the cracked lip looks too low to be Wylie E. himself.
-there is always blood/fecal matter/fur left behind.......unless you wash the car for some reason
GL
AliBenn is offline   Reply With Quote
Old 11-16-2012, 09:18 PM   #8
wookieda
Scooby Newbie
 
Member#: 326265
Join Date: Jul 2012
Vehicle:
1996 GF8 WRX STI

Default

Quote:
Originally Posted by AliBenn View Post
as an insurance adjuster i will tell you this:
-the cracked lip looks too low to be Wylie E. himself.
-there is always blood/fecal matter/fur left behind.......unless you wash the car for some reason
GL
I'm here to get opinions on my rough idling issue, not about your professional opinion on rahter i hit an animal or not. it was a small coyote/stray dog and i have taken enough photos and record of calling police and calling my insurance company on the spot to worry about the claim.

and i was not speeding to hit the thing and explode it all over my car.

http://img856.imageshack.us/img856/9920/641n.jpg

wookieda is offline   Reply With Quote
Old 11-17-2012, 03:12 PM   #9
paulpat
Scooby Specialist
 
Member#: 237145
Join Date: Feb 2010
Chapter/Region: SCIC
Location: 562
Vehicle:
02 WRX
12 FXT

Default

Homer simpson voice: ugggggghhhhhhm. Dinnnnnnneeeerrrrrr
paulpat is offline   Reply With Quote
Old 11-18-2012, 09:54 PM   #10
sonicwrxpa
Scooby Newbie
 
Member#: 148111
Join Date: May 2007
Chapter/Region: MAIC
Location: central pa.....amish country..
Vehicle:
2003 wrx
sonic yellow

Default

Yeah, I have been unlucky enough to hit a large dog, deer, and small bear all with my suby. :-((( The only animal trace left was hair from the deer that was stuck In the seal of my tire/rim. No blood at all.

Check for lose vac lines or maybe just clean your iacv. Could just be dirty and have nothing to do with the coyote.
sonicwrxpa is offline   Reply With Quote
Old 11-19-2012, 09:12 AM   #11
bplumley70
Scooby Newbie
 
Member#: 330040
Join Date: Aug 2012
Location: herkimer ny
Vehicle:
2003 wrx
wrb

Default

i hit a deer last year. knocked my timing chain off a notch. i dont know how it was possible but it did indeed mess with the idle. something to check out
bplumley70 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.