Welcome to the North American Subaru Impreza Owners Club Tuesday November 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-12-2012, 09:17 PM   #1
jdm_palomino
Scooby Newbie
 
Member#: 335755
Join Date: Oct 2012
Chapter/Region: TXIC
Location: houston tx
Vehicle:
2005 Wrx Hybrid
PSM

Default misfire issue... help?

I have changed all spark plugs and switched around the coil for cylinder #4 and I keep getting a cel for cylinder 4 misfire, it stays on and sometimes it flashes. What could cause this?
jdm_palomino is offline   Reply With Quote
Old 12-12-2012, 09:36 PM   #2
chris07sti
Scooby Newbie
 
Member#: 177312
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Manhattan, KS
Vehicle:
2005 STI
Aspen white

Default

this has been covered a lot. Have you done a compression and leakdown test? can also be injector. Fuel, Spark, rings...try and search there is a lot of info.
chris07sti is offline   Reply With Quote
Old 12-19-2012, 12:14 PM   #3
tekhnogod
Scooby Newbie
 
Member#: 250957
Join Date: Jul 2010
Location: Boston
Vehicle:
2008 Impreza Outback

Default

Hi,

I have a 2008 Subaru Impreza Outback Sport with 94k miles (have always done oil change, 30k and 60k service on time). The check engine light started to blink while I was driving. Within .5 mile, I was dead in the water. I towed it to my Subaru dealership and they said the sparkplugs (100k mile life expentancy) failed which caused the coils and spark plug seals to break. After they performed the work, the car still will not run. The speculate that its the right cylinder head that needs to be replaced but will have to charge $700 just to diagnose the problem. What do you think is going on? It sounds like we have a similar. Thanks.

Note: I know little about cars so I'm desparately seeking advise.
tekhnogod is offline   Reply With Quote
Old 12-19-2012, 02:43 PM   #4
CRAZYHAWK
Scooby Specialist
 
Member#: 198067
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: RAMSEY, NJ
Vehicle:
2009 IMPREZA 2.5i 4d
WHITE Premium

Default

What code did they get?

Does the engine turn over when trying to start?

Spark plugs should last between 30K and 60K.
CRAZYHAWK is offline   Reply With Quote
Old 12-19-2012, 03:34 PM   #5
tekhnogod
Scooby Newbie
 
Member#: 250957
Join Date: Jul 2010
Location: Boston
Vehicle:
2008 Impreza Outback

Default

After the new spark plugs were installed and everything. They told me that the computer read out is good. However, the car still will not start.

They told me that the spark plugs were platinum tipped so it should last 100k miles.
tekhnogod is offline   Reply With Quote
Old 01-03-2013, 05:14 PM   #6
GigglesTheBugeye
Scooby Newbie
 
Member#: 309935
Join Date: Feb 2012
Default

This is what I am going by for mine. Good luck! http://forums.nasioc.com/forums/show...g+knock+sensor
GigglesTheBugeye is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.