Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-14-2012, 06:24 AM   #1
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default 2012 vs 2013 impreza issues

Is it just me or does it seem like the 2012s have more issues? granted - I know they've had an additional year but every time I see a thread with multiple people having a problem I try to scan over it to see if someone with a 2013 is affected. it seems like so far they aren't. have you guys noticed this? it makes me cautiously optimistic that I won't have squeaky seat, oil consumption, crazy rattles or popping noises, etc.
M45 is offline   Reply With Quote
Old 12-14-2012, 06:42 AM   #2
Guzzi 1
Scooby Newbie
 
Member#: 338666
Join Date: Nov 2012
Chapter/Region: MWSOC
Location: Northeast Ohio
Vehicle:
2013 Impreza Premium
Dark Grey Metalic CVT

Default

I've wondered the same thing myself. After reading the oil threads, I have kept an eye on mine. So far, (knock on wood), the level is at the top of the marks with about 2000 miles on the car since new. Also, I have read where people are not happy with the performance. It's hard to tell if they are just expecting more or what. Going from a WRX myself, I was expecting less. I have been pleasantly suprised that it is better than I expected. Of course it is not the WRX, but that was not what I was going for this time around.

Sqeeks and rattles are one thing, which I'm happy to say I have not has so far. I can't help but wonder if the VVT has been changed, either electronically or with cam profile, or any other puter controled system, such as how the CVT reacts. Short of comparing part numbers, puter maps, or inside knowlege, that may remain a mystery.

Even using the remote start system several times a week has not had a terrible impact on fuel economy. 10 miles one way for work is my routine. Even with warm up time, I'm still above 30mpg, and it is soooooooo nice to get into a warm car!

John
Guzzi 1 is offline   Reply With Quote
Old 12-14-2012, 01:17 PM   #3
PuyallupCoug
Scooby Newbie
 
Member#: 337092
Join Date: Nov 2012
Location: Kirkland, WA
Vehicle:
2013 Impreza SLTD 5d
DGM

Default

Quote:
Originally Posted by Guzzi 1 View Post
I've wondered the same thing myself. After reading the oil threads, I have kept an eye on mine. So far, (knock on wood), the level is at the top of the marks with about 2000 miles on the car since new. Also, I have read where people are not happy with the performance. It's hard to tell if they are just expecting more or what. Going from a WRX myself, I was expecting less. I have been pleasantly suprised that it is better than I expected. Of course it is not the WRX, but that was not what I was going for this time around.

Sqeeks and rattles are one thing, which I'm happy to say I have not has so far. I can't help but wonder if the VVT has been changed, either electronically or with cam profile, or any other puter controled system, such as how the CVT reacts. Short of comparing part numbers, puter maps, or inside knowlege, that may remain a mystery.

Even using the remote start system several times a week has not had a terrible impact on fuel economy. 10 miles one way for work is my routine. Even with warm up time, I'm still above 30mpg, and it is soooooooo nice to get into a warm car!

John
You're lucky. My 2013 has 450 miles on it and I'm still at 21.3 mpg for a 5 mile commute. Theres been about 150 of the miles via freeway yet my MPG is still horrible. I drive like a grandma too...
PuyallupCoug is offline   Reply With Quote
Old 12-16-2012, 08:58 AM   #4
LGA2011
Scooby Newbie
 
Member#: 321173
Join Date: May 2012
Default

Quote:
Originally Posted by PuyallupCoug View Post
You're lucky. My 2013 has 450 miles on it and I'm still at 21.3 mpg for a 5 mile commute. Theres been about 150 of the miles via freeway yet my MPG is still horrible. I drive like a grandma too...
I have 16mpg on average in my center dash.

I admit it would have been horrible with any car. The main driver is not very fuel efficient, since I have been able to reach the EPA rating while driving it from point A to point B.

When the oil temperature is below 60 degree, the MPG is really bad since the idle engine speed is higher, once it get around 70 degree celsius the engine stick at 1.5k RPM at 30mph.

Canadian higher trim have oil temp.
LGA2011 is offline   Reply With Quote
Old 12-14-2012, 08:44 AM   #5
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

I think they did a pretty good job making the car feel a little more powerful than it is.

I too have been checking my oil and I'm a little above the full mark so far. Again this is less than 2000 miles though so it's probably too early to know if I'll have an oil consumption issue.

I'm surprised you are getting 30 MPG with that commute and letting the car idle. seems pretty good. I'm generally around 26-28 MPG b/c my commute is only about 3.5 miles one way. I did manage over 36 MPG on a 30 min drive that included some highway and back roads by taking it easy on the gas. So the MPG numbers are possible - you just have to keep it at 65 mph and under.
M45 is offline   Reply With Quote
Old 12-14-2012, 08:52 AM   #6
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Albany NY
Vehicle:
2012 Sport 5MT
Green/Silver

Default

the main problem between the 12's and the 13's is that they discontinued the two-tone color so no one else can get one that looks like mine anymore.

Teal/silver two-tone rocks. The black/gray was nice as well, but harder to clean.
Zeeper is offline   Reply With Quote
Old 12-14-2012, 09:01 AM   #7
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

Quote:
Originally Posted by Zeeper View Post
the main problem between the 12's and the 13's is that they discontinued the two-tone color so no one else can get one that looks like mine anymore.

Teal/silver two-tone rocks. The black/gray was nice as well, but harder to clean.
yeeeaaaahhhh

M45 is offline   Reply With Quote
Old 12-14-2012, 09:50 AM   #8
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

One possibility is that there aren't as many 13's out there with lots of miles yet.
But you are right, first-year production usually yeilds more problems.
My concearn is that they may be so jazzed about sales figures that qc could be slipping.
Hopefully for consumers the kinks have been worked out of the 13's.
The oil consumption, I doubt has been "fixed" as no one seems to know what its coming from, and its affected random fb and fa engines starting with the 11 forester.
79letour is offline   Reply With Quote
Old 12-14-2012, 10:17 AM   #9
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2013 Impreza2.0i CVT
DGM (sedan)

Default

Seat squeak: check!
Infrequent difficulty in starting: check!
Oil consumption: the jury is still out, but I'm certainly monitoring it closely.

Then again, mine has an early production date. So some of the issues might have been fixed for those of you who ordered yours.
lymphomaniac is online now   Reply With Quote
Old 12-14-2012, 10:22 AM   #10
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

Quote:
Originally Posted by lymphomaniac View Post
Seat squeak: check!
Infrequent difficulty in starting: check!
Oil consumption: the jury is still out, but I'm certainly monitoring it closely.

Then again, mine has an early production date. So some of the issues might have been fixed for those of you who ordered yours.
I did have a hard start once but since then no problems. I'm not sure when my car was actually manufactured. I bought it in September or early October I think. It had just arrived on the lot.
M45 is offline   Reply With Quote
Old 12-14-2012, 10:35 AM   #11
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Albany NY
Vehicle:
2012 Sport 5MT
Green/Silver

Default

I think the only difference between the 12's and 13's is that some '12 owners had to bring their car back to the dealer for software updates and a few 12's were delayed for them to replace the master cylinder.

Other than that, the sporadic problems are the same between both years, but there are a lot more '12 owners to discuss issues, many '13 owners still haven't taken delivery of their car.

Last edited by Zeeper; 12-14-2012 at 10:40 AM.
Zeeper is offline   Reply With Quote
Old 12-14-2012, 10:48 AM   #12
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

Quote:
Originally Posted by Zeeper View Post
Other than that, the sporadic problems are the same between both years, but there are a lot more '12 owners to discuss issues, many '13 owners still haven't taken delivery of their car.
I'm not sure we can really say that yet if the sample size is small. I know the design hasn't really changed but some manufacturing bugs may have been worked out.
M45 is offline   Reply With Quote
Old 12-14-2012, 10:45 AM   #13
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

check by the door, black tag will tell you manufacture date.
aeoporta is offline   Reply With Quote
Old 12-14-2012, 01:52 PM   #14
mrbloink
Scooby Newbie
 
Member#: 333058
Join Date: Sep 2012
Default

Just hit 3500 in my '13 no issues so far *knock on wood* I average 31.2 MPG. I have a 5mt. 48 mile commute
mrbloink is offline   Reply With Quote
Old 12-14-2012, 03:22 PM   #15
Piper
Scooby Newbie
 
Member#: 32242
Join Date: Jan 2003
Chapter/Region: NWIC
Location: Jet City
Vehicle:
2013 Impreza
Sport Limited DGM

Default

Quote:
Originally Posted by mrbloink View Post
Just hit 3500 in my '13 no issues so far *knock on wood* I average 31.2 MPG. I have a 5mt. 48 mile commute
Same here - no real problems on my 2013 Sport. Hard start has shown its head a few times, but I now wait a couple of seconds before turning the car over from the on position. Seems to work as the issue has not come back. 2000 miles on the OD and oil level is still shows full. Get a rattle once in a while, but mainly on really cold mornings. Once the car heats-up it goes away. 12 mile (on way) commute and getting 26 MPG. Did see 31+ MPG once, but that was on a 100+ mile trip.
Piper is offline   Reply With Quote
Old 12-14-2012, 03:30 PM   #16
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2013 Impreza2.0i CVT
DGM (sedan)

Default

One thing that I forgot to mention: I do get the odd "cheap plastic heat-expansion" type snapping noises coming from the console area (where all the HVAC controls are), especially as my car warms up on cold days. Never had that with my '01 Integra until very late in its life (perhaps the few winter months before the accident).

Annoying? Yes.
Worrisome? A bit.
Am I going to do anything about it? I'm too lazy.
lymphomaniac is online now   Reply With Quote
Old 12-14-2012, 03:56 PM   #17
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

i don't think they really changed anything between the late 2012s and the 13's
flyboy1100 is offline   Reply With Quote
Old 12-15-2012, 01:24 PM   #18
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by flyboy1100 View Post
i don't think they really changed anything between the late 2012s and the 13's
I have a late 2012 (arrived at dealership mid-June 2012). Slight seat squeak, but not enough to bother me. If it gets worse, I'll get the Tech Bulletin solution installed. No other squeaks/rattles. No oil consumption. Only had a hard-start situation once.

Now that I've installed a Wheelskin leather wrap on my steering wheel (the groove molded into the plastic wheel **really** bothered me), a Subaru leather shift knob, and a Pioneer head unit with satellite radio receiver, I'm really liking the car a lot.
sgoldste01 is offline   Reply With Quote
Old 12-15-2012, 12:17 AM   #19
hi5.0
Scooby Newbie
 
Member#: 340456
Join Date: Dec 2012
Location: Honolulu, Hawaii
Vehicle:
2013 Impreza

Default

Have a 2013 5-door. Have rattle/buzzing sound around the front door panel/B-pillar trim area. Also note some "plastic expansion/contraction" noises in the HVAC area when using AC or heater.
hi5.0 is offline   Reply With Quote
Old 12-15-2012, 10:16 AM   #20
alphaproject
Scooby Newbie
 
Member#: 147588
Join Date: Apr 2007
Default

A guy over here paid so low for a 2012 Impreza at a recent auction...I about crapped my pants. He said it was burning oil and he only had it a week...turned around and make a quick 2x profit on it here in south florida.

He also said there were 2 Sti's for really cheap with alot of miles...but he felt they don't sell that fast in florida.. I was like...REALLY? According to the website I go to...this one.... someone would have bought all the Subbies like that.

I saw the 2013 in person the other day...why are they getting uglier and uglier may I ask? I feel like they reserve the style to the WRX which didn't use to be the case. Sure the WRX and Sti always looked better...however.. the base models really look vanilla now to the point that I wouldn't even want one in place of our 2007 2.5i base model, no joke. I don't know what car I would want to replace our 2007 Impreza but it's certainly not the 2012-2013 models...they are just so dang ugly. Anyone agree?
alphaproject is offline   Reply With Quote
Old 12-15-2012, 10:54 AM   #21
stevehnm
Scooby Specialist
 
Member#: 329526
Join Date: Aug 2012
Chapter/Region: SWIC
Location: Ground Control
Vehicle:
2013 Impreza Spt cvt
Silver

Default

Quote:
Originally Posted by alphaproject View Post
I saw the 2013 in person the other day...why are they getting uglier and uglier may I ask? I feel like they reserve the style to the WRX which didn't use to be the case. Sure the WRX and Sti always looked better...however.. the base models really look vanilla now to the point that I wouldn't even want one in place of our 2007 2.5i base model, no joke. I don't know what car I would want to replace our 2007 Impreza but it's certainly not the 2012-2013 models...they are just so dang ugly. Anyone agree?
No, actually I like the look of our 5 door Impreza Sport. If it weren't for the abysmal mpg it would be a great car.
stevehnm is offline   Reply With Quote
Old 12-15-2012, 10:56 AM   #22
flamencoracer
Scooby Newbie
 
Member#: 35698
Join Date: Apr 2003
Chapter/Region: MWSOC
Location: Chicago, IL
Vehicle:
2011 WRX, '12 Sport
'00 Miata, Corvairs

Default

We're happy with our '12 Sport Limited CVT that we've had for a year. No problems. We do have the dash buzz when it's cold, but same as my previous '09 WRX and my current '11 WRX..... I wish Subaru would fix up that issue.

I'm definitely not crazy about leather seats, too slippery, and the moonroof cuts down the headroom. I like the seat/mirror heater, though.

We've gotten 37 on the highway once or twice, when driving at a steady 60.

From our experiences, the '12 (first model year for it) doesn't have any exceptional issues.
flamencoracer is offline   Reply With Quote
Old 12-15-2012, 04:18 PM   #23
nels0300
Scooby Newbie
 
Member#: 331332
Join Date: Sep 2012
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2013 Sport 5sp
DGM

Default

Quote:
Originally Posted by alphaproject View Post
I don't know what car I would want to replace our 2007 Impreza but it's certainly not the 2012-2013 models...they are just so dang ugly. Anyone agree?
The first generation and the 2012-2013 Imprezas are the only ones that aren't ugly IMO.
nels0300 is offline   Reply With Quote
Old 12-15-2012, 09:26 PM   #24
Guzzi 1
Scooby Newbie
 
Member#: 338666
Join Date: Nov 2012
Chapter/Region: MWSOC
Location: Northeast Ohio
Vehicle:
2013 Impreza Premium
Dark Grey Metalic CVT

Default

Quote:
Originally Posted by nels0300 View Post
The first generation and the 2012-2013 Imprezas are the only ones that aren't ugly IMO.
Of course it is all subjective, but I agree. I really liked my bug eye. I like what they did with the new ones. The ones in the middle, not so much. But hey, the world would be a pretty dull place if we all liked the same thing.

On another note,I did a road trip today from Northeast Ohio down to Columbus and back. I made a few discoveries. First, the speedo on my car is right on with the GPS. The odo is a little pesimistic. Over 303.2 GPS miles, the odo registered 298.7. Anyway, the other point of interest is that going down, I stuck the cruise at 5 over, running 70 most of the way. The tach is about 2200 rpm. Dash mileage going down showed 35.4 avg. mpg. Coming home, I set the cruise at 65 running the motor at 2000 rpm. That seems to be a magic number as the reading continued to climb all the way home. Upon hitting the gas station, I had 37.8 mpg average. Since I had a few miles on the tank prior to departing, I used the actual distance on the tank and came up with 36.43 mpg. That was 322.3 actual miles using 8.845 gallons. I guess I should have gone 65 on the way down too. These readings were on the trip B, (the 35.4 and 37.8) which were a direct comparison to the GPS. Trip A was when I refueled the other day. Once I figured out the discrepency on the odo, I used that percentage to calculate the actual mileage on the tank, which is where the 36.43 came from. I can say however that the estimate the dash is displaying is pretty accurate for my particular car when I compare it to GPS numbers.

It would appear that keeping the rpm @ 2 grand will take you farther than running it higher. To go 5 mph faster would have only shortened the trip by 15 minutes or so one way so no biggie there. Not to mention that our state police were working hard today giving out performance evaluations.

Another item I have noticed, which I had mentioned elsewhere, was that certain fuel gives me better results. The local BP is good for a 3 mpg reduction over a local Get Go. (Get Go is associsted with a grocery store.) I would have expected that to be the other way around. In any event, fuel blends can not only be different from region to region but even locally. (I know when I hit the Plains states on the motorcycle my mileage goes down the tubes with the corn gas.) Anyway, it might be worth experimenting locally to find what takes you the farthest.

John
Guzzi 1 is offline   Reply With Quote
Old 12-18-2012, 03:31 AM   #25
Xarthan
Scooby Newbie
 
Member#: 312318
Join Date: Mar 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 Impreza Sport
ISM

Default

Quote:
Originally Posted by alphaproject View Post
I don't know what car I would want to replace our 2007 Impreza but it's certainly not the 2012-2013 models...they are just so dang ugly. Anyone agree?
You are asking in a thread where the majority own 12/13 models if they find their car that they paid for is ugly?

Where's the logic in that?
Xarthan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.