Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-08-2013, 08:25 AM   #1
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default Stage 2 WRX transmission problems?!

Hey guys i had a question about whats going on with my 2012 stage 2 WRX. it happens when cornering under hard acceleration and also when i punch the gas in first or second lastly It seems when i floor it in either 2nd or 3rd and let off at about 5.5k RPMS, it feels like my transmssion shakes and clunks?! i can feel the tranny or motor like clunk back and forth. its only 1 or 2 big clunks and it makes you cringe because it sounds awful haha. does this mean my transmission or motor cant hold the power of my stage 2? thoughts and suggestions would be awesome guys thank you!

Last edited by wrx_yfz; 08-09-2013 at 05:13 PM.
wrx_yfz is offline   Reply With Quote
Old 04-08-2013, 09:03 AM   #2
Tripintaz
Scooby Specialist
 
Member#: 245218
Join Date: Apr 2010
Chapter/Region: South East
Location: FL
Vehicle:
2013 STI Limited

Default

Are you pushing the clutch in when you let off that gas at that RPM? If not then DERP.
Tripintaz is offline   Reply With Quote
Old 04-08-2013, 10:47 AM   #3
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

I don't touch the clutch unless I'm shifting and if I'm shifting then i don't have this problem. It's only when I reach high RPM's and then let off the throttle.
wrx_yfz is offline   Reply With Quote
Old 04-08-2013, 11:19 AM   #4
FuJi K
Scooby Guru
 
Member#: 3687
Join Date: Jan 2001
Chapter/Region: MWSOC
Location: St. Paul, MN
Vehicle:
MY99 GF4 JDM 6spd
NF Performance

Default

You should inspect the tranny mounts, engine mount nuts.
FuJi K is offline   Reply With Quote
Old 04-08-2013, 11:52 AM   #5
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

Sense I do not know what I'm inspecting should I just get this looked at, at a auto shop?
wrx_yfz is offline   Reply With Quote
Old 04-08-2013, 01:00 PM   #6
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

I asked a similar question. My engine bucks hard if I let off the gas near redline, especially if its a partial let off. One big buck. I was told pitch stop. Upgrade that and maybe the stuff happen g to you will reduce or disappear.
some dude is offline   Reply With Quote
Old 04-08-2013, 01:20 PM   #7
Dave D.
Scooby Specialist
 
Member#: 130990
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Menzel Lake, WA
Vehicle:
06 Red Ltd.Wagon
I need a new tuner!

Default

Stock engine mounts. Upgrade them and you will have little if any bucking. It makes a huge difference, believe me.
Dave D. is offline   Reply With Quote
Old 04-08-2013, 01:35 PM   #8
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

Whats pitch stop? And Dave d did you have this similar problem or something?
wrx_yfz is offline   Reply With Quote
Old 04-08-2013, 01:46 PM   #9
RoadKillDMD
Scooby Specialist
 
Member#: 284792
Join Date: Jun 2011
Chapter/Region: RMIC
Location: Vanilla Valley, CO
Vehicle:
2011 STI
Blurple

Default

Quote:
Originally Posted by wrx_yfz View Post
Whats pitch stop? And Dave d did you have this similar problem or something?
http://bit.ly/Z3UaOl
RoadKillDMD is offline   Reply With Quote
Old 04-08-2013, 03:22 PM   #10
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

is this a serious issue? are my motor mounts likely to break or can i ignore this?
wrx_yfz is offline   Reply With Quote
Old 04-08-2013, 04:21 PM   #11
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Its probably only serious if they break and you don't replace them. Probably not very serious to break one, just don't make a habit of it or anything. Look under your intercooler. There should be a brace there connected to the firewall. That is the pitch stop.
some dude is offline   Reply With Quote
Old 04-08-2013, 08:33 PM   #12
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

alright cool i appreciate the help ill look into getting a new pitch stop/tranny/motor mounts!
wrx_yfz is offline   Reply With Quote
Old 08-09-2013, 05:03 PM   #13
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

hey guys im still worried about this clunking noise. I brought it to my local subaru dealership where i bought my car and i had the head mechanic look at my motor and transmission mounts, while i waited there for over 2 hours he came back and said that they were not stressed or in bad condition at all and that they looked fine. Does this mean that those are now out of the question now for being my problem? i want to get this fixed because i cant really do any spirited driving without worrying about the clunking noise.
wrx_yfz is offline   Reply With Quote
Old 08-09-2013, 05:06 PM   #14
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

i will try and explain the problem again in better detail. Its a hard clunk underneath my car i cant tell if its the motor and tranny but its a heavy clunk. the noise can happen almost at any range in the rpms for Ex.) if im in first gear i can punch the throttle for a second to bring the rpms to like 3-4 and let of quickly and it will clunk. going around corners in high RPMs it will clunk, letting off the gas at high rpms to slow down without the break it will clunk as well. just trying to put as much detail as possible. Looking for some help here, i dont want to buy the mounts and have that not fix the problem. thanks guys
wrx_yfz is offline   Reply With Quote
Old 08-12-2013, 12:26 AM   #15
EnlightenedOne
Scooby Newbie
 
Member#: 278744
Join Date: Apr 2011
Chapter/Region: NWIC
Location: Rogers, Arkansas
Vehicle:
06 WRX
WRB

Default

Like the previous people have said, replace the motor mounts and possibly the pitch stop. I have the same issue except this is on an 06 wrx. Saving up to get those parts. Let us know how everything turned out once you have replaced those parts
EnlightenedOne is offline   Reply With Quote
Old 08-12-2013, 07:32 AM   #16
JonnyV2889
Scooby Specialist
 
Member#: 197384
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MWV NH
Vehicle:
2006 WRX Ltd
OBP

Default

Quote:
Originally Posted by wrx_yfz View Post
i will try and explain the problem again in better detail. Its a hard clunk underneath my car i cant tell if its the motor and tranny but its a heavy clunk. the noise can happen almost at any range in the rpms for Ex.) if im in first gear i can punch the throttle for a second to bring the rpms to like 3-4 and let of quickly and it will clunk. going around corners in high RPMs it will clunk, letting off the gas at high rpms to slow down without the break it will clunk as well. just trying to put as much detail as possible. Looking for some help here, i dont want to buy the mounts and have that not fix the problem. thanks guys
Mounts won't hurt. I heard a lot of people have issues with rear diff clunk. Is it right under you or behind you?
JonnyV2889 is offline   Reply With Quote
Old 08-28-2013, 03:21 PM   #17
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

Quote:
Originally Posted by JonnyV2889 View Post
Mounts won't hurt. I heard a lot of people have issues with rear diff clunk. Is it right under you or behind you?
It sounds like its right under me. are people having problems in their newer subies? mines an 12'
wrx_yfz is offline   Reply With Quote
Old 08-28-2013, 04:55 PM   #18
dan2510
Scooby Newbie
 
Member#: 305615
Join Date: Jan 2012
Location: IL
Vehicle:
2013 WRX Limited Sdn
SWP

Default

Let me know how this works out...I'm thinking about doing the same to my '13 WRX.
dan2510 is offline   Reply With Quote
Old 08-12-2013, 08:54 AM   #19
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Quote:
Originally Posted by wrx_yfz View Post
Hey guys, I had a question about whats going on with my 2012 stage 2 WRX. It happens when cornering under hard acceleration and also when I punch the gas in first or second.

Lastly, it seems when I floor it in either 2nd or 3rd, and let off at about 5.5k RPMS, it feels like my transmssion shakes and clunks?! I can feel the tranny or motor like clunk back and forth. Its only 1 or 2 big clunks and it makes you cringe because it sounds awful haha.

Does this mean my transmission or motor cant hold the power of my stage 2?

Thoughts and suggestions would be awesome guys thank you!
Problem:
OEM Liquid-filled engine mounts, and a soft-durometer rubber for both the engine mounts and the transmission mount.

Solution:
Replace with Subaru Group-N engine mounts and transmission mount.

Buy parts package from TiC: http://turninconcepts.com/product_in...oducts_id=1083

PS: I'm not 'guessing' on this one, or 'think I know'; I do know.
Big-E is offline   Reply With Quote
Old 08-28-2013, 03:20 PM   #20
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

Update: Bought a STI Group N Transmission mount and a Kartboy pitchstop ill update you guys to see if those have stopped the problem after i install them.
wrx_yfz is offline   Reply With Quote
Old 09-06-2013, 09:37 PM   #21
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

Update:
i installed a new Transmission mount/ pitchstop/ shifter bushings and all the clunking has gone away and the car is so much more responsive and quicker and is a lot faster, the only think is that the NVH is very bad. i can hear so many random noises here and there and i dont know if its normal or not.
wrx_yfz is offline   Reply With Quote
Old 09-09-2013, 11:02 AM   #22
subezero
Scooby Newbie
 
Member#: 207614
Join Date: Apr 2009
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2008 WRX 5dr
SSM

Default

Perfectly normal. I doubt the car is any faster, but absolutely more responsive. Enjoy that feeling, you won't be able to stop replacing soft bushings and mounts now!
subezero is online now   Reply With Quote
Old 09-17-2013, 01:00 AM   #23
wadowrx
Scooby Specialist
 
Member#: 343621
Join Date: Jan 2013
Chapter/Region: MWSOC
Location: NW Indiana
Vehicle:
2012 Impreza WRX
Dark Metallic Gray

Default

I have some Group N engine mounts for sale!
But seriously, I upgraded to the Group N transm ount and the Torque Solutions pitch stop mount and 90% of my "bucking" issues are gone.
wadowrx is offline   Reply With Quote
Old 09-17-2013, 08:06 PM   #24
wrx_yfz
Scooby Newbie
 
Member#: 345962
Join Date: Feb 2013
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2012 WRX Sedan
WRB

Default

i fixed the NVH problems it was a couple things rubbing like the heatshield.
wrx_yfz is offline   Reply With Quote
Old 10-02-2013, 04:27 AM   #25
Nunogolos
Scooby Newbie
 
Member#: 369855
Join Date: Oct 2013
Default

check clutch
Nunogolos is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.