Welcome to the North American Subaru Impreza Owners Club Saturday October 22, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 06-25-2013, 04:12 PM   #1
Scooby Newbie
Member#: 176983
Join Date: Apr 2008
Chapter/Region: SCIC
Location: OC
2003 Wrx

Default Clutch prob. bad sign?

Hi guys been having a problem for a while and finally got tired of it and trying to fix now. my clutch only comes back up part way after i push it down. First thing i tried is bleeding the system. Didnt work. second, i replace the slave cylinder and bled again. same result. No leaks around the master or anywhere i can see. But i found this under my clutch pedal inside when took a peek.

what can leak in there like this?

car: 03 wrx 108k miles.
stock trans etc.
chuchu_rocket is offline   Reply With Quote
Old 06-27-2013, 06:32 AM   #2
Aaron'z 2.5RS
Scooby Guru
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
'00 RS/WRX Stg5
'98 RS Stock


Really strange but id say the clutch master cylinder went
Aaron'z 2.5RS is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:22 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.