Welcome to the North American Subaru Impreza Owners Club Thursday November 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-24-2001, 09:40 AM   #1
Revision
Scooby Guru
 
Member#: 242
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Carol Stream, IL USA
Vehicle:
MY05 PSM GGA !STOCK
MY99 RS-RIP / MY95 MX-5

Post Rallispec Intake (review 14k miles)

Well, after @14k miles and 6 months I figured it was time to clean the Rallispec intake. For reference, I have a MY99 with the Apexi SAFC and Stromung midpipe. I have experience NO check engine lights or other failures of any kind. The spare MAF is for reference only. The spark plugs all came out clean with the exception of #4 which is part of another post.


Here we have a shot of the Pipercross cone filter & MAF along side a New In/Out of Box MAF.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856165&Sequence=0&Sc ale=320x200" border=0>

Here is a comparision of the insides of the new and used MAFs. Note there was no dirt to be found inside the MAF. There was some dust on wire mesh, which was neglegible.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856172&Sequence=0" border=0>

Washing the foam filter element with Simple Green and luke warm water.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856182&Sequence=0&Sc ale=320x200" border=0>

A lot of dirt came out of the filter which took repeated washings before the water finally came clean.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856184&Sequence=0&Sc ale=320x200" border=0>

All shiny and new. I let this air dry and didn't oil as per RalliSpec's specs.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856191&Sequence=0&Sc ale=320x200" border=0>

Here is the tube side of the intake. There were some minor scratches on the inside which were noted, but no dirt whatsoever. Even after passing several shop towels through the tube, nothing was found.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856236&Sequence=0" border=0>

Here is the installed intake in a new direction. I think I may have just scared some people.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856239&Sequence=0" border=0>


For some reason, this mounting position just doesn't seem to work. Even though it seems that the intake could be fitted through the hood scoop.
<IMG SRC="http://albums.photopoint.com/j/View?u=1155221&a=11755957&p=41856242&Sequence=0" border=0>

So far, I am very happy with the intake. No dirt has come through even with the dusty summer and the salty winter here in Chicago. Maintainance is a snap. Power delivery remains good and the sound quality, though sometimes loud at WOT, is worth it.
Revision is offline   Reply With Quote
Old 02-24-2001, 10:31 AM   #2
M a t t
Guest
 
Member#:
Post

hehe, that looks funny.
  Reply With Quote
Old 02-24-2001, 10:33 AM   #3
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Wink

I have to say your car looks *very* happy you cleaned the filter. Maybe too happy, I think you should wash it with some very cold water soon.



[This message has been edited by Peaty (edited February 24, 2001).]
Peaty is offline   Reply With Quote
Old 02-24-2001, 11:59 AM   #4
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
04 FXT
Red

Post

The pics of the original install - http://8complex.mwic.org/rallispec_intake/
8Complex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STI springs from Rallispec... any reviews? SCRAPPYDO Brakes, Steering & Suspension 1 01-03-2003 02:02 PM
Rallispec Intake for MY99RS tmaler13 Normally Aspirated Powertrain 2 06-13-2001 09:53 PM
Installed Rallispec intake whiteblur New England Impreza Club Forum -- NESIC 6 05-17-2001 09:09 PM
Installed Rallispec intake whiteblur New England Impreza Club Forum -- NESIC 0 05-17-2001 11:02 AM
Rallispec MY00 Intake review (kinda long) Basil Technical Forum Archive 5 07-22-2000 10:17 PM


All times are GMT -4. The time now is 07:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.