Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-18-2003, 07:04 PM   #1
BajaNut
Scooby Specialist
 
Member#: 36905
Join Date: May 2003
Chapter/Region: BAIC
Location: Kirkland, WA
Vehicle:
2014 Outback SAP
leggtnut on lgt.com

Default Idle question on my MY90 legacy sedan L

Hello all,

In my MY90 Legacy Sedan L, I just had the Alternator replaced because it went out and now when I am Idleing, not all the time, the Idle drops down to about 500rpm's and sometimes it drops so low that it is stalling the car. Should I take the car back to the place that I had the alternator done, or could this be a compleatly different issue?

Thank you,

Ben
BajaNut is offline   Reply With Quote
Old 06-18-2003, 07:11 PM   #2
legacy2003
Scooby Specialist
 
Member#: 38338
Join Date: Jun 2003
Chapter/Region: MAIC
Location: Washington, DC Metro
Vehicle:
2003 Outback Sdn H6
Black

Default

might be the battery. my alternator went in my 95 and obviously the battery ended up dying. put a new alternator in and had sort of the same problem. replaced the battery and everything was golden. so check on that.

-mike
legacy2003 is offline   Reply With Quote
Old 06-18-2003, 07:17 PM   #3
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

Ignoring the alternator replacement Id say without a doubt its a sticking Idle Air Controller.

Does the Idle bounce when its cold in the morning?

With the car off and the headlights on are they a reasonable brightness? Even with the alternator disconnected the car should be able to idle just fine if the battery is okay. The other way around too, if the battery is near dead the car should be able to run when the alternator is providing power (without the headlights, brakelights or rear defrost on).
ciper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle Question on 2000 OBS Richard1296 Normally Aspirated Powertrain 0 12-11-2006 08:42 PM
wrx springs/struts on installed on a 95 legacy sedan emyselfandi Brakes, Steering & Suspension 0 03-23-2005 10:25 PM
Uneven idle problem on my snowblower nitrohuffer Off-Topic 11 01-12-2005 04:15 PM
Just picked up my 2004 Legacy Sedan Diabolical1 CC Legacy Forum 3 07-25-2004 10:08 AM
Mirror tint -- here's a couple pics on my silver Legacy GT sedan... JSiwek Interior & Exterior Modification 6 02-25-2002 03:48 PM


All times are GMT -4. The time now is 09:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.