Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-23-2003, 12:39 AM   #1
Boost4U
Scooby Specialist
 
Member#: 16459
Join Date: Mar 2002
Location: Montreal
Vehicle:
1998 2.5RS
WRB

Default Gas smells!

Here is my problem...

I just installed a TEC-2 on my EJ205 swap....I jumped the relay for the fuel pump to check the Vishnu rails and hoses for leaks......I couldn't find any. At least until gas started dripping out the gasket between the two sections of the exhaust manifold. I pulled the plugs, and they were very wet!! Somehow gas was injected into the cylinder.....the car was not power up, the Tec-2 was not powered. I should also say that the fuel system is setup with a Malpassi FPR, Vishnu rails, and 550cc RC injectors. The system is connected in parallel with the 2 return feeding into the 2 barbs on the regulator and then back to the fuel tank. I used my compressor to simulate fuel delivery under boost...about 20+ PSI. Only one side of the engine flooded with fuel.... Anyone have any ideas why this would happen? And why only on one side?

-Chris

Last edited by Boost4U; 12-23-2003 at 06:13 PM.
Boost4U is offline   Reply With Quote
Old 12-23-2003, 06:14 PM   #2
Boost4U
Scooby Specialist
 
Member#: 16459
Join Date: Mar 2002
Location: Montreal
Vehicle:
1998 2.5RS
WRB

Default

This is confusing me!
Boost4U is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horrible Gas Mileage/Raw gas smell in cabin ScoobySnacker Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 12-18-2007 08:14 PM
2 newbie questions, Occasional gas smell and gas pipe wattpuppy Newbies & FAQs 0 10-31-2006 02:01 PM
gas smell TSB- repaired and still smelling it! SVX WRX Warranty Issues & SOA Problems 5 04-13-2004 08:33 PM
gas smell? tonic Newbies & FAQs 4 04-11-2001 11:53 AM
Exhaust gas smell in car... WRC666 General Forum Archive 5 03-03-2001 01:47 AM


All times are GMT -4. The time now is 09:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.