Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-21-2004, 10:31 PM   #1
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Exclamation help! piaa xt pro 80

i am having the worst time wit these fog lights.
i got them, installed them, and they worked for like a week.
today i opened the housing to check the bulbs and the bulbs are fine. now, i can't put the housing back together cuz these stupid lil brackets that the screws go into fell off and theyre on the inside of the housing! how am i supposed to screw them in place when they can only be secured to the screw from the outside?! damn! i wired my fog lights to the stock switch. when i press the switch i hear a click from the relay, but no power no lights! *** is going on. this is pissing me off, im about to buy stock foglights, this sucks. someone help meeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee eeeeeeeeeee!!!!!!!!!!!!
kAn9ArOo is offline   Reply With Quote
Old 03-21-2004, 11:50 PM   #2
BlkTS02
Scooby Specialist
 
Member#: 50142
Join Date: Dec 2003
Chapter/Region: South East
Location: West TN
Vehicle:
2002 2.5TS
MBP

Default

you'll need to remove the lens / reflector assembly to get the bracket for the screws. Read the directiona and it'll show you how to put them together (you don't remove the screws from the brackets, just loosen them enough so it'll slide together)

Did you use the stock wiring harness, or the one that came with the piaas?

Did you test the lights before finishing the install? Get yourself a test light and make sure that there's power from where you're trying to get it from. Start at the battery, trace along the power cord and check everything.

If all else fails pull it apart and start over.

Trust me, you're gonna love the lights, as well as everyone behind you. But anyone in front of you or coming towards you are gonna be blind
BlkTS02 is offline   Reply With Quote
Old 03-22-2004, 09:24 PM   #3
glepko
Scooby Newbie
 
Member#: 19651
Join Date: Jun 2002
Location: PA
Vehicle:
2002 WRX
Silver

Default

Quote:
Originally posted by BlkTS02

Trust me, you're gonna love the lights, as well as everyone behind you. But anyone in front of you or coming towards you are gonna be blind
With fog lights??? He's got some problems with aiming if that's the case, like most red americans
glepko is offline   Reply With Quote
Old 03-22-2004, 09:29 PM   #4
idealrides
Scooby Specialist
 
Member#: 10314
Join Date: Sep 2001
Location: St. Martin
Vehicle:
03 WRX 325hp SOLD!
06 Jeep SRT8 - 450hp

Default

the 80 XT comes in either fog or driving beam patterns. both will blind oncoming traffic, but the driving beam will actually burn their retinas.
idealrides is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PIAA 80-XT Pros brucelee Car Part Reviews 1 05-19-2007 03:13 AM
piaa xt 80 pro lens???! kAn9ArOo Electrical & Lighting 2 08-21-2006 07:44 PM
anyone with piaa xt 80 pros!! kAn9ArOo Electrical & Lighting 1 03-06-2004 08:00 PM
help! my piaa xt pro 80s kAn9ArOo Electrical & Lighting 10 01-27-2004 11:12 PM
anyone have piaa xt 80 pros? kAn9ArOo Electrical & Lighting 4 01-22-2004 10:26 AM


All times are GMT -4. The time now is 08:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.