Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-07-2004, 09:12 AM   #1
Silver04DE
Scooby Newbie
 
Member#: 57106
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Port Jeff Stn., NY Long Island
Vehicle:
2004 WRX Sedan(sold)
VF39, Protune

Default Help: Right turn signal flashing twice as fast...

Hey guys, I just completed the 04' Headlight mod removing the orange reflector lenses this weekend. i replaced the clear turn signal bulbs with the 7440 Titan bulbs by APC, silver that flash amber, ordered online. They appeared to be working correctly right after the mod. Now, a few days later, I noticed that the right turn signal is flashing atleast twice as fast as it should normally. The left blinker functions normally, and the hazards flash together normally as well. I tried a search, found some similar threads, but not quite an answer to the fix. Can someone please help? Thanks
Jon
Silver04DE is offline   Reply With Quote
Old 09-07-2004, 09:18 AM   #2
sixpack subaru
*** Banned ***
 
Member#: 64974
Join Date: Jun 2004
Location: My Shed, Melbourne, Australia
Vehicle:
1995 WRX,APEXi,HKS,$
Faded, Stonechipped Red

Default

Quote:
Originally Posted by Silver04DE
Hey guys, I just completed the 04' Headlight mod removing the orange reflector lenses this weekend. i replaced the clear turn signal bulbs with the 7440 Titan bulbs by APC, silver that flash amber, ordered online. They appeared to be working correctly right after the mod. Now, a few days later, I noticed that the right turn signal is flashing atleast twice as fast as it should normally. The left blinker functions normally, and the hazards flash together normally as well. I tried a search, found some similar threads, but not quite an answer to the fix. Can someone please help? Thanks
Jon
Hey,
Check your globes......if one has blown, the 'flasher can' will flash quicker..


Cheers,

Sixpack Subaru
sixpack subaru is offline   Reply With Quote
Old 09-07-2004, 10:43 AM   #3
Silver04DE
Scooby Newbie
 
Member#: 57106
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Port Jeff Stn., NY Long Island
Vehicle:
2004 WRX Sedan(sold)
VF39, Protune

Default

thanks for the reply. "globe" , is the same as bulb? Pretty sure nothing has blown, but i'll check today. I took my time, and special care to handle the bulbs with a fresh new clean pair of rubber gloves. I admit I know zero about the electrical aspect of my car. I'll check back here. Anyone else?
Silver04DE is offline   Reply With Quote
Old 09-07-2004, 10:48 AM   #4
skyhawk
Scooby Specialist
 
Member#: 36255
Join Date: May 2003
Location: Meridian Mississippi
Vehicle:
04 WRB WRX
Drive 2 Work,Work 2 Drive

Default

Yes, sixpack subaru is referring to the bulbs. If one is blown, that side will blink twice as fast. Also make sure the connector is locked on the bulb good and not loose.
skyhawk is offline   Reply With Quote
Old 09-07-2004, 12:42 PM   #5
chrisdeaner
Scooby Specialist
 
Member#: 24625
Join Date: Sep 2002
Chapter/Region: BAIC
Location: San Rafael, CA
Default

Ditto, that is almost always the problem. check all the bulbs on that side of the car (Front turn, side marker, rear turn) More than likely one blew...
-Chris
chrisdeaner is offline   Reply With Quote
Old 09-07-2004, 04:38 PM   #6
Silver04DE
Scooby Newbie
 
Member#: 57106
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Port Jeff Stn., NY Long Island
Vehicle:
2004 WRX Sedan(sold)
VF39, Protune

Default

Well, you guys were right... Damn this sucks. I wonder what caused the new turn signal bulb to blow? I assumed that it was identical wattage because so many members in the Sticky 04 headlight mod thread had used and recommended them. Honestly though, I can't even check because i threw
the package away. This is where i purchased them:

7440's

Anyone know for a fact that they are compatible or not? Should I seek an identical replacement? or should I order 2 totally different bulbs? Such a pain, because none of my local stores have them, and takes about a week to order and receive them in the mail. Suggestions??
thanks
Jon
Silver04DE is offline   Reply With Quote
Old 09-07-2004, 04:53 PM   #7
Ironlung
Scooby Newbie
 
Member#: 52121
Join Date: Jan 2004
Location: Centreville
Vehicle:
2004 WRX
WRB

Default

You probably just got a bad bulb, or maybe you touched the glass while putting in
Give the company a call, maybe they can just send you a replacement

Jeff
Ironlung is offline   Reply With Quote
Old 09-08-2004, 10:45 AM   #8
skyhawk
Scooby Specialist
 
Member#: 36255
Join Date: May 2003
Location: Meridian Mississippi
Vehicle:
04 WRB WRX
Drive 2 Work,Work 2 Drive

Default

I guess you wish you would have bought spares, I know you didn't expect them to last forever. Shouldn't have cost that much to not buy spares and you had to pay shipping anyway.
Sorry about your little problem.
skyhawk is offline   Reply With Quote
Old 09-08-2004, 02:38 PM   #9
chrisdeaner
Scooby Specialist
 
Member#: 24625
Join Date: Sep 2002
Chapter/Region: BAIC
Location: San Rafael, CA
Default

I'd call the place you got them and say you "know" you didn't touch the glass so it must've been a bad bulb...maybe they'll hook you up?
-Chris
chrisdeaner is offline   Reply With Quote
Old 09-08-2004, 05:14 PM   #10
Silver04DE
Scooby Newbie
 
Member#: 57106
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Port Jeff Stn., NY Long Island
Vehicle:
2004 WRX Sedan(sold)
VF39, Protune

Default

Well, actually Skyhawk, now I'm glad I hadn't ordered any extras of these particular bulbs. I'm pretty certain that the quality of these APC bulbs is not the greatest. After following the advice of some who posted above, and a response in the actual "sticky: 04 headlight mod" thread, I removed the malfunctioning bulb (again carefully not to touch any glass) and looked it over. The bulb seemed to be in perfect condition. I reinserted into the connector, and made sure it was firmly secure. I tried the signal again, and to my surprise it was working!!.... however only temporarily unfortunately. I went to check all the front lights, right turn, left turn, hazards... and once again from inside the dash the blinkers were flashing quickly and neither bulb was lighting up .. now on either side!! Now as i stated before, I'm certianly not an electrician, but I did take my time , and was careful to follow Skivvie's step by step guide to perfection. I will certainly contact cardomain/sounddomain.com , but don't really expect them to be of much help.
Silver04DE is offline   Reply With Quote
Old 09-09-2004, 09:06 AM   #11
skyhawk
Scooby Specialist
 
Member#: 36255
Join Date: May 2003
Location: Meridian Mississippi
Vehicle:
04 WRB WRX
Drive 2 Work,Work 2 Drive

Default

Sorry to hear that and thanks for the info on the quality.
skyhawk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast Turn Signal Handsdown Electrical & Lighting 15 12-03-2008 11:03 AM
Front Right Turning Signal Acting Up goldenej20child Electrical & Lighting 1 05-14-2007 12:21 AM
Where Can I Find A Silverish, Amber Flashing Turn Signal Bulb Three105 Interior & Exterior Modification 13 07-11-2006 07:03 PM
Weak, slow right turn signal H2OSB Electrical & Lighting 1 03-11-2005 01:21 AM
impreza front right turn signal lamp White 2.5rs Private 'For Sale' Classifieds 0 07-30-2003 02:28 PM


All times are GMT -4. The time now is 08:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.