Welcome to the North American Subaru Impreza Owners Club Friday November 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 07-15-2005, 12:08 AM   #1
Scooby Newbie
Member#: 83497
Join Date: Mar 2005
Location: Maryland
2002 WRX Wagon
World Rally Blue

Default surge in ej22t, Suggestions?

I have a 93 lgacy rs and every time the boost comes on the car shakes and surges, sometimes violently. both the engines power delivery and boost seem to jump around however the car is so jumpy many times the boost gauge cannot react fast enough to show much change. I have tried to fix it by:

replacing the bov with a turbosmart recirculating type.

substituting a manual boost controller for the stock electronic one(now stock again).

replaced hoses and checked endlessly for vacuum leaks.

I did find one very large vacuum leak (pre-turbo) but fixing this did virtually nothing. I also unplugged the battery to try to reset the ecu still nothing.

Has anyone heard of anything like this? does anyone have any suggestions?
monkeypaw76 is offline   Reply With Quote
Old 07-15-2005, 09:28 AM   #2
Scooby Newbie
Member#: 66331
Join Date: Jul 2004
Location: Boulder, Colorado

Check your plugs, you should be able to tell if your running too rich on boost. My car was doing that a week ago but i have a completely diff setup on my legacy and i just needed to lean out the fuel a little bit.
DamienX is offline   Reply With Quote
Old 07-15-2005, 11:36 AM   #3
Scooby Specialist
Member#: 42659
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Williamsport PA/SilvrSprngs MD
92 Legacy turbo5mt
All go and no show...


Do you get a CEL when this happens? If so, pull the codes.

I had a problem kind of like that once and it was because I had a loose vacuum line to the MAP sensor. Under heavy boost it was coming loose at the sensor. Tie strapped it and never had it happen again.
legacy92ej22t is offline   Reply With Quote
Old 07-16-2005, 10:40 PM   #4
Scooby Specialist
Member#: 14141
Join Date: Jan 2002
Location: 13.239@102.85 @ 5800 ft on 13T
2002 Impreza WRX


what turbo are you running. If your getting true compressor surge on the turbo, than you need to lower your boost settings or change the settings so the boost builds slower. Compressor surge means the turbo is building more boost than it can support at that engine rpm ( usually poorly matched turbo and engine combination ).

If it is not due to compressor surge you could be having fuel or ignition issues.

It would help with a bit more info about your setup (how close to stock are you), and the circumstances where you see the surging. If your getting any CEL you need to get that code pulled and come back to the forum with that info.

hotrod is offline   Reply With Quote
Old 07-19-2005, 03:43 PM   #5
Scooby Specialist
Member#: 67229
Join Date: Jul 2004
Location: SLC
9295 BC/gm6
winestone/funky blue


sounds like hesitation to me. sruge is more of a noise than it is a violent jerck and it doesnt happen when you get on it. do a tune up, replace your plugs and wires, be sure not to use auto lite. use ngk and what ever your local autozone shucks kragen checker has for wires. borg warner works pretty good.
azn2yunr is offline   Reply With Quote
Old 07-19-2005, 09:21 PM   #6
Scooby Specialist
Member#: 89385
Join Date: Jun 2005
Location: Loading...
many most all


Too much boost, not enough fuel? Fuel filter, fuel sock?
turbo2ner is offline   Reply With Quote
Old 08-18-2005, 05:03 PM   #7
Scooby Newbie
Member#: 93913
Join Date: Aug 2005
Location: South Fla 8-)
1996 Maxima
Super Black


Fuel pump??
nismology is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Japanese Cars Surge In Value Rankings - Baja Ranked #1 flyinpig News & Rumors 4 10-12-2005 02:16 PM
Strange surge in power at 5K RPM bleat Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 22 09-17-2005 01:17 AM
high G oil surge in heads patr Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 07-23-2005 01:27 PM
Boost surging in 5th O2-GGA Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 04-07-2004 04:04 PM
EMI surging in 1st gear i-rex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 01-03-2003 09:23 PM

All times are GMT -4. The time now is 12:30 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.