Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-09-2005, 01:02 AM   #1
stayfido
Scooby Newbie
 
Member#: 35726
Join Date: Apr 2003
Location: portland, or
Vehicle:
2002 psm sedan stg 4

Default Heater problem

I have an 02 wrx and just recently the heater has been acting up. When the engine is under any type of load the heater blows hot air. But when I park and idle, the ait drastically cools off. If I rev it it will warm up a little and then cool off. This happens regardless of whether the car is warmed up or not. Also the temp of the car seems to be normal. Any ideas??
stayfido is offline   Reply With Quote
Old 11-09-2005, 01:46 PM   #2
MK1ofMnM
Scooby Newbie
 
Member#: 6976
Join Date: May 2001
Chapter/Region: MWSOC
Location: Southwest, Iowa
Vehicle:
2006 F150

Default

I would try checking the coolant level in radiator first. Sounds like maybe an air pocket/low coolant.
MK1ofMnM is offline   Reply With Quote
Old 11-09-2005, 05:23 PM   #3
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

This is with the a/c switched to on, and the blower on? Do you have the blower on "auto"?
z is offline   Reply With Quote
Old 11-09-2005, 08:33 PM   #4
stayfido
Scooby Newbie
 
Member#: 35726
Join Date: Apr 2003
Location: portland, or
Vehicle:
2002 psm sedan stg 4

Default

No auto temp mode in my car, a/c off, the blower is set to either 1 through 4 and the heat all the way to hot. I will check the coolant level, it just seems like an odd problem. Any other ideas?
stayfido is offline   Reply With Quote
Old 11-09-2005, 10:27 PM   #5
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

Well my theory was more along the lines of the A/C fan clutch, tensioner but if the A/C isn't even on, that's out the window.

Probably more along the lines of what MK1 was thinking - something with the coolant level/ cooling system pressure.
z is offline   Reply With Quote
Old 11-10-2005, 11:09 PM   #6
stayfido
Scooby Newbie
 
Member#: 35726
Join Date: Apr 2003
Location: portland, or
Vehicle:
2002 psm sedan stg 4

Default

duh, low coolant....problem solved, thanks!!
stayfido is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1985 GL Heater Problem lefty2053 'Old School' Subaru Forum 5 02-20-2005 09:01 PM
Legacy with heater problem... White2.5GT Legacy Forum 14 12-27-2004 03:46 PM
Blower Motor on heater Problem slowme Electrical & Lighting 5 11-02-2004 10:17 PM
another heater problem spoonfedb18a1 Service & Maintenance 0 05-31-2004 11:44 AM
heater problem AK_2002_WRX Service & Maintenance 1 11-04-2003 04:57 AM


All times are GMT -4. The time now is 10:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.