Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-07-2006, 08:51 AM   #1
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default 06 Stock STi - Sudden Engine Whistling Noise After High Speed

I was driving on the highway last week and wanted to open the car up, so on the next straigtaway, I punched the gas and got the car up to 140mph in 6th gear. As I got to the 140 mark, all of a sudden I hear the this really high pitch noise. I let my foot off the accelerator and the noise remained and slowly diminished as the car slowed down.

Now, whenever I drive I hear this high pitch noise as I accelerate. Any idea what this might be? Think I blew a hose or something? I looked under the hood while the car was on and didn't notice any weird noises or sounds.

It also seems now that it takes longer for the turbo to kick in and I only hear the turbo spooling once I get to 4th gear. Think this should be a dealer issue?

Any help would be appreciated.

Thanks,
Six
SixSigma is offline   Reply With Quote
Old 02-07-2006, 08:52 AM   #2
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

oops. wrong forum. can a mod please put this in the 2.5L forum. Thanks.
SixSigma is offline   Reply With Quote
Old 02-07-2006, 09:07 AM   #3
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

Usually the whistling sound at high speeds is caused by the mirrors. I guess if you're hearing it now at low speeds then it is engine related. Weird though.
garface is offline   Reply With Quote
Old 02-07-2006, 09:03 AM   #4
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default 06 Stock STi - Sudden Engine Whistling Noise After High Speed

double post.

Last edited by SixSigma; 02-07-2006 at 02:15 PM.
SixSigma is offline   Reply With Quote
Old 02-07-2006, 09:10 AM   #5
Vampyr
Scooby Specialist
 
Member#: 31761
Join Date: Jan 2003
Location: Wichita, KS
Vehicle:
2005 sold! STi
Aspen White w/ Gold rims

Default

first off... how many miles were on your car when you did the 140mph run?
Vampyr is offline   Reply With Quote
Old 02-07-2006, 09:18 AM   #6
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

I had about 2000 miles on it. So it was broken in enough.
SixSigma is offline   Reply With Quote
Old 02-07-2006, 09:21 AM   #7
06WRXTR
Scooby Specialist
 
Member#: 96668
Join Date: Sep 2005
Location: SW Missouri
Vehicle:
2006 WRX TR

Default

its wind noise bro, i had the same problem
06WRXTR is offline   Reply With Quote
Old 02-07-2006, 09:29 AM   #8
tomt5078
Scooby Newbie
 
Member#: 84619
Join Date: Apr 2005
Chapter/Region: MWSOC
Location: Milwaukee, Wisconsin
Vehicle:
2013 BRZ
Silver

Default

Quote:
Originally Posted by 06WRXTR
its wind noise bro, i had the same problem

So how did you fix it then?
tomt5078 is offline   Reply With Quote
Old 02-07-2006, 09:26 AM   #9
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

but it was quite loud. do you get that much wind noise?
SixSigma is offline   Reply With Quote
Old 02-07-2006, 09:30 AM   #10
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

I don't think it's wind noise because I can hear it at low speeds, like 20mph. I didn't hear this noise prior to this stunt.
SixSigma is offline   Reply With Quote
Old 02-07-2006, 12:24 PM   #11
ignomini
Scooby Newbie
 
Member#: 106955
Join Date: Feb 2006
Vehicle:
'04 STi
Blue, of course

Default

My '04 does the same thing any time you hit the limiter in 6th, or load the car hard at very high speed. At first I thought it was wind noise, but now I wonder if it's the ECU dumping boost through some double secret outlet. If so, your "valve" may have stuck and you're losing boost at low speeds.

But then *** do I know, this is only my first post.
ignomini is offline   Reply With Quote
Old 02-07-2006, 12:36 PM   #12
Timmy Burns
Scooby Newbie
 
Member#: 99348
Join Date: Oct 2005
Chapter/Region: South East
Location: Atlanta
Vehicle:
If I could only
get you oceanside.

Default

Quote:
Originally Posted by ignomini
At first I thought it was wind noise, but now I wonder if it's the ECU dumping boost through some double secret outlet.
There is no double secret outlet for your turbo, that I can assure you.

Any mods? Do you have gauges? If so, what were you boosting at that time? As many minor details that you can remember will be helpful.
Timmy Burns is offline   Reply With Quote
Old 02-07-2006, 12:44 PM   #13
stidailydriver
Scooby Specialist
 
Member#: 69650
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: des moines
Vehicle:
06 sti
black w/gold

Default

like ^^he said, are you stock? how much boost? maybe you poped off a vacuum hose. and are you sure its not just the tranny whine you are hearing?


IBnewpost"howdoIremovedoublesupersecretboostvalveo utlet?"

Last edited by stidailydriver; 02-07-2006 at 12:56 PM.
stidailydriver is offline   Reply With Quote
Old 02-07-2006, 12:25 PM   #14
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

that's the best theory yet. how do i go about checking for this?

edit: And welcome to the boards
SixSigma is offline   Reply With Quote
Old 02-07-2006, 12:58 PM   #15
supermarkus
Scooby Guru
 
Member#: 6971
Join Date: May 2001
Location: Edmonds, Washington, USA
Vehicle:
2008 WRX STi
SSM

Default

Your electronic throttle makes a lot of noise even at idle, normal. It's probably in your imagination if you cant find any leaks and the noise persists. What probably happened is the whistling at high speed made you very sensitive to those types of noises, now you're listening to your car more and finding more "problems". Then you come online and look up other whistling "problems" and this site has turned you into an automotive hypochondriac. This site is great for that.
supermarkus is offline   Reply With Quote
Old 02-07-2006, 06:38 PM   #16
thehollowrift
Scooby Specialist
 
Member#: 86788
Join Date: May 2005
Chapter/Region: MAIC
Location: MoCo
Vehicle:
04 STi
PSM

Default

At that high of a speed --- your differentials do crazy things ---
Had a good friend have that similar problem or maby it was a transfer case??
its one of the two

might want to get that checked out.... and make sure you take it to a dealer without any MODS.... his problem was that he took it to a dealer and they finished off his tranny problem.......

just my .02
thehollowrift is offline   Reply With Quote
Old 02-07-2006, 07:14 PM   #17
2thAche
Scooby Newbie
 
Member#: 83131
Join Date: Mar 2005
Chapter/Region: South East
Location: Marietta, GA
Vehicle:
2004 STi
WR Blue

Default

Is this like a high pitched electronic kind of whistle or a whoosh kind of whistle? Sometimes under partial throttle accelleration you can hear the blow-off valve dumping pressure, sounds like a whooshing whistle. Under full throttle this should go away if your RPMs are up enough.

Another thing that can make a high pitched whistle that sounds electronic is a fuel pump.
2thAche is offline   Reply With Quote
Old 02-09-2006, 12:07 AM   #18
KillerSTI04
Scooby Newbie
 
Member#: 98912
Join Date: Oct 2005
Default Ic Hose

Its definatly and I/c Hose twice once when i was racing a 350z at about 100 i just lost aloot of power... and every time i would take it over 3000 rpms the noise would start Especially at 4000 rpm when the turbo is already spooled up. IF its making that loud of a noise its definatly the I/c Hose check it out... im sure youll be just as surprised as i was... it could be off just a little and make a hell of alot of noise
KillerSTI04 is offline   Reply With Quote
Old 02-07-2006, 09:18 AM   #19
subieworx
Scooby Guru
 
Member#: 47769
Join Date: Nov 2003
Chapter/Region: MWSOC
Default

Probably an IC hose. Check the TMIC to make sure everything is connected. Is the high pitched squeal when boost is coming on? Does it sound exhaust related? Do you hear it while idleing?
subieworx is offline   Reply With Quote
Old 02-07-2006, 09:19 AM   #20
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

I only hear it when accelerating, even at low rpm's. It sounds like it's coming from the driver side engine compartment. But I can't be sure. It's definately not the exhaust.
SixSigma is offline   Reply With Quote
Old 02-07-2006, 09:51 AM   #21
subieworx
Scooby Guru
 
Member#: 47769
Join Date: Nov 2003
Chapter/Region: MWSOC
Default

Check all intercooler hoses then. One was likely not tightened down enough.
subieworx is offline   Reply With Quote
Old 02-07-2006, 10:17 AM   #22
aREX4X
Scooby Newbie
 
Member#: 18781
Join Date: May 2002
Vehicle:
2005 911

Default

I'm gonna say the mirror noise too, my 2002 used to do it and it scared the crap out of me the first few times, when I really got going it almost sounded like the horn a bit.

x...
aREX4X is offline   Reply With Quote
Old 02-07-2006, 10:26 AM   #23
SixSigma
Scooby Newbie
 
Member#: 104557
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Naugy, CT
Vehicle:
2006 STi
Black w/Silver

Default

hmm... the thing is the noise dissappears on the highway when i'm going the normal 55-80mph.

I haven't tried to get it over 100mph since. It's probably all in my head. Just weird though. The engine idles just fine. I checked the hoses and everything looks in order.

Oh well. I'll have to keep an ear out for it I guess.
SixSigma is offline   Reply With Quote
Old 02-07-2006, 10:46 AM   #24
Dr. Fob
Scooby Newbie
 
Member#: 101329
Join Date: Nov 2005
Location: Cleveland - Toronto
Vehicle:
'06 STi - white
'00 S2000 - silver

Default

My friend's '05 WRX wagon makes a whistling sound AFTER the car is shut off. The noise stays constant for at least 5 minutes. If there were air leaks it ought to have released all the pressure after 5 minutes right? Any ideas?
Dr. Fob is offline   Reply With Quote
Old 02-07-2006, 11:15 AM   #25
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

Quote:
Originally Posted by Dr. Fob
My friend's '05 WRX wagon makes a whistling sound AFTER the car is shut off. The noise stays constant for at least 5 minutes. If there were air leaks it ought to have released all the pressure after 5 minutes right? Any ideas?

Don't the new models run the fans sometimes after the car is shut off?
garface is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud whistling noise after downpipe install....leak? AutoSpeedWRX Factory 2.0L Turbo Powertrain 26 11-01-2008 09:27 PM
whistling sound at high speeds Nikko Factory 2.0L Turbo Powertrain 19 05-17-2007 07:51 AM
Whistling Noise After Installing DP i-max Factory 2.0L Turbo Powertrain 8 01-02-2007 07:57 PM
whistling noise at high mph vnmvx-0 Factory 2.0L Turbo Powertrain 9 02-19-2005 10:05 AM


All times are GMT -4. The time now is 09:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.