Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > AccessPort

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-26-2006, 06:15 PM   #1
madwrxing
Scooby Newbie
 
Member#: 109212
Join Date: Mar 2006
Location: Madtown, WI
Vehicle:
03 wrx
Sonic Yellow

Default Will someone please help with my low boost?

Dear fellow experts, please help me with my low boost problem.

I flashed my ECU with stage1 93Octane map about 1 week ago. I have noticed the car pulls harder than the stock map. However, the highest boost I have seen on any gear is about 9.5psi. Before I reflash, the boost level is normal about 13ish. I have done the Vishu reset trick, and gave it a full tank of gas learning. It still stuck at 9.5psi.

I only have TurboXS BOV and K&N Tyhoon intake. Don't laugh at me, I know I shouldn't alter the factory intake system, but this one came with the car. I did beat up on the previous owner when I bought the car if that makes you feel better.

So my question is what the f*** is going on? How come I see normal boost with stock map, not with stage 1? Am I safe running this way? I will go to Stage 2 once I gather some pipes, hoses and OEM AIR BOX. Meanwhile, should I convert back to stock map, or just be gentle with the paddle? I hate to have $600 sitting in my garage not doing anything. I have to say the car does pull much harder now at low rev, and still smoked a s2000 last week (but it was driven by a grandpa, )
madwrxing is offline   Reply With Quote
Old 03-26-2006, 07:23 PM   #2
boundy3
Scooby Specialist
 
Member#: 54598
Join Date: Feb 2004
Chapter/Region: South East
Location: Orlando
Vehicle:
2004 WRX Sedan
WR Blue Pearl #68 STX

Default

yeah something is definately not right.

First off, what car/year do you have?

What are you checking boost with AP, gauge, ecuexplorer, etc.? AP would likely be the most accurate.

Have you checked for any vaccum leaks or holes in your intake system?

May want to try the hwg duty map and see if that helps any, but if your down about 5 psi I dont think it will help.

May want to try the 91 oct map, or if you live in california the cali map.

Check the adjustment on the wastegate actuator arm. Search for intsructions on it, basiclly take the c-clip off and put a little preload on the wastegate. It helped me hit target boost when I was about 1 psi low. But then again if your 5 psi low and were hitting stock target boost probably not the problem.

And of course, if you can put the stock bpv and airbox on.

Good luck
boundy3 is offline   Reply With Quote
Old 03-26-2006, 08:49 PM   #3
madwrxing
Scooby Newbie
 
Member#: 109212
Join Date: Mar 2006
Location: Madtown, WI
Vehicle:
03 wrx
Sonic Yellow

Default

it's 03 wrx. I have the OEM turbo gauge, and the reading is off the turbo gauge as while. it's 93 Wisconsin fuel.

I will try to have someone read the live boost from AP this week while I am driving.
madwrxing is offline   Reply With Quote
Old 03-27-2006, 03:18 AM   #4
dvang
Scooby Specialist
 
Member#: 84188
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: its too cold
Vehicle:
05 legacy
caravan full of kids now

Default

try tightening the wastegate

if your around milwaukee we can meetup sometime and i can help you if your not sure on how to do it.
dvang is offline   Reply With Quote
Old 03-27-2006, 03:45 AM   #5
TeknoWhore
Scooby Newbie
 
Member#: 37904
Join Date: Jun 2003
Vehicle:
2008 Subaru STi
SSK

Default

Try unloading all the maps and download new ones from Cobb. Mine did the same thing. I think one of the maps was downloaded wrong or something cause I was supposed to be runnin stg 1 93 but it was the econo map instead. Try that, and give it 30 miles or so.
TeknoWhore is offline   Reply With Quote
Old 03-27-2006, 08:48 AM   #6
madwrxing
Scooby Newbie
 
Member#: 109212
Join Date: Mar 2006
Location: Madtown, WI
Vehicle:
03 wrx
Sonic Yellow

Default

thanks everyone, I really appreciate it. I will try the maps first, that should be easy to do. If that doesn't fix it, I will look at the wastegate.
madwrxing is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
someone please help with inspection... RuskiiWRX02 New England Impreza Club Forum -- NESIC 12 11-23-2009 08:42 PM
Will someone please help me? Gravel Girl Southern California Impreza Club Forum -- SCIC 6 07-30-2004 02:29 PM
House selling/reselling. Please help with my idea... Impreza2.5RSTi Off-Topic 18 07-17-2003 02:38 PM
('93-'01) Please help with my question SammyDFG Impreza Forum 23 08-02-2001 02:31 PM
Will someone please help me (asap) runnerj General Forum Archive 20 02-19-2001 02:56 PM


All times are GMT -4. The time now is 12:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.