Welcome to the North American Subaru Impreza Owners Club Thursday September 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-03-2001, 10:25 PM   #1
Bottom Feeder
Scooby Specialist
 
Member#: 2808
Join Date: Nov 2000
Chapter/Region: MAIC
Location: Occupied Virginia
Question Just put in Castrol Syntec Blend...

I changed my oil a little while ago, draining out Mobil 1 and filling it with Syntec Blend, both in 5w-30. I don't know if it means anything, but my car is quieter now, kinda sounding 'more lubricated'. The all-synthetic Mobil wasn't even that old or dirty, so I don't know why the motor would sound better, especially under acceleration. Hmm...
Bottom Feeder is online now   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
just put in ngks...should I be worried?... Blindeye_03 Normally Aspirated Powertrain 8 06-22-2012 03:05 PM
Just put in a VF34 and have questions David@Vishnu Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 02-23-2003 07:20 PM
New to Turbos and I just put in a boost gauge, now I have a question gotsol Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 07-09-2002 08:33 AM
just put in eibach pros christoph1371 Brakes, Steering & Suspension 11 02-01-2002 10:51 AM
Just put in a Cerwin Vega Vega series! jay25RS Car Audio, Video & Security 1 07-24-2001 10:33 PM


All times are GMT -4. The time now is 01:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.