Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-03-2006, 05:32 PM   #1
3rdTimeOffender
Scooby Newbie
 
Member#: 53764
Join Date: Jan 2004
Location: Morgantown WV
Vehicle:
2013 Impreza Sport
Silver

Default Drivetrain or Suspension Problem??

Okay I have a 5-speed MT in a 99 Legacy. I had a horrible clicking/clunking sound when pulling into a parking space. Basically with the wheel turned left or right there is a bad sound either in the suspension or the transmission. I figured it was just my CV joints and decided to replace the axels since I had 116k miles on the vehicle. But nope didn't fix the problem. Does anyone have any suggestions what this might be? I have looked at everything in the suspension components while I had the car on the lift but I ddin't notice anything. Any suggestions would be helpful before I go to the dealer. I usually like to fix these things myself.
3rdTimeOffender is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shops or forum member in Central Jersey to fix suspension problem the HKIC Tri-State Area Forum 7 09-24-2009 03:56 PM
STI suspension problem or feature? padams64 Brakes, Steering & Suspension 17 04-17-2004 12:55 PM
Suspension Or Tranny Problems blackbeast Warranty Issues & SOA Problems 0 04-27-2003 11:57 PM
Suspension problems! Back end is unstable. shutters left or right??!!!??? Rallyspec Brakes, Steering & Suspension 9 01-28-2002 06:13 PM


All times are GMT -4. The time now is 06:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.