Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-05-2007, 12:50 AM   #1
akuma59
Scooby Newbie
 
Member#: 72519
Join Date: Oct 2004
Chapter/Region: SCIC
Location: 310
Vehicle:
05 EJ20T
silveR.

Default Mcculloch 10k disappointment

hey guys.
i need some help from people who have experienced my problem.
i installed the h1 10k set on my 05 wrx.
after i got them installed properly. when i went to test them, they didnt turn on.
is it possible that i shorted the ballast? might of been a spark tht i didnt see.
neither side turns on.? what shud i do?
please help, very ashamed at myself if i did sumpn wrng.
akuma59 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
disappointment after disappointment 12eckless WRX General Community 88 06-04-2004 10:21 AM
McCulloch 5000k H.I.D. in Stock headlight DNG_WRX Interior & Exterior Modification 7 06-04-2002 05:17 PM
Your opinion on McCulloch H.I.D. MaximusRex Interior & Exterior Modification 22 05-25-2002 02:27 AM


All times are GMT -4. The time now is 10:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.