Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-02-2007, 09:35 AM   #1
zentrandi
Scooby Specialist
 
Member#: 130577
Join Date: Oct 2006
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
03 gga WRX 10' LGT
Both silver

Question Burning clutch smell and slipping

My car is at 85k miles and i bought it used with 2 previous owners at 75K and yesterday my clutch didnt engage correctly at 4th gear, so now i smell this metallic burn so I let it cool overnight. This morning the smell wasnt there, but when i got to work, I could faintly smell it, and as i drove to work, it felt like it was slipping a little in 1st and 3rd mostly and somewhat on 2nd.

So the question is:

Should I think about replacing my clutch?

if so:

Exedy Stage 1 Single Plate Organic Clutch?

or

Exedy OEM replacement Organic Clutch?


I dont have much of a power goal. All i want is stage 2 with AP maybe upping the boost to 15psi max. The car is pretty much stock, minus the resonator, and with K&N filter. But in the future, i want to have a full TBE and catless UP and silicone charge pipe and y pipe.

So if i need replacement, would the OEM kit suffice?

Thanks in advance
zentrandi is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
burning clutch smell after driving 02blkwagn19 Transmission (AT/MT) & Driveline 2 12-22-2007 01:30 PM
Clutch smell and smoke rbailey644 Transmission (AT/MT) & Driveline 0 01-17-2005 12:15 PM
Burning clutch smell, brand new car Balve General Community 5 11-10-2004 03:15 PM
Question for STi owners - burning clutch smell from reverse? avatarr Transmission (AT/MT) & Driveline 13 03-23-2004 09:19 AM
Burning clutch smell dragonglen Baja Forum 3 10-28-2003 11:20 PM


All times are GMT -4. The time now is 07:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.