Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-17-2002, 01:51 PM   #1
Jewbaru
Scooby Specialist
 
Member#: 1994
Join Date: Jul 2000
Location: "Teh Hebro Town"
Vehicle:
2013 Impreza WRX
WRB

Default Is my fuel pump crapping out on me?

I drove out to the city today to run an errand, and when I was stopped at a light, with the radio down, I could hear a loud whining coming from the car. I listened for a bit, and it's coming from the rear passenger side of the car, where the fuel pump is. When the car was idling on the timer, I walked around the car and listened. The whine was REALLY loud. The car doesn't feel any different, but the A/F guage shows it's running a touch leaner under cruise than it was normally. Still well within stoich, however. I thought I felt the car hesitating a little when I was cruising, but I may just be paranoid, since the a/f guage wasn't fluttering into the lean range.

The pump is a Walbro, and it's not even a year old yet.
Jewbaru is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my fuel pump getting weak or is it the Turbo? ClayMac Factory 2.0L Turbo Powertrain 12 11-20-2008 03:59 PM
Access Port Crapped out on me during very first tune Mr Nice Guy AccessPort 8 06-30-2006 07:19 AM
HELP! My car is crapping out on me synickle General Community 4 12-03-2005 12:27 PM
Is my fuel pump going bad? Or is it worse? NicGordon Service & Maintenance 5 10-15-2002 02:43 PM
Attn: Brullen Crapped Out On Me booger Normally Aspirated Powertrain 4 07-15-2002 12:54 PM


All times are GMT -4. The time now is 10:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.