Welcome to the North American Subaru Impreza Owners Club Tuesday October 25, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-11-2007, 04:28 PM   #1
Scooby Specialist
Member#: 139244
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: South Elgin
2002 EJ207 WRB WRX

Default CEL - Evap issues?

last night my CEL came on during normal driving. Car runs fine. Took it to auto zone to get the code. Came back with a P0447 which auto zone has listed as "EVAP Emission Control System Vent Circuit Open"

a google of the code came back with "Evaporative emission control system vent control low input" so... i have no clue what to check. Read about a possible bad connection. but where is the sensor thats throwing this code located on the car?

Any help would be much appreciated.

Car is pretty much stock other than perrin ic hose, turbo inlet, and a CAI.

Thanks in advance,

Tyrael is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL p1153 Issue thcfortified AccessPort 4 05-11-2009 05:22 PM
CEL question/issue ihaveanose1234 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 01-09-2007 05:40 PM
used wrx... CEL... bad evap system drain valve... $240 tad_02Wgn Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 08-03-2004 10:27 AM
what else can cause the evap. emissions leak CEL? jmaiken Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 12-27-2003 10:55 AM
Help with CEL P0457 EVAP Sparks Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 07-15-2002 10:35 AM

All times are GMT -4. The time now is 08:05 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.