Welcome to the North American Subaru Impreza Owners Club Sunday April 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-21-2007, 10:12 PM   #1
wigglesxjr
Scooby Specialist
 
Member#: 4293
Join Date: Feb 2001
Chapter/Region: SCIC
Location: Southern California
Vehicle:
2002 WRX
Midnight Black Pearl

Default Newly Minted 257/WRX hybrid -- rod knock or noisy valvetrain?

Hey guys,
just wanted to thank all the guy on here, especially DrinkAV8 and everyone else who has posted up their hybrid build stories -- I'll shortly be doing the same as soon as I can get the kinks worked out. Those include:

1) chattery/shuddery clutch (ugh)
2) strange knock/tick from the driver's side

SETUP:
EJ257 shortblock (new)
cleaned/decked WRX heads
STi head gasket
stock turbo/accesories
downpipe, prodrive axle back

I noticed this knock/tick shortly after starting up the engine...though I'm not exactly sure it was present during the first time that I started my new hybrid up. The noise is RPM dependent, and at idle I estimate about 350-400bpm at my 750-800rpm idle (worrying).

video of my problem:
http://www.youtube.com/watch?v=Z1Vb4uvRQME

haven't taken a look at the oil yet, but thought I'd get some opinions here first. THanks much.

-JT

Last edited by wigglesxjr; 08-21-2007 at 11:45 PM. Reason: added setup info
wigglesxjr is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rod knock = Hybrid Swap! tshivers00 Built Motor Discussion 29 08-06-2013 02:08 PM
Some knocking...rod knock or piston slap? mtcs Built Motor Discussion 41 12-03-2012 05:47 AM
FS: in wNY Project car 2002 WRX Wagon WRB would be $6500, Rod knock = $3500 - SOLD stutz342 Private Vehicle 'For Sale' Classifieds 25 06-03-2010 10:27 AM
Strange WRX Hybrid Noise, not ticking or knocking. alex02wrx Built Motor Discussion 3 12-10-2009 04:32 PM
rod knock or valve knock Zerogravity Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 32 06-01-2009 12:28 PM


All times are GMT -4. The time now is 10:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.