Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-07-2007, 12:49 AM   #1
dblurx4
Scooby Specialist
 
Member#: 124935
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Tempe, Arizona
Vehicle:
'05 WRX

Default Help with me HKS SSQ...

Ok, heres the deal. I received the BOV for Christmas last year. I installed it and it worked perfect for about 2 weeks. Then all the sudden one week it just started acting up? My car was jumping around at idle, and fell on its face a couple times. Figured it was a vac. leak of some sort. So I took it off and re-installed my stock BOV and it fixed the problem immediately. Any ideas on how to fix it, what to look for etc... It has been sitting for months. Any input would be great... I need the BOV for more power, so PLEASE help me !

Thanks in advance
Justin
dblurx4 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With My HKS Turbo Timer Type1 TeamDeezNutz Electrical & Lighting 5 09-18-2009 07:53 PM
help me with my HKS ssq bov djpete Tri-State Area Forum 5 12-31-2005 03:36 PM
Help with an HKS SSQ BOV dexterous Factory 2.0L Turbo Powertrain 8 09-12-2004 12:47 PM
Anyone up to help with an HKS SSQV shaneswrx Mid Atlantic Impreza Club -- MAIC 1 11-11-2003 09:33 PM
Need help with me S-AFC settings??? Xscreamer Normally Aspirated Powertrain 3 02-21-2001 08:13 AM


All times are GMT -4. The time now is 02:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.