Welcome to the North American Subaru Impreza Owners Club Saturday November 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-07-2007, 01:49 AM   #1
dblurx4
Scooby Specialist
 
Member#: 124935
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Tempe, Arizona
Vehicle:
'05 WRX

Default Help with me HKS SSQ...

Ok, heres the deal. I received the BOV for Christmas last year. I installed it and it worked perfect for about 2 weeks. Then all the sudden one week it just started acting up? My car was jumping around at idle, and fell on its face a couple times. Figured it was a vac. leak of some sort. So I took it off and re-installed my stock BOV and it fixed the problem immediately. Any ideas on how to fix it, what to look for etc... It has been sitting for months. Any input would be great... I need the BOV for more power, so PLEASE help me !

Thanks in advance
Justin
* Registered users of the site do not see these ads.
dblurx4 is offline   Reply With Quote
Old 09-07-2007, 01:57 AM   #2
shwoop_soobie
Scooby Specialist
 
Member#: 102323
Join Date: Dec 2005
Chapter/Region: SWIC
Location: Prescott AZ
Vehicle:
99 power poles
beware

Default

my advice would be to use your stock bov. the hks one acted up because your car does not like it... it likes stock, re-cerc
what kind of power are you planing on having...? i don't see any reason the stock wouldn't work with any type of reasonable power...
find uni bombers thread on bov's... it will answer all
shwoop_soobie is offline   Reply With Quote
Old 09-07-2007, 02:02 AM   #3
dblurx4
Scooby Specialist
 
Member#: 124935
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Tempe, Arizona
Vehicle:
'05 WRX

Default

Hey thanks, I received the BOV as a gift from my gf. She has been wondering why the hell its not on my car ... So I was just looking to fix the problem, for I wouldnt mind having it back on. If I sold it she would, well you know how women are . . .
dblurx4 is offline   Reply With Quote
Old 09-07-2007, 06:23 AM   #4
tspinks
Scooby Specialist
 
Member#: 109088
Join Date: Mar 2006
Chapter/Region: SWIC
Location: Tempe Arizona
Vehicle:
2006 Infiniti G35
Liquid Platinum

Default

have you checked to see if it is leaking air? not sure how to check it tho. Try nasioc technical boards.
tspinks is offline   Reply With Quote
Old 09-07-2007, 08:11 AM   #5
dozer54321
Scooby Specialist
 
Member#: 116437
Join Date: Jun 2006
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2002 WRX - MINE
99 SUS - WIFEY

Default

gormonks car did the same thing when he put on his full atmospheric, it would die at idle, he tuned it out, did you reset your ecu when you put your BOV on for "more power"
dozer54321 is offline   Reply With Quote
Old 09-07-2007, 11:27 AM   #6
dblurx4
Scooby Specialist
 
Member#: 124935
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Tempe, Arizona
Vehicle:
'05 WRX

Default

Quote:
Originally Posted by dozer54321 View Post
gormonks car did the same thing when he put on his full atmospheric, it would die at idle, he tuned it out, did you reset your ecu when you put your BOV on for "more power"
I didnt try that... I called HKS and they told me just to get the car tuned with the BOV on my car. So I guess here in a couple weeks im going to get a header abd APS 3", I will just tune it then. I was told to tune it with it on there, and also I was told to just disassemble the whole thing and put it back together. But the darn thing is brand new. So do you think I should just try putting it back on, then unplugging my battery and seeing where it gets me?
dblurx4 is offline   Reply With Quote
Old 09-07-2007, 11:43 AM   #7
dozer54321
Scooby Specialist
 
Member#: 116437
Join Date: Jun 2006
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2002 WRX - MINE
99 SUS - WIFEY

Default

you can try it, but your better off just keeping the stocker on until you get tuned but you can try the ecu reset if you want to try it
dozer54321 is offline   Reply With Quote
Old 09-07-2007, 05:35 PM   #8
tspinks
Scooby Specialist
 
Member#: 109088
Join Date: Mar 2006
Chapter/Region: SWIC
Location: Tempe Arizona
Vehicle:
2006 Infiniti G35
Liquid Platinum

Default

id say put it on night before ur tune, after tune u should be gold
tspinks is offline   Reply With Quote
Old 09-07-2007, 07:08 PM   #9
Smoby
Scooby Specialist
 
Member#: 97642
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2002 Wrx Sedan
MBP

Default

The hks is known to leak and cause this problem. There are a lot of hks fakes out there also which have crap build quaility.

If your car runs fine with the stocker then I think you have a problem with the hks. If you are able to tune it out then you are just putting a bandaid on the problem and not fixing it.
Smoby is offline   Reply With Quote
Old 09-07-2007, 07:39 PM   #10
WgnWheel
Scooby Specialist
 
Member#: 63605
Join Date: Jun 2004
Chapter/Region: SWIC
Location: Moms...yours
Vehicle:
04 Wrx Wgn TimeAtk
10 Golf TDI, 08 Stang GT

Default

stand on one foot, tap hks twice with index finger, say 5 "hail marry's", re-install hks bov, start car...















and it still will run like poop, cause hks+suby is not a good match.
WgnWheel is offline   Reply With Quote
Old 09-07-2007, 11:41 PM   #11
gormonk
Scooby Specialist
 
Member#: 98960
Join Date: Oct 2005
Chapter/Region: SWIC
Location: phoenix, AZ
Vehicle:
1978 brat (fo realz)
red

Default

Quote:
Originally Posted by Smoby View Post
The hks is known to leak and cause this problem. There are a lot of hks fakes out there also which have crap build quaility.

If your car runs fine with the stocker then I think you have a problem with the hks. If you are able to tune it out then you are just putting a bandaid on the problem and not fixing it.
i'd like to know where you got that info. with the design of the hks it is impossible to leak unless
1. its broken
2. car has a vacuum leak

but yeah dude resetting the ECU wont be enough. there are ways to tune around it. leave the stocker on for now. it took me 2 months to tune for my atmospheric bov. its a pain in the ass.
gormonk is offline   Reply With Quote
Old 09-08-2007, 12:13 AM   #12
dblurx4
Scooby Specialist
 
Member#: 124935
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Tempe, Arizona
Vehicle:
'05 WRX

Default

Thanks guys for all of the help. My girl purchased the BOV from hopupracing.com. Im pretty positive its the real deal, but then again who knows? The car runs perfect without the HKS on there. So for now I will just stick with it... When I get my car tuned next here in a couple weeks, I will slap it on there and see where it gets me. If the same result occurs, I will just put my stocker back on. To be honest, I really do like the way it sounds ... I might just go ahead and see if I can go a different route, maybe the Greddy RS or something else? Is there any full atmospheric BOV out there that doesnt give you trouble?
dblurx4 is offline   Reply With Quote
Old 09-08-2007, 01:04 AM   #13
gormonk
Scooby Specialist
 
Member#: 98960
Join Date: Oct 2005
Chapter/Region: SWIC
Location: phoenix, AZ
Vehicle:
1978 brat (fo realz)
red

Default

greddy RS is what im usin
gormonk is offline   Reply With Quote
Old 09-08-2007, 01:38 AM   #14
Smoby
Scooby Specialist
 
Member#: 97642
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2002 Wrx Sedan
MBP

Default

I have heard of a few leaking when at idle. The MAF tells the ecu how much air is being used and fueling is adjusted accordingly. If you have a leak then your motor is getting less air then the ecu thinks so you run rich.

How did you tune out your issue, mess with the maf table?
Smoby is offline   Reply With Quote
Old 09-08-2007, 01:55 AM   #15
Smoby
Scooby Specialist
 
Member#: 97642
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2002 Wrx Sedan
MBP

Default

Quote:
Originally Posted by gormonk View Post
i'd like to know where you got that info. with the design of the hks it is impossible to leak unless
1. its broken
2. car has a vacuum leak

but yeah dude resetting the ECU wont be enough. there are ways to tune around it. leave the stocker on for now. it took me 2 months to tune for my atmospheric bov. its a pain in the ass.
That is what I was saying earlier, a lot of fakes means crap parts which break. The shaft inside likes to stick also

I actually had a ssqv and it leaked where the vaccuum nipple went into the bov if I put any pressure on it.
Smoby is offline   Reply With Quote
Old 09-08-2007, 02:07 AM   #16
gormonk
Scooby Specialist
 
Member#: 98960
Join Date: Oct 2005
Chapter/Region: SWIC
Location: phoenix, AZ
Vehicle:
1978 brat (fo realz)
red

Default

Quote:
Originally Posted by Smoby View Post
That is what I was saying earlier, a lot of fakes means crap parts which break. The shaft inside likes to stick also

I actually had a ssqv and it leaked where the vaccuum nipple went into the bov if I put any pressure on it.
thats cause of a bad seal where it goes into the housing. a buddy of mine had the same problem. i took it apart and fixed it with a new fitting. but yeah after messing with my maf table and afr table i was able to tune it out completely. dozer can attest to how well my car runs in stop and go traffic (thats what most of our work commute was.)
gormonk is offline   Reply With Quote
Old 09-08-2007, 09:14 PM   #17
John2.5RS
Scooby Guru
 
Member#: 1140
Join Date: Mar 2000
Chapter/Region: SCIC
Location: On the road
Vehicle:
2013 Ecoboost'd F150
Grey

Default

I'm pretty sure that HKS makes a kit make it a re-circ. BOV. I personally don't like external BOV, they're noisy and waste perfectly good, filtered & metered air. unless it's to run different piping arangements, such as a front mount.
John2.5RS is offline   Reply With Quote
Old 09-08-2007, 10:31 PM   #18
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

pm treefrogaz for a tune man, best thing you can do.
SubeSTIle is offline   Reply With Quote
Old 09-09-2007, 03:26 PM   #19
desmo750
Scooby Specialist
 
Member#: 111256
Join Date: Mar 2006
Chapter/Region: SWIC
Location: The land of R-tards, AZ
Vehicle:
1992 Legacy Turbo
don't call me white...

Default

desmo750 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With My HKS Turbo Timer Type1 TeamDeezNutz Electrical & Lighting 5 09-18-2009 08:53 PM
help me with my HKS ssq bov djpete Tri-State Area Forum 5 12-31-2005 04:36 PM
Help with an HKS SSQ BOV dexterous Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 09-12-2004 01:47 PM
Anyone up to help with an HKS SSQV shaneswrx Mid Atlantic Impreza Club -- MAIC 1 11-11-2003 10:33 PM
Need help with me S-AFC settings??? Xscreamer Normally Aspirated Powertrain 3 02-21-2001 09:13 AM


All times are GMT -4. The time now is 02:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.