Welcome to the North American Subaru Impreza Owners Club Wednesday December 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-03-2002, 02:33 PM   #1
NickSTi
Scooby Specialist
 
Member#: 626
Join Date: Dec 1999
Location: Miami FL
Vehicle:
2001 Impreza 2.5 RS
Black Diamond Pearl

Question Fuel Pump Relay Question

Problem: My car runs for 4s, then dies.
Observation: Fuel pressure on crank goes to 40psi, then slowly drops to zero, at which point the car obviously stalls.
Notes: I thought something was wrong with my fuel pump, and/or the relay. It is not the pump for I got a used one and the same problem remained.
Fix: The fuel pump relay in my car (green relay, 4 wires. 2001 RS) has 2 black/red wires. one is hot on start. The way I get my car working is to bridge the two black red wires together, and my car is working perfectly now. I traced the black/red wire on the wiring diagram: black/red (4) to fuel pump. For some reason, the black/red wire in question goes hot then off, which is turning the fuel pump off, hence why the car dies. Bridging the hot on start black/red wire to the black/red wire in question fixes this problem. But I want to know if any wiring gurus know what is wrong with that black/red wire to fuel pump.

My wiring harness was redone and I am running a Haltech in it right now. Thanx in Advance.
NickSTi is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need fuel pump and fuel pump relay 4/18/10 raceckr MWSOC Private Classifieds 1 04-18-2010 04:05 AM
Fuel Pump Relay Control and Airconditioner Cut Relay Control modifiedauto Newbies & FAQs 0 09-19-2007 09:43 PM
Fuel Filter replacement - where is fuel pump relay? SeenDubAYouAreEx Newbies & FAQs 4 07-11-2007 10:29 PM
fuel pump relay question imprezaclipse Subaru Conversions 3 06-13-2007 05:57 PM
fuel pump relay question ILwrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 04-15-2005 09:38 PM


All times are GMT -4. The time now is 11:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.