Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-02-2008, 03:32 PM   #26
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

tinywrex, thanks for providing an explanation of how your launch control works.
http://tinywrex.wordpress.com/2008/0...-how-it-works/
* Registered users of the site do not see these ads.
Jon [in CT] is offline   Reply With Quote
Old 02-02-2008, 03:39 PM   #27
fasterthanurwrx
*** Banned ***
 
Member#: 82734
Join Date: Mar 2005
Default

Maybe we can take a look at the NO LIFT SHIFT stuff again
fasterthanurwrx is offline   Reply With Quote
Old 02-02-2008, 04:24 PM   #28
.one lane
Scooby Specialist
 
Member#: 114528
Join Date: May 2006
Location: Outer space
Vehicle:
2002 Space Shuttle
Discovery

Default

Quote:
Originally Posted by Jon [in CT] View Post
tinywrex, thanks for providing an explanation of how your launch control works.
http://tinywrex.wordpress.com/2008/0...-how-it-works/
I was just reading that, and the LC uses a fuel cut. Wouldn't that cause lean condition? I was told that an ignition cut is safer.
.one lane is offline   Reply With Quote
Old 02-02-2008, 04:46 PM   #29
rkramer
Scooby Guru
 
Member#: 118209
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2009 Kia Borrego

Default

Quote:
Originally Posted by .one lane View Post
I was just reading that, and the LC uses a fuel cut. Wouldn't that cause lean condition? I was told that an ignition cut is safer.
it isn't lean if there is zero fuel in the chamber to ignite. ignition cut is dangerous because now you have a full charge of fuel that is going to ignite somewhere. either in your exhaust manifold, turbo, or cat.
rkramer is offline   Reply With Quote
Old 02-02-2008, 06:18 PM   #30
Hyper
Scooby Guru
 
Member#: 15822
Join Date: Feb 2002
Location: MOCKBA
Vehicle:
1999 WRB GM6
2.12cc V9 Type RA

Default

so once it's patched, do you actually see a new "map" in the ROM where you can change the settings?

I can't check, as my ECU id isn't supported yet (A4TJ111C-RT)
Hyper is offline   Reply With Quote
Old 02-02-2008, 06:25 PM   #31
vaccine
Scooby Newbie
 
Member#: 94490
Join Date: Aug 2005
Location: Australia
Default

Quote:
Originally Posted by Tgui View Post
Half shafts feeling lucky?
no problems yet with the 6-puck i have in place.
Plus a friend has been dragin for at least 5 years and only just busted his first half shaft. that was on a 91 RS liberty with a 5spd dogbox that has ****ty half shaft joints and shafts half the thickness. and was more probably to do with the dccd centre he has now putting 70% to the back wheels.

Load the drive train-up and she is apples.Side step the clutch with no slack taken in the drive-train and you are asking for trouble.
vaccine is offline   Reply With Quote
Old 02-02-2008, 06:35 PM   #32
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by Hyper View Post
so once it's patched, do you actually see a new "map" in the ROM where you can change the settings?

I can't check, as my ECU id isn't supported yet (A4TJ111C-RT)
1 picture is worth a 1000 words

xswrex is offline   Reply With Quote
Old 02-02-2008, 06:36 PM   #33
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by .one lane View Post
I was just reading that, and the LC uses a fuel cut. Wouldn't that cause lean condition? I was told that an ignition cut is safer.
factory rev limiter code works with fuel cut, can't be that bad ehh?
xswrex is offline   Reply With Quote
Old 02-02-2008, 06:38 PM   #34
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by Jon [in CT] View Post
tinywrex, thanks for providing an explanation of how your launch control works.
http://tinywrex.wordpress.com/2008/0...-how-it-works/
no problem, i only hope it is clear enough for everyone to understand
xswrex is offline   Reply With Quote
Old 02-02-2008, 06:48 PM   #35
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

xswrex is offline   Reply With Quote
Old 02-02-2008, 08:49 PM   #36
wrxsti.l
Scooby Specialist
 
Member#: 156973
Join Date: Aug 2007
Chapter/Region: International
Location: Adelaide, Australia
Vehicle:
2002 ADM WRX STi
STi Black/Blue

Default

any chance of patching the AUDM 2002 2.0L sti?

I can forward you a copy of my rom if required.

Also, will this cause any compatability problems when tuning the patched ROM with Enginuity and reflashing my patched and tuned ROM with ecuFlash?
wrxsti.l is offline   Reply With Quote
Old 02-02-2008, 11:15 PM   #37
gaveup
Scooby Newbie
 
Member#: 116036
Join Date: May 2006
Location: Ft Lauderdale.
Vehicle:
2015 WRX STi
DGM

Default

Please dear god update us when you have a 32bit for the 06-07's (pleaasseee)


Ill be your best friend (By best friend I mean send you at least $50..depending on my current funds and all)

Last edited by gaveup; 02-02-2008 at 11:29 PM.
gaveup is offline   Reply With Quote
Old 02-03-2008, 12:50 AM   #38
WeldingHank
Scooby Specialist
 
Member#: 98645
Join Date: Oct 2005
Chapter/Region: NESIC
Location: Lawrence,ma
Vehicle:
2002 WRX Wagon
PSM

Default

So I can't view the tables in EcuFlash version 1.29 that i run on my win2k system. But i can on version 1.34. BUT in the getting started FAQ it states that 1.34 will only work on WinXP and Vista. So why Can i run it on my win2k system, or will it not be able to flash?

OR

Can I modify the tables in 1.34 then flash them with 1.29?
WeldingHank is offline   Reply With Quote
Old 02-03-2008, 01:34 AM   #39
.one lane
Scooby Specialist
 
Member#: 114528
Join Date: May 2006
Location: Outer space
Vehicle:
2002 Space Shuttle
Discovery

Default

sweet! I just patched my rom w/ the launch control. Truly awesome!!

thank you xswrex!!!
.one lane is offline   Reply With Quote
Old 02-03-2008, 01:40 AM   #40
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by wrxsti.l View Post
any chance of patching the AUDM 2002 2.0L sti?

I can forward you a copy of my rom if required.

Also, will this cause any compatability problems when tuning the patched ROM with Enginuity and reflashing my patched and tuned ROM with ecuFlash?
as mentioned on site, patch can be created for any 16bit ROM, any market any region. A copy of your rom will be required

No compatibility issues or problems, you can even use Enginuity (or any editor for that matter) for editing as long as you port the XML parameters.
xswrex is offline   Reply With Quote
Old 02-03-2008, 01:44 AM   #41
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by WeldingHank View Post
So I can't view the tables in EcuFlash version 1.29 that i run on my win2k system. But i can on version 1.34. BUT in the getting started FAQ it states that 1.34 will only work on WinXP and Vista. So why Can i run it on my win2k system, or will it not be able to flash?
i cannot answer on that, i suppose ecuflash will run on a win2k system but maybe the driver for the cable does not work properly under win2k

Quote:
Originally Posted by WeldingHank View Post
Can I modify the tables in 1.34 then flash them with 1.29?
i believe you can, the flashing process just reads the file in binary format, it reads bytes, it transmits bytes!
xswrex is offline   Reply With Quote
Old 02-03-2008, 01:48 AM   #42
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by .one lane View Post
sweet! I just patched my rom w/ the launch control. Truly awesome!!

thank you xswrex!!!
you are welcome!

which rom revision? A4SGE01C?
xswrex is offline   Reply With Quote
Old 02-03-2008, 02:48 AM   #43
pbrink
Scooby Newbie
 
Member#: 117334
Join Date: Jun 2006
Location: Indiana
Vehicle:
2002 Impreza WRX
WRB

Default Wwwwwwwwoooooooowwwwwwwww!!!!

Just installed the patch and changed my map. This is really amazing stuff Thanks a lot!! I used the A4SGE01C revision in an 02 wrx and every thing went smooth, good instructions. A little change to the speed threshold and it will be smooth consistent launches. I was using a delta rpm of 3200 and a speed threshold of 20 k/hr and was hitting the limiter after the launch. Its a little wet out and I had a little too much wheel spin but to be expected.

Thanks again.

Parker
pbrink is offline   Reply With Quote
Old 02-03-2008, 02:57 AM   #44
.one lane
Scooby Specialist
 
Member#: 114528
Join Date: May 2006
Location: Outer space
Vehicle:
2002 Space Shuttle
Discovery

Default

Quote:
Originally Posted by xswrex View Post
you are welcome!

which rom revision? A4SGE01C?
yup! I need to edit the speed threshold value. I was bouncing off the rev limiter when I launched lol. LC rpm delta was set at 2200.
.one lane is offline   Reply With Quote
Old 02-03-2008, 03:53 AM   #45
NSFW
Scooby Guru
 
Member#: 140444
Join Date: Feb 2007
Chapter/Region: NWIC
Location: Near Seattle, WA
Vehicle:
05 Stage Free LGT
ATP 3076, 6MT, AVO FMIC

Default

So how hard would it be to put the threshold and delta in RAM?
And then write a little utility to tweak those values from a laptop using a Tactrix cable?
NSFW is offline   Reply With Quote
Old 02-03-2008, 03:53 AM   #46
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

A4TF800F-USDM WRX MY05 patch is released

http://tinywrex.wordpress.com/2008/0...reza-wrx-my05/
xswrex is offline   Reply With Quote
Old 02-03-2008, 04:09 AM   #47
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by NSFW View Post
So how hard would it be to put the threshold and delta in RAM?
And then write a little utility to tweak those values from a laptop using a Tactrix cable?
Not hard, just time consuming. I am sure you understand that this is not a matter of copy-paste
xswrex is offline   Reply With Quote
Old 02-03-2008, 04:11 AM   #48
simon021
Scooby Specialist
 
Member#: 157532
Join Date: Aug 2007
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
2002 MY03 EJ207 E85
Dom 1.5XTR Twinscroll!

Default

can the A4SGE01C patch be used with any 02 ECU as long as the xml code is inserted into the proper file in ecu flash?

EDIT: Tried it, and the inital values set for the RPM Delta and speed values are not 0 upon opening the rom for the first time in ECU Flash. I would have to say it's not safe use this A4SGE01C patch on an A4SGD10C rom, even though they are both USDM MY02 revisions.

Last edited by simon021; 02-03-2008 at 04:28 AM.
simon021 is offline   Reply With Quote
Old 02-03-2008, 04:52 AM   #49
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by simon021 View Post
can the A4SGE01C patch be used with any 02 ECU as long as the xml code is inserted into the proper file in ecu flash
NO NO AND NO. Why oh why dont you read the instructions!

Quote:
Originally Posted by simon021 View Post
EDIT: Tried it, and the inital values set for the RPM Delta and speed values are not 0 upon opening the rom for the first time in ECU Flash. I would have to say it's not safe use this A4SGE01C patch on an A4SGD10C rom, even though they are both USDM MY02 revisions.
Really so whats new man? Every patch is ROM specific, i specifically mention that. The patcher should give error messages as well as it wont patch anything unless the original isnt exactly what it expects it to be. If all is ok it will just print "x bytes patched"

As others have suggested you can use A4SGE01C ROM on any USDM MY02 because it is the version that fixes some issues, that is why i created a patch for that first. If you want a specific A4SGD10C you just have to wait!

You should not mix things up in your head!

Last edited by xswrex; 02-03-2008 at 09:51 AM.
xswrex is offline   Reply With Quote
Old 02-03-2008, 09:36 AM   #50
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

I used the A4SGE01C patch for my usdm02. Using the tinypatcher.exe, here's what I got:

Rogan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Launch Control on 2004 WRX Doomsti AccessPort 18 11-16-2012 03:16 PM
Launch Control on 32bit ECU Nuke209 Open Source Reflashes 126 05-17-2008 10:49 AM
Help with wiring in launch control on an 05 WRX. Sir Wagon UTEC 2 03-07-2008 04:45 PM
Failed NY state Inspection because of Launch Control on UTEC? vipernj Engine Management & Tuning 2 01-24-2006 06:10 PM
utec remote switch launch control on 4eat topgrinder Engine Management & Tuning 1 03-27-2003 08:34 PM


All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.