Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-02-2008, 12:08 AM   #1
wrxG
Scooby Newbie
 
Member#: 155087
Join Date: Jul 2007
Location: West Springfield MA
Vehicle:
02 WRX

Default Built motor.. first startup knock.

So I have built EJ257 with Eagle rods, Wiseco pistons and Cothworth Crank bearings with 2.0 WRX heads. I stardet the car up few days ago and it started knocking right away. I have no idea what could of went wrong. Some people tell me its the rod bearings, I have no clue how could that get messed up, but other people tell me that it could be the Wiseco pistons, they say Wiseco pistons dont fit well and it could be really bad piston slap that I'm hearing.

If anyone knows what could be wrong or give me some advice please do. It took me alot of time and money to do this the right way and it seems like it was all for nothing.
wrxG is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Who will blow there newly built motor first? TJ Texas Impreza Club Forum -- TXIC 82 02-14-2008 02:09 PM
world's first built motor and s/c on an svx sicksubie New England Impreza Club Forum -- NESIC 49 09-06-2007 11:19 PM
First built motor and supercharger in an SVX sicksubie General Community 38 09-06-2007 11:15 PM
built motor knock sensitivity dukeduster Built Motor Discussion 5 03-13-2007 12:39 AM
unusual knock issue - built motor Lennon UTEC 8 05-11-2006 02:00 PM


All times are GMT -4. The time now is 10:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.