Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-05-2008, 06:50 PM   #1
Susie's Suby
Scooby Newbie
 
Member#: 21370
Join Date: Jul 2002
Chapter/Region: MAIC
Location: In the #24 Chevy--I mean Subie
Vehicle:
01 Impreza RS 2.5
Blew-ridge Pearl

Default Help me!!!

I am ready to drive this car off a cliff.
We have an 01 2.5RS, the engine started to have a bad misfire. I replaced plugs and wires, no improvement. Took it to a dealer, they found a cracked y-pipe, also showed codes for misfires on 2,3,4 cyls, cat sysytem efficiency below threshold (p0420), evap emission control system malfunction (p0440),
and evap system vent control low imput. We replaced the y-pipe and cats, now runs even worse. If revs go below 4000, the engine just about dies. While we were waiting for cats to come in, the shop put a straight pipe in, and the car ran fine. They installed the cats today and its bad again. Does anyone have any ideas why this would happen?
Mike
Susie's Suby is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aaargh! Help me Neek! Help me Tom Cruise! banman Off-Topic 16 09-08-2006 01:50 AM
Help Me, Help Me, Help Me! againstdan Newbies & FAQs 9 11-11-2005 10:26 PM
I need to get a sound clip from ATHF... help me Obi W... I mean help me OT! Asinine Off-Topic 7 03-03-2005 12:33 PM
Help Me! Help Me Please! wrxxxappeal Factory 2.0L Turbo Powertrain 8 05-10-2003 11:14 AM
Help me/Help YOu/Help ME MichiganRS General Forum Archive 7 12-15-2000 08:54 AM


All times are GMT -4. The time now is 01:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.