Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-20-2008, 03:48 PM   #326
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

For the wiring, I would highly suggest getting the merge done by ECS or some other place. ECS though, I would highly recommend as they have experience doing the BE/BH engine swap...

I think ten80 voiced his opinion that in hindsight he wouldve paid someone to do the merge himself...
* Registered users of the site do not see these ads.
rougeben83 is offline   Reply With Quote
Old 05-29-2008, 12:09 AM   #327
BeckaSki
Scooby Newbie
 
Member#: 40535
Join Date: Jul 2003
Location: Issaquah, WA
Vehicle:
'00 Red LegacyGT w/
'03 Stage 2 WRX Swap

Default

I discovered an interesting new issue with the car recently. When I stop the car and leave it in reverse, and turn the key off, the car stays on, engine running, dash lit up, everything. It's very very odd and quite disconcerting. It stays on until the shifter is pushed into neutral without engaging the clutch. We have no idea if it's done this all along, since I usually park it in neutral, but the hilly northwest is changing up my routine. Anybody know what might cause this?

Also, here's a picture from the tulip festival in Skagit County last month. My boss and I were in Bellingham for a meeting and stopped by on the way home. She mocked me profusely, so enjoy.

BeckaSki is offline   Reply With Quote
Old 05-29-2008, 01:06 AM   #328
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

wait, how is it not stalling when left in reverse and clutch out?
rougeben83 is offline   Reply With Quote
Old 05-29-2008, 02:20 AM   #329
ten80
Scooby Specialist
 
Member#: 53625
Join Date: Jan 2004
Location: WA
Vehicle:
00 EJ205 LGT LTD

Default

She means in reverse, ignition off, clutch in, and car stays on.
ten80 is offline   Reply With Quote
Old 05-29-2008, 04:40 AM   #330
Plays_With_toys
Scooby Specialist
 
Member#: 82556
Join Date: Mar 2005
Location: Parker, Colorado
Vehicle:
1996 Legacy L wagon

Default

I think he was confused about this part:

Quote:
It stays on until the shifter is pushed into neutral without engaging the clutch.
Very strange indeed. Still one of my favorite cars in colorado though.
Plays_With_toys is offline   Reply With Quote
Old 05-29-2008, 11:00 AM   #331
ten80
Scooby Specialist
 
Member#: 53625
Join Date: Jan 2004
Location: WA
Vehicle:
00 EJ205 LGT LTD

Default

Not quite, the car has been in Washington for a year now and I get to go play with it next week
ten80 is offline   Reply With Quote
Old 05-29-2008, 03:55 PM   #332
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

Hmm, do you think it has something to do with the clutch switch/ignition wiring being crossed up somewhere?

I got to see if that works on my car now

Did you even get the boost spike resolved?
rougeben83 is offline   Reply With Quote
Old 05-29-2008, 11:33 PM   #333
BeckaSki
Scooby Newbie
 
Member#: 40535
Join Date: Jul 2003
Location: Issaquah, WA
Vehicle:
'00 Red LegacyGT w/
'03 Stage 2 WRX Swap

Default

Quote:
Originally Posted by rougeben83 View Post
Did you even get the boost spike resolved?
Nope. Christophe is still in Colorado for graduate school, so he only hangs out in Washington with the car once a month or so, and we usually do other things instead of work on the car. It's on the list for when he's here for longer later this summer.
BeckaSki is offline   Reply With Quote
Old 05-07-2010, 02:11 PM   #334
Mr Evolution
Scooby Newbie
 
Member#: 103333
Join Date: Dec 2005
Location: NYC
Default

any updates with this car?

I want to know for longterm

Thanks a lot for the write up and this thread should be stickied
Mr Evolution is offline   Reply With Quote
Old 05-07-2010, 08:15 PM   #335
matty2hotty
*** Banned ***
 
Member#: 145838
Join Date: Apr 2007
Chapter/Region: NWIC
Location: Tacoma, Washington
Vehicle:
01 B4 LGT "Sedan"
DR

Default

+1 for updates
matty2hotty is offline   Reply With Quote
Old 05-07-2010, 11:26 PM   #336
L_C99
Scooby Newbie
 
Member#: 225787
Join Date: Oct 2009
Chapter/Region: MWSOC
Location: UP of Michigan
Vehicle:
2004 Impreza RSTI
PSM

Default

Just read this thread from top to bottom and enjoyed it all as a fellow BE owner. Too bad I have no ambition and no money.
L_C99 is offline   Reply With Quote
Old 06-28-2010, 10:38 AM   #337
njdriver04
Scooby Newbie
 
Member#: 248747
Join Date: Jun 2010
Chapter/Region: Tri-State
Location: East Coast Americas
Vehicle:
04' SG XT
Blk

Default

would there any difference if this was done with a 04 sti?
njdriver04 is offline   Reply With Quote
Old 06-28-2010, 09:25 PM   #338
ten80
Scooby Specialist
 
Member#: 53625
Join Date: Jan 2004
Location: WA
Vehicle:
00 EJ205 LGT LTD

Default

Quick update-

car still runs fine with over 30k miles on the swap. Boost spike at WOT due to serious leaks from the silicone intercooler hoses- took a long time to figure out but was easy to fix! Boost is not rock-solid going up hills using cruise control, but I don't have the patience to figure that one out.

Also have a small issue when driving in traffic and warm weather; the idle RPMS get higher with every stop and eventually reach near 3000 RPM when stopped at lights. Pulling the gas pedal up with my toe brings them down a bit (~1500 RPM). I've checked the throttle cable, have flushed the radiator fluid, and installed an Grimmspeed thermostat. Don't think it's a cooling issue, but have no idea what to look at next.

Nothing new to report, I've just done basic maintenance on the car and have no plans for any upgrades or changes.

Swapping in an 04 STI would be essentially the same, except you'd might run into complications with the rear axles, I think they differ for R160 and R180 rear diffs, but I've not thought about it for a long time.
ten80 is offline   Reply With Quote
Old 12-21-2012, 08:34 PM   #339
b4Legacy02
*** Banned ***
 
Member#: 341267
Join Date: Dec 2012
Chapter/Region: SCIC
Location: Los Angeles, CA
Vehicle:
05 Legacy / 04 WRX

Default

any updates on this build how the car runs?
b4Legacy02 is offline   Reply With Quote
Old 02-03-2013, 09:28 AM   #340
97ej22e
Scooby Newbie
 
Member#: 327710
Join Date: Jul 2012
Chapter/Region: NESIC
Location: Sanford, Maine
Vehicle:
1999 Impreza OBS
Green

Default

This is an awesome build thread! I may be doing the same thing to my 98 Outback eventually.
97ej22e is offline   Reply With Quote
Old 02-07-2013, 03:10 AM   #341
Fuzzyfuzz
Scooby Newbie
 
Member#: 284245
Join Date: May 2011
Default

[quote=BeckaSki;22448081]I discovered an interesting new issue with the car recently. When I stop the car and leave it in reverse, and turn the key off, the car stays on, engine running, dash lit up, everything. It's very very odd and quite disconcerting. It stays on until the shifter is pushed into neutral without engaging the clutch. We have no idea if it's done this all along, since I usually park it in neutral, but the hilly northwest is changing up my routine. Anybody know what might cause this?/QUOTE]

My stock 02 Legacy does this. Check it out:

Anybody know what's up with that?
Fuzzyfuzz is offline   Reply With Quote
Old 02-25-2013, 11:24 PM   #342
ten80
Scooby Specialist
 
Member#: 53625
Join Date: Jan 2004
Location: WA
Vehicle:
00 EJ205 LGT LTD

Default

Hadn't been on here for so long that I forgot my login....

anyways, it seems that the swap is not the cause of the "on while in reverse" issue. Good to know about this little quirk.

Car still runs great with 190k on the chassis, and we swapped in the engine (with 60k miles) at 127k. Grimmspeed thermostat failed shortly after I installed it and I'm back to a stock thermostat. Have been running Shell Rotella T-6 5w40 for the last 30k or so and the car only consumes 1/2 qt between oil changes (4,500-5,000k intervals). Need to replace door window seals and a few little minor things but mechanically it is sound.
ten80 is offline   Reply With Quote
Old 03-01-2013, 02:04 PM   #343
wfo250
Scooby Newbie
 
Member#: 264111
Join Date: Nov 2010
Location: ABQ
Default

Looks like the swap worked out pretty good, I might pick your brain as my swap commences.
wfo250 is offline   Reply With Quote
Old 03-01-2013, 05:17 PM   #344
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

nice to see you're still driving the lego!
rougeben83 is offline   Reply With Quote
Old 03-02-2013, 01:19 AM   #345
BE5Legacy
Scooby Newbie
 
Member#: 347875
Join Date: Feb 2013
Vehicle:
2005 LGT

Default

Good to know you still have the BE swap. I wanna do this to my BE as well but a automatic turbo swap.
BE5Legacy is offline   Reply With Quote
Old 03-20-2013, 09:07 PM   #346
Sneeky Pete
Scooby Specialist
 
Member#: 97745
Join Date: Oct 2005
Chapter/Region: MWSOC
Location: Chicago-Subs
Vehicle:
2005 OBXT 5spd red
05 OB Lmited Black

Default

Hell yea, I remember this one, good to see it still hittin them corners. Inspiring write up, I may not have my bh any more but I always wished I did this to it.
Sneeky Pete is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Swap 2.0L WRX or 2.5L WRX into my 00RS Rallly2000 Subaru Conversions 1 09-23-2008 09:32 PM
FS: Subaru Legacy JDM Aero Grille 2000-2004 BE BH B4 *MINT* MYfirst00 Legacy Specific Parts 13 05-09-2007 09:52 AM
FS: Fidanza Flywheel, NEW, 9.5lbs, Fits 2.0l WRX and 2.5l NA Impreza/Legacy $300 obo joltdudeuc Drivetrain 12 02-25-2007 10:00 PM
2000-2004 BE/BH Legacy GT Headlight/DRL/Fog Mods ryankenn Electrical & Lighting 4 12-21-2006 09:52 PM
FS: 2.0L WRX Turbo Motor complete ComTekAuto Private 'For Sale' Classifieds 0 04-24-2006 06:51 PM


All times are GMT -4. The time now is 12:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.