Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-23-2008, 09:08 PM   #1
bjwk89
Scooby Specialist
 
Member#: 175615
Join Date: Mar 2008
Chapter/Region: Tri-State
Location: nepa
Vehicle:
2005 STi
Black Stg. 2

Default passenger side head light not working?

i posted in the newbies forum also but thought i'd hit up here too. The other week with all OEM bulbs my 1 headlight and 1 brake light went out. The brake bulb actually exploded into pieces. I then replaced that brake bulb with a generic one. i wanted bulbs from danielstern but he never got back to me and i wasn't really ready to buy all good bulbs right now, so i just got the generic sylvania silverstars because my friend uses them and they seem pretty decent, so i figured why not. A few days later both my brake light and headlight went out again, i had a 2 pack of brake light bulbs so i put the other one in and it's doing ok, but now my passenger side headlight has no power to the regular driving light. I used a voltage meter to test it and the bulb socket is getting no power, the fuse area is fine, the relay is fine, all the fuses in the car seem good but im getting no power to the headlight. Anyone have any idea what i should do? i don't want to take it to subaru and get charged an arm and a leg, i have $50 in subie bucks but i'm not sure if i could use those yet plus i don't want to. Is there any else where a short would have disrupted the connection that i could go in and fix? If the fuses are fine where else would the connection be broken?

any help? i got pulled over for no headlight already, the cop was very understanding but i don't want to be a padiddle for much longer
bjwk89 is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB Passenger Side head light and corner marker Also Front Bumper and more 97 Impreza Jester of Paint Private 'Wanted' Classifieds 0 07-04-2009 12:39 PM
WTS: 07 STi passenger side head light *brand new* Evil_STI Exterior/Styling 1 12-31-2008 11:08 AM
2004 Hid Passenger Side Head Light New FOR SALE thekidran Exterior/Styling 1 09-27-2007 12:32 AM
STi passenger side head light CarQz17 Private 'Wanted' Classifieds 0 07-13-2006 12:48 PM
WTB: JDM passenger side head light 02-03, working or broken. pleue Private 'Wanted' Classifieds 0 02-23-2006 12:41 AM


All times are GMT -4. The time now is 08:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.