Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-08-2008, 11:17 PM   #1
mchrenen
Scooby Newbie
 
Member#: 72427
Join Date: Oct 2004
Chapter/Region: MWSOC
Location: W. Suburbs, IL
Vehicle:
03 WRX MBP - sold!
07 FXT Sports UGM FTW

Question things that are NOT working on my WRX

1) passenger side EDM headlight. Just replaced the H1 bulbs and then tried the associated fuses, no luck. The drl still works though.
2) cruise control
3) horn

are these things related or am I just having bad luck Any suggestions? thanks
mchrenen is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C is not working on '04 WRX mattswrxnc Factory 2.0L Turbo Powertrain 12 08-28-2012 10:49 AM
Gauges not working on 02 WRX jjs316 Factory 2.0L Turbo Powertrain 6 06-30-2008 05:02 PM
For those of you that are not working today Matt_H Mid Atlantic Impreza Club -- MAIC 19 12-23-2006 07:07 PM
OT: Some pictures of what I work on when I am not working on my RS. paultg New England Impreza Club Forum -- NESIC 15 07-06-2001 05:48 AM
Attn. Chad, Kris and all that are helping work on my car. bill harvey New England Impreza Club Forum -- NESIC 2 07-20-2000 06:35 PM


All times are GMT -4. The time now is 09:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.