Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-12-2008, 02:05 AM   #1
chargerbry
Scooby Newbie
 
Member#: 154007
Join Date: Jul 2007
Chapter/Region: NWIC
Location: Aloha Oregon
Vehicle:
2004 WRX Evo3 16g'D
07 6 speed

Default Weird tranny noise with new light flywheel and clutch??

I changed my factory flywheel out with an ACT pro light and then installed a centerforce dual friction clutch. The instant I drove it it felt great however it also instantly started to make tranny noise when I am compressioning down off the gas like either a bad bering noise or sycros just going crazy. As soon as I touch the gas it goes away. 2 days later the centerforce pressure plate exploded so I went to the Exedy stage 2 3 puck disk with matching pressure plate. It still makes the same noise. At first I thought is was the clutch but I now figure the flywheel does it cause it makes the same noise with both clutches. Anyone else have this noise after installing a light flywheel. I hope its only sycros whinning cause of the "less rotating mass" rather than maybe I found a bering problem when I lightened it up?

Any feedback would be appreciated
Bryan

Last edited by chargerbry; 08-12-2008 at 02:12 AM.
chargerbry is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird tranny noise and lots of metal on plug frederik Transmission (AT/MT) & Driveline 14 03-24-2009 05:00 PM
05 STI weird tranny noise with dccd set to open Ray_STi Transmission (AT/MT) & Driveline 1 10-23-2008 10:19 PM
light flywheel and clutch? STIred05 Transmission (AT/MT) & Driveline 3 11-14-2006 06:57 PM
Light Flywheel and Sport Clutch kit *new* nhluhr Private 'For Sale' Classifieds 2 04-23-2004 08:47 PM
weird tranny noises shortfuseWRX Transmission (AT/MT) & Driveline 4 12-16-2003 09:58 PM


All times are GMT -4. The time now is 11:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.