Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2008, 05:40 PM   #1
jetblue2004
Scooby Newbie
 
Member#: 194230
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: New york
Vehicle:
2004 Subaru
WRB

Default Cruise control light keep flashing whats up with that

My cruise control light keeping flashing until i reset ecu ,what could be the problem any ideas ?
* Registered users of the site do not see these ads.
jetblue2004 is offline   Reply With Quote
Old 11-19-2008, 05:41 PM   #2
ryan_13
Scooby Specialist
 
Member#: 191604
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Western Mass
Vehicle:
2004 STI Stage 2
Aspen White

Default

do you have a catless exhaust?
ryan_13 is offline   Reply With Quote
Old 11-19-2008, 06:14 PM   #3
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

filling out your profile would help
ive heard that some cars with the cruise controls (all the controls) on the steering column/steering wheel have been known to wear out and sag/cause problems
ex is a 04 sti
again, fill out your profile
Jncominco2 is offline   Reply With Quote
Old 11-20-2008, 05:34 PM   #4
jetblue2004
Scooby Newbie
 
Member#: 194230
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: New york
Vehicle:
2004 Subaru
WRB

Default

it has a 3inch perrin turbo back exaust


Quote:
Originally Posted by ryan_13 View Post
do you have a catless exhaust?
jetblue2004 is offline   Reply With Quote
Old 11-20-2008, 05:38 PM   #5
jetblue2004
Scooby Newbie
 
Member#: 194230
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: New york
Vehicle:
2004 Subaru
WRB

Default

Quote:
Originally Posted by Jncominco2 View Post
filling out your profile would help
ive heard that some cars with the cruise controls (all the controls) on the steering column/steering wheel have been known to wear out and sag/cause problems
ex is a 04 sti
again, fill out your profile

thats what i thought to but when i reset the ecu it doesn't flash until i start hitting the gas pedal hard.
jetblue2004 is offline   Reply With Quote
Old 11-20-2008, 05:49 PM   #6
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

maybe you should get the codes checked before you reset the ECU
munkis is offline   Reply With Quote
Old 11-20-2008, 06:05 PM   #7
jetblue2004
Scooby Newbie
 
Member#: 194230
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: New york
Vehicle:
2004 Subaru
WRB

Default

Quote:
Originally Posted by munkis View Post
maybe you should get the codes checked before you reset the ECU

dont have a factory ecu can i still chk the codes with the aftermarket ecu the same?
jetblue2004 is offline   Reply With Quote
Old 11-21-2008, 10:36 AM   #8
drdabbles
Scooby Newbie
 
Member#: 110229
Join Date: Mar 2006
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
2004 WRX STi
Java Black

Default

Yes. For future reference, when something on the dash starts flashing (there are TONS of threads on here with the exact title as yours...a simple search would have answered your question instantly), get your codes read. It can be something simple like the O2 sensor is reading something strange, or it could be your cams not advancing...as it was in my case. Driving around with something wrong CAN do serious harm, and if you car is new enough to be covered by a warranty, SOA can tell you to stuff it. They probably wont, but they certainly could.
drdabbles is offline   Reply With Quote
Old 11-21-2008, 01:08 PM   #9
Engmus
Scooby Specialist
 
Member#: 115645
Join Date: May 2006
Chapter/Region: MAIC
Location: South-East PA
Default

Jetblue2004.

You filled in 2004 Subaru WRX.

Please list Mileage and ALL mods pertaining to ECU Tuning, Power, and Drive-train. Suspension, cosmetic and audio modifications shouldn't be causing this kind of issue.

With that information we can better diagnose your issue.

You say it happens when you "hit the gas hard" do you have a tune? How long has this been happening? Did it happen before a certain modification? What ECU do you have? You said it was different?

Did you mean aftermarket ECU, or aftermarket tune?

Thanks
Engmus is offline   Reply With Quote
Old 11-21-2008, 05:36 PM   #10
jetblue2004
Scooby Newbie
 
Member#: 194230
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: New york
Vehicle:
2004 Subaru
WRB

Default

Quote:
Originally Posted by Engmus View Post
Jetblue2004.

You filled in 2004 Subaru WRX.

Please list Mileage and ALL mods pertaining to ECU Tuning, Power, and Drive-train. Suspension, cosmetic and audio modifications shouldn't be causing this kind of issue.

With that information we can better diagnose your issue.

You say it happens when you "hit the gas hard" do you have a tune? How long has this been happening? Did it happen before a certain modification? What ECU do you have? You said it was different?

Did you mean aftermarket ECU, or aftermarket tune?

Thanks

i have a turboxs ecu and perrin intake and 3inch exaust and turboxs boost controller and if i reset the ecu by diconnecting the battery for a min it will go away until start hitting the gas hard and building boost.
jetblue2004 is offline   Reply With Quote
Old 11-22-2008, 11:50 AM   #11
Engmus
Scooby Specialist
 
Member#: 115645
Join Date: May 2006
Chapter/Region: MAIC
Location: South-East PA
Default

^That could be alot of things, based off that maybe you are hitting fuel cut.

Does your car suddenly "Lurch" like you've hit a imaginary wall?

Did you get tuned or just kind of throw everything together and hope for the best?

I have a feeling you are in need of a tune.
Engmus is offline   Reply With Quote
Old 11-22-2008, 03:49 PM   #12
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

you don't have an aftermarket ecu. You still have a factory one with a piggyback controller ontop. like Engmus said, read the codes... get a tune
sidewayz is offline   Reply With Quote
Old 10-09-2010, 10:49 PM   #13
cky211
Scooby Specialist
 
Member#: 31129
Join Date: Dec 2002
Chapter/Region: NWIC
Location: Spokane WA
Vehicle:
02 WRX MPB
No TGV + lots of P&P

Default

flashing cruise control with no CEL I searched & searched on this anybody have info?
cky211 is offline   Reply With Quote
Old 11-22-2010, 08:49 AM   #14
urotsukidoji
Scooby Newbie
 
Member#: 54583
Join Date: Feb 2004
Location: Raleigh
Vehicle:
2004 WRX STi
Java Black

Unhappy

having similar issues with my '04 STi. Flashing cruise, imaginary wall, CEL... mental drain. Had a new 02 sensor installed, no luck. Had tune-up a month ago so i doubt its the plugs but maybe the pack or distributor. Trying to get it to TurboTime.
urotsukidoji is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 03:42 PM
check engine light + flashing cruise control light ericmwas Newbies & FAQs 6 08-24-2009 11:21 PM
CEL came on, and Cruise Control light is flashing 07Wagon Factory 2.5L Turbo Powertrain 14 12-31-2007 12:12 PM
Check engine light on and cruise control light flashing mpadovano Factory 2.5L Turbo Powertrain 6 01-23-2005 02:04 PM
help 3 screws whats up with that???? chillN 2.5RS Car Audio, Video & Security 10 01-10-2001 01:35 AM


All times are GMT -4. The time now is 03:27 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.