Welcome to the North American Subaru Impreza Owners Club Monday March 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-29-2008, 01:14 PM   #1
loki12487
Scooby Newbie
 
Member#: 140781
Join Date: Feb 2007
Chapter/Region: TXIC
Location: San Antonio TX
Vehicle:
2013 STI
CBS

Default coolant overheating issue need help asap

i'm having an issue with my car overheating while im on the highway the gauge will start moving towards the red area and then it will drop close to the normal range. i've changed the coolant and it hasn't fixed the problem. could i possibly have a problem with the thermostat?
loki12487 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
coolant issues. need help! ImprezivEJ20 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 10-22-2008 05:38 PM
WTB wrx coolant reservoir tank. Need it asap! ki11switch NWIC Private Classifieds 5 09-24-2008 02:53 PM
serious, serious issues... need help ASAP with turbo placement silentt Normally Aspirated with bolt-on Forced Induction Powertrain 25 09-03-2007 07:53 PM
strange issue..freaking me out need help asap. willguidry Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 29 09-14-2006 12:47 PM
UTEC tuning issues need help asap Sharky NRK Engine Management & Tuning 6 11-11-2005 06:23 PM


All times are GMT -4. The time now is 09:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.