Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-08-2006, 07:11 PM   #1
mdd1986
Scooby Specialist
 
Member#: 83450
Join Date: Mar 2005
Chapter/Region: Tri-State
Location: Westchester NY
Vehicle:
2000 Audi S4 Stage 3
Silver

Default P0137 code

I keep throwing this code with my catless exhaust. I have the ap so it can not be from being catless. Does this mean that my o2 sensor is shot. Also any1 know where i can get an o2 sensor for cheap?
* Registered users of the site do not see these ads.
mdd1986 is offline   Reply With Quote
Old 11-10-2006, 04:20 PM   #2
BuffaloUPSGuy
Scooby Newbie
 
Member#: 89427
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Buffalo, NY
Vehicle:
2005 Legacy GT STi
Regal Blue Pearl

Default

Stage 1 or 2? Stage 1 won't kill some of the codes that stage 2 does (if I remember correctly from my setup).
BuffaloUPSGuy is offline   Reply With Quote
Old 11-10-2006, 06:16 PM   #3
hulkSTi
Scooby Newbie
 
Member#: 96355
Join Date: Sep 2005
Chapter/Region: South East
Vehicle:
2005 STi
OBP

Default

i thread that code and one of my wires in the o2 was bad. i just fixed the wire and it was good to go
hulkSTi is offline   Reply With Quote
Old 11-10-2006, 06:19 PM   #4
TMessick
Scooby Newbie
 
Member#: 882
Join Date: Feb 2000
Location: Michigan
Vehicle:
2004 WRX Wagon
very blue

Default

P0137 = downstream O2 sensor shorted low. Basically means your rear O2 is reading like 0 volts. Most likely cause is the rear O2 signal wire shorted to ground, although it's also possible that you have an issue with the rear O2 sensor. Check your wiring before you go replacing stuff..
TMessick is offline   Reply With Quote
Old 11-10-2006, 06:57 PM   #5
hulkSTi
Scooby Newbie
 
Member#: 96355
Join Date: Sep 2005
Chapter/Region: South East
Vehicle:
2005 STi
OBP

Default

Quote:
Originally Posted by TMessick View Post
P0137 = downstream O2 sensor shorted low. Basically means your rear O2 is reading like 0 volts. Most likely cause is the rear O2 signal wire shorted to ground, although it's also possible that you have an issue with the rear O2 sensor. Check your wiring before you go replacing stuff..
yep, mine had a bad wire.
hulkSTi is offline   Reply With Quote
Old 11-16-2006, 01:48 PM   #6
mdd1986
Scooby Specialist
 
Member#: 83450
Join Date: Mar 2005
Chapter/Region: Tri-State
Location: Westchester NY
Vehicle:
2000 Audi S4 Stage 3
Silver

Default

ok thx i will do that
mdd1986 is offline   Reply With Quote
Old 08-21-2008, 11:03 AM   #7
rhinotech
Scooby Specialist
 
Member#: 144880
Join Date: Mar 2007
Chapter/Region: TXIC
Location: Cajun Country
Vehicle:
03 Civic
Rollin' hard...

Default

bump this thread....

I have this code.. will this make the car run funky?
rhinotech is offline   Reply With Quote
Old 08-21-2008, 11:28 AM   #8
Haelan
Scooby Specialist
 
Member#: 151045
Join Date: Jun 2007
Location: NW Indiana
Vehicle:
2013 Subaru STI
CBP

Default

P0137 — O2 SENSOR CIRCUIT LOW VOLTAGE (BANK 1 SENSOR 2)

FAIL SAFE
Sub feedback control: Not allowed


I'm not sure what 'sub feedback control' entails. I'm interested to learn something new if someone else knows the answer.


Edit:

Google to the rescue.

"A sub-feedback control is performed, by which the
upstream-side target air-fuel ratio is corrected so that the air-fuel
ratio detected by the downstream-side exhaust gas sensor becomes equal to
a downstream-side target air-fuel ratio."

Sounds to me like the rear O2 readings are used as correction values for the front O2 readings. Though that goes against what everyone here on NASIOC states that it won't change performance. It could theoretically make your car run slightly richer or leaner during closed-loop fueling. Again, this is only in place for emissions, but the rear O2 does seem to have an effect.

With P0137 enabled there is no correction based on the rear O2. If anything I would think the car would run better.

Please chime in if I'm off base here....

Last edited by Haelan; 08-21-2008 at 11:55 AM.
Haelan is offline   Reply With Quote
Old 11-28-2008, 02:21 PM   #9
IH8-V8
Scooby Newbie
 
Member#: 69655
Join Date: Sep 2004
Default

I am wrestling with the P0137 code as well on my 2004 STi. Prior to upgrading my "firmware" on my accessport v2 I never had a problem. I recently upgraded my firmware, and now whenever I drive on the highway, like clockwork, 20 min into the drive my CEL (and also my cruise control light) starts to flash. It is always a p0137 code. I read in previous posts a few months back that not all stage 1 mapping deletes this code. So, I went with a stage 2 map and I am still having a problem. I am actually going outside now to check my o2 wiring based on the suggestions above. Bottom line, I need to get this figured out ASAP---I am due for a NYS inspection!!! If anyone has any thoughts I am willing to try anything...
IH8-V8 is offline   Reply With Quote
Old 11-29-2008, 06:10 PM   #10
SuperHawk
Scooby Newbie
 
Member#: 1036
Join Date: Mar 2000
Location: Las Vegas, NV USA
Vehicle:
2006 WRX Wagon Ltd.
WRB

Default

If you look at the codes that should be inhibited in the map notes from Cobb that is one of them. If you have an aftermarket tune from another tuner then they need to inhibit the code. I had the same problem after someone custom tuned my car they forgot to inhibit the CEL codes.

So if you have an access port down load the latest version of the map that you are using and just re-flash the ecu!

Dennis
SuperHawk is offline   Reply With Quote
Old 11-30-2008, 11:11 AM   #11
prwatts
Scooby Newbie
 
Member#: 194393
Join Date: Nov 2008
Default

Quote:
Originally Posted by SuperHawk View Post
If you look at the codes that should be inhibited in the map notes from Cobb that is one of them. If you have an aftermarket tune from another tuner then they need to inhibit the code. I had the same problem after someone custom tuned my car they forgot to inhibit the CEL codes.

So if you have an access port down load the latest version of the map that you are using and just re-flash the ecu!

Dennis
Sorry to be dumb - where are the O2 sensors and how many are there?
prwatts is offline   Reply With Quote
Old 11-30-2008, 11:52 AM   #12
ASU
Scooby Specialist
 
Member#: 164551
Join Date: Nov 2007
Chapter/Region: SWIC
Location: Baumholder, Deutschland
Vehicle:
2006 Brotastic STi
Land of beer and laws

Default

Quote:
Originally Posted by prwatts View Post
Sorry to be dumb - where are the O2 sensors and how many are there?
Dude fill out your profile and read the newbie FAQ's !
ASU is offline   Reply With Quote
Old 11-30-2008, 04:23 PM   #13
SuperHawk
Scooby Newbie
 
Member#: 1036
Join Date: Mar 2000
Location: Las Vegas, NV USA
Vehicle:
2006 WRX Wagon Ltd.
WRB

Default

The one that causes this problem is in the down pipe.
SuperHawk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P0137 and P0140 jonpark Factory 2.5L Turbo Powertrain 6 09-02-2010 06:47 PM
check engine light code P0137 o2 sensor circuit low voltage bank 1 sensor 2 duque Engine Management & Tuning 1 05-09-2010 01:43 AM
Codes P2096 & P0137 SLCDUB Factory 2.5L Turbo Powertrain 2 08-04-2007 11:15 PM
P0137 Check engine light code 03WRX83 Factory 2.0L Turbo Powertrain 5 12-15-2003 06:56 PM
P0137 CEL Code ?? KanosWRX Factory 2.0L Turbo Powertrain 0 10-27-2003 07:59 PM


All times are GMT -4. The time now is 12:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.