Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-07-2008, 07:33 PM   #1
lagodcm
NASIOC Supporter
 
Member#: 164038
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Boise, ID
Vehicle:
2013 WRX STAGE 2
Ice Silver

Default Turbo oil suppy...No Filter in Banjo bolt?

Doing my 20g install....I can't find a filter anywhere. Is it the oil line from turbo directly to the block that should have the filter
* Registered users of the site do not see these ads.
lagodcm is offline   Reply With Quote
Old 12-07-2008, 08:32 PM   #2
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

ya pretty sure its that line

the one line coming off the top of the turbo to the block
gtasti is offline   Reply With Quote
Old 12-07-2008, 09:32 PM   #3
lagodcm
NASIOC Supporter
 
Member#: 164038
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Boise, ID
Vehicle:
2013 WRX STAGE 2
Ice Silver

Default

Yea, There was no filter in the bolt....
lagodcm is offline   Reply With Quote
Old 12-07-2008, 10:14 PM   #4
woodys77
Scooby Specialist
 
Member#: 192147
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2007 STI EfiLogics
422whp 421wtq fpgreen

Default

my 06 wrx didnt have the filter either. forcedperformance said they have seen some 06's without and some with it.
woodys77 is offline   Reply With Quote
Old 12-08-2008, 02:00 AM   #5
lagodcm
NASIOC Supporter
 
Member#: 164038
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Boise, ID
Vehicle:
2013 WRX STAGE 2
Ice Silver

Default

Quote:
Originally Posted by woodys77 View Post
my 06 wrx didnt have the filter either. forcedperformance said they have seen some 06's without and some with it.
When I took the bolt out I looked in the hole with a mirror/flashlight...I saw something that look brass like, but that was in the bolt hole....I stuck a screwdriver in there and nothing felt loose.
lagodcm is offline   Reply With Quote
Old 12-08-2008, 01:35 PM   #6
lagodcm
NASIOC Supporter
 
Member#: 164038
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Boise, ID
Vehicle:
2013 WRX STAGE 2
Ice Silver

Default

I called my dealership....The guy looked up 06 wrx in his computer for the filters and nothing came up. I guess they were never there.
lagodcm is offline   Reply With Quote
Old 12-08-2008, 09:17 PM   #7
woodys77
Scooby Specialist
 
Member#: 192147
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2007 STI EfiLogics
422whp 421wtq fpgreen

Default

i pmed you i hope it helps. !!!!!!!!!!!please dont forget to oil the turbo before you start the car!!!!!!!!!!!!!!!!!.
woodys77 is offline   Reply With Quote
Old 12-09-2008, 07:41 AM   #8
Woodward
Scooby Specialist
 
Member#: 102424
Join Date: Dec 2005
Chapter/Region: BAIC
Location: Patterson, CA
Vehicle:
2003 Tundra
GrEy

Default

There was a bulletin or something about these. I know Subaru was removing them bc they were causing problems and starving turbos.
Woodward is offline   Reply With Quote
Old 12-11-2008, 09:02 AM   #9
pjm
Scooby Newbie
 
Member#: 73755
Join Date: Nov 2004
Chapter/Region: MWSOC
Vehicle:
05 STI

Default

I just ran into that bulletin somewhere on the internet. Sorry I don't have the link. I don't recall where I was.

Woodward is right on. Starving turbos was the issue. The bulletin listed VIN patterns for determining whether you had the filter or not. If I remember right, they dropped the filter for STI's after April of 2005. I don't remember if it was the same for WRX's, though.
pjm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo Oil Feed Line Filter emsfd125 Newbies & FAQs 4 01-03-2010 07:50 PM
Turbo Oil Supply Line Filter Ques. e[tx] Newbies & FAQs 3 07-18-2008 10:53 PM
IMPORTANT:filters in banjo bolts k mier Factory 2.5L Turbo Powertrain 9 05-07-2007 06:10 AM
Help! No filters in oil lines! cheek_FXT Factory 2.5L Turbo Powertrain 1 03-01-2006 04:52 AM
Oil feed line, what size banjo bolt for the block? CMJ Factory 2.0L Turbo Powertrain 4 07-14-2005 09:42 PM


All times are GMT -4. The time now is 10:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.