Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South East Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > South East Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-01-2002, 12:30 PM   #1
scoobiblue
Scooby Newbie
 
Member#: 15697
Join Date: Feb 2002
Location: Orlando, Fl
Vehicle:
2002 Impreza WRX
WR Blue Pearl

Default Alignment experience from Hell

Yesterday I went to get my car aligned at Allied Discount Tire. I looked around for someone that had a nice alignment machine. This store just got a new Hunter machine a month ago. So I said let's do it. I recently put on suspension items; New rims and tires, sway bars, end links, H/D sway bar mounts and front ALK.
They started with the back. The guy doing the work showed me the rear camber readings. The right side was at -1.3 deg and the left was at -2.10 deg. On the WRX you can not adjust the camber. I don't understand why the left is so far off when it should be -1.30.
Next he went to the front. He could not break loose the bolts to do the camber alignment. He broke a universal and a socket trying. So he only did the toe. The camber was at 0.5 left and 0.6 right. He set toe at 0.0. I wanted to get a 1.0 deg camber. He said they would have to heat up the bolts to break them and they really did not want to do it.
Why is the camber so far off in the rear? Should I get a camber kit? Could some of the work I did have screwed things up? What should I do about the front bolts they can not break?

Where is the bolt they are having troubles breaking? Maybe I can break them at home with my tools or go to the dealership and have them break. I just didn't want the dealership to see my car since I did suspension work. Afraid they would be pissed.

HELP!!!!
scoobiblue is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Addison Wheel Alignment Experiences? proletariandan Mid West Subaru Owners Club Forum -- MWSOC 9 04-11-2009 07:22 PM
SW Alignment experience NeoteriX Texas Impreza Club Forum -- TXIC 3 06-05-2004 12:03 AM
My alignment experience at trueline (Kearny mesa)... illmatic Southern California Impreza Club Forum -- SCIC 3 01-03-2003 08:39 PM
Alignment experiments = rubbbing in rear... need suggestions Steve E Brakes, Steering & Suspension 2 09-05-2002 02:31 PM
Bad alignment experience Scoobiblue Jr. Brakes, Steering & Suspension 3 09-02-2002 01:14 AM


All times are GMT -4. The time now is 05:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.