Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-15-2009, 09:53 AM   #1
06HAWKMAN
Scooby Specialist
 
Member#: 166626
Join Date: Dec 2007
Chapter/Region: RMIC
Location: salt lake city utah
Vehicle:
2006 wrx ewg vf39'd
obp

Default External w/g chattering help.

Ok before you ask i did do a search, and here is all relative info. 2006 wrx, vf39, sti topmount, hoa boost solenoid, cobb downpipe, invidia catback, cobb airbox, and the part in question grimmspeed/tial 44 ewg
Ok so i got tuned yesterday and am very happy, John at cobb is an amazing tuner and did everything i wanted to the car and it pulls very hard, on a low reading mustang dyno it put down 280 whp and 290 wtq. Also i had solid auto install the ewg and noah down there also did a very amazing job. Thanks to both of you very much! Now the question, when i start at around 2000 rpm and go full throttle i get this chatter sound from what i believe is my wastegate until i start to boost, it sounds like a paintball gun with no c02. it just makes a faint clacking sound like the piston inside the wastegate is not seating correctly. My boost does not fluctuate at all and holds very strong? also when i am approaching full boost it starts to flutter like crazy (this i believe is because my turbo is still to small and not pushing enough pressure?) so are these just the awesome sounds of a normally operating wastegate or do i need to have cobb/solid look at it? thank you for any input you guys might have!
06HAWKMAN is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help!!! flashing cel and no one can help tommy 02wrx Factory 2.0L Turbo Powertrain 21 06-05-2010 07:26 PM
External Waste Gate install help johnlattanzi Newbies & FAQs 23 03-17-2010 10:05 AM
External Wastegate Question plz help!!! ac23 Newbies & FAQs 1 06-08-2007 05:15 AM
97 Legacy GT AT Trans chatter, HELP? kecksubaru Transmission (AT/MT) & Driveline 1 09-27-2006 08:44 AM
How much is an external wastegate going to help? verc Factory 2.0L Turbo Powertrain 8 05-08-2005 09:38 AM


All times are GMT -4. The time now is 06:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.