Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-22-2009, 04:44 PM   #26
BIGSKYWRX
Scooby Guru
 
Member#: 7958
Join Date: Jul 2001
Location: Plains of Eastern Montana
Vehicle:
09 GH B+

Default

Quote:
Originally Posted by michaelpharvey View Post
Knock knock, rattle rattle....~400 miles. Build Date 9/08. VIN 5043XX. It's Sunday, so I guess I'll have to go visit the dealership tomorrow.

Add me to the list!

Am I the first with a 9/08 build date?
sorry to hear that
* Registered users of the site do not see these ads.
BIGSKYWRX is offline   Reply With Quote
Old 02-22-2009, 07:33 PM   #27
ScoobyNubieToo!
Scooby Specialist
 
Member#: 75234
Join Date: Nov 2004
Chapter/Region: Tri-State
Location: Williamstown, NJ
Vehicle:
2004 WRX Wagon with
07 STI 6-Speed Goodness!

Default

Holy crap! 150 miles and engine failure! WOW!
ScoobyNubieToo! is offline   Reply With Quote
Old 02-22-2009, 08:32 PM   #28
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Why did you remove those 6? I believe at that time I was keeping track of the list and all of those people, while not having responded to PM, did submit a post indicating that they experienced engine failure (we already sorted out all of the BS yes voters in the engine failure poll). Please send me a list of those 6 and I will attempt to contact them. As for why someone wouldn't respond to a PM, when I joined ClubRSX however many years ago I didn't realize I had a PM until about a year after it was sent...just never noticed. Frankly I'd keep them in the list...the more the merrier.

Also, I see we have our first September car! CONGRATULATIONS...you've just been duped into spending ~25k on an inferior product! Ha ahah haha...awe... I am a sad banana.
AshJWilliams is offline   Reply With Quote
Old 02-22-2009, 09:14 PM   #29
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by AshJWilliams View Post
Why did you remove those 6? I believe at that time I was keeping track of the list and all of those people, while not having responded to PM, did submit a post indicating that they experienced engine failure (we already sorted out all of the BS yes voters in the engine failure poll). Please send me a list of those 6 and I will attempt to contact them. As for why someone wouldn't respond to a PM, when I joined ClubRSX however many years ago I didn't realize I had a PM until about a year after it was sent...just never noticed. Frankly I'd keep them in the list...the more the merrier.
I like to think of the list as "confirmed" failures, or at least as close to confirmed as you can get when dealing with people reporting this stuff on a forum. For example, on the original list, there was a guy on there who had an 04 WRX with a spun bearing. I only discovered that because he happened to actually respond to my PM. If the VIN/build date are given, you can at least weed out these types of mistakes.

I'll go ahead and add the 6 back in as a footnote to the main list, but not counting them in the total. Feel free to see if you can get a hold of them.
Tea cups is offline   Reply With Quote
Old 02-23-2009, 02:41 PM   #30
fog hat
Scooby Newbie
 
Member#: 196426
Join Date: Dec 2008
Location: So-Cal
Vehicle:
2009 WRX 5 door
White-ish

Default

Fog Hat +1

At the same time I purchased my 09 WRX my father also purchased an 09 WRX 5 door (figured we would get a better deal buying two at the same time). This Saturday he joined myself and 26 others. Not sure of his VIN but if I remember correctly the VIN was real close to mine, I do know that it has an 08-08 build date.

I will post his VIN asap.

Last edited by fog hat; 02-24-2009 at 12:26 AM.
fog hat is offline   Reply With Quote
Old 02-23-2009, 02:44 PM   #31
fog hat
Scooby Newbie
 
Member#: 196426
Join Date: Dec 2008
Location: So-Cal
Vehicle:
2009 WRX 5 door
White-ish

Default

could not vote in the poll (not enough post yet?)
fog hat is offline   Reply With Quote
Old 02-23-2009, 10:47 PM   #32
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

OMG both you and your father have experienced 09 WRX engine failures?! That is ****ing horrible.
AshJWilliams is offline   Reply With Quote
Old 02-24-2009, 10:37 AM   #33
bailey1224
Scooby Newbie
 
Member#: 203886
Join Date: Feb 2009
Default engine failure

09 WRX with 2700 miles loud knocking noise engine failure....new car in the shop. Dont have my vin and build date on me since my car is in the shop. Will post that later tonight when i get it. Subaru claims to have never heard of this problem..and is saying my oil was low (which is was NOT) and since the oil was low i need a new engine...? exact words. what have the dealers been telling everyone else with this problem?
bailey1224 is offline   Reply With Quote
Old 02-24-2009, 02:51 PM   #34
BIGSKYWRX
Scooby Guru
 
Member#: 7958
Join Date: Jul 2001
Location: Plains of Eastern Montana
Vehicle:
09 GH B+

Default

sorry to hear that

I can't believe in this day and age of networking that the dealers are clueless on this issue- maybe two months ago- certainly not today. I'm beginning to believe that possibly this is some kind of "mum is the word" edict, the other possibility is the dealerships are living in a musty cave with no communication from the outside world- including from SOA.
BIGSKYWRX is offline   Reply With Quote
Old 02-24-2009, 03:07 PM   #35
bailey1224
Scooby Newbie
 
Member#: 203886
Join Date: Feb 2009
Default

yeah i kno. i talked to them today actually and they said that they had spoke with a rep from SOA and he also has never heard of this problem... Theyre replacing my engine atleast.
bailey1224 is offline   Reply With Quote
Old 02-25-2009, 01:14 PM   #36
Mighty E
Scooby Specialist
 
Member#: 152553
Join Date: Jun 2007
Chapter/Region: TXIC
Location: SATX
Vehicle:
2005 05 STI-Dom3
2006 B9 Tribeca Ltd.

Default

Quote:
Originally Posted by bailey1224 View Post
09 WRX with 2700 miles loud knocking noise engine failure....new car in the shop. Dont have my vin and build date on me since my car is in the shop. Will post that later tonight when i get it. Subaru claims to have never heard of this problem..and is saying my oil was low (which is was NOT) and since the oil was low i need a new engine...? exact words. what have the dealers been telling everyone else with this problem?
so are you supposed to check the oil level on a car with only 2700 miles????
i think that the reason of failure would have been best left unsaid if that were the case.
Mighty E is offline   Reply With Quote
Old 02-25-2009, 08:23 PM   #37
fog hat
Scooby Newbie
 
Member#: 196426
Join Date: Dec 2008
Location: So-Cal
Vehicle:
2009 WRX 5 door
White-ish

Default

OK here is the 411 on pops car:

5 door, White, Premium:

VIN: 803626
Build date: 08-08
Miles: 8200

Last edited by fog hat; 02-25-2009 at 08:30 PM.
fog hat is offline   Reply With Quote
Old 02-25-2009, 08:45 PM   #38
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added another new failure (fog hat's dad), updated a build date, and added an "unconfirmed" failure to footnote(bailey1224).
Tea cups is offline   Reply With Quote
Old 02-25-2009, 09:41 PM   #39
BIGSKYWRX
Scooby Guru
 
Member#: 7958
Join Date: Jul 2001
Location: Plains of Eastern Montana
Vehicle:
09 GH B+

Default

8200 miles- arghhhhh looks like it's going to be at least 10k before a guy can even start to think he's out of the woods
BIGSKYWRX is offline   Reply With Quote
Old 02-26-2009, 12:11 AM   #40
reaper702
Scooby Newbie
 
Member#: 191827
Join Date: Oct 2008
Location: Sin City
Vehicle:
2009 WRX
WRB

Default

Quote:
Originally Posted by BIGSKYWRX View Post
8200 miles- arghhhhh looks like it's going to be at least 10k before a guy can even start to think he's out of the woods
that sucks man, now i have to wait until 10k to be worry free, i guess dp and stage 2 are on hold for a while...
reaper702 is offline   Reply With Quote
Old 02-26-2009, 11:24 AM   #41
fog hat
Scooby Newbie
 
Member#: 196426
Join Date: Dec 2008
Location: So-Cal
Vehicle:
2009 WRX 5 door
White-ish

Default

Quote:
Originally Posted by reaper702 View Post
that sucks man, now i have to wait until 10k to be worry free, i guess dp and stage 2 are on hold for a while...

Yeah but keep in mind those are old man miles .



But he does live in Palm desert and work in Irvine (about 2 hours) so most of the miles were at low RPM in 5th.

You should be good after 10k, but who knows.
fog hat is offline   Reply With Quote
Old 02-26-2009, 03:44 PM   #42
capaWRX
Scooby Specialist
 
Member#: 37768
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: NJ
Vehicle:
MY12 wrx ltd
98 2.0rs (sold!)

Default

Quote:
Originally Posted by reaper702 View Post
that sucks man, now i have to wait until 10k to be worry free, i guess dp and stage 2 are on hold for a while...
i wouldn't even say 10k miles is the free zone. this issue has me thinking of potentially never modding the drivetrain of my car. in all honestly, i really don't want to put any extra money into it, but a pioneer f90bt and spt boost gauge are most likely the first mods.
capaWRX is offline   Reply With Quote
Old 02-28-2009, 09:07 PM   #43
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added another failure (nkodemus82).
Tea cups is offline   Reply With Quote
Old 03-02-2009, 05:00 PM   #44
fog hat
Scooby Newbie
 
Member#: 196426
Join Date: Dec 2008
Location: So-Cal
Vehicle:
2009 WRX 5 door
White-ish

Default

EVERYONE MUST CALL SOA AND GET A CASE NUMBER!

I can not stress this enough. It takes a few moments out of your day.

If all of us demand to be heard SOA will be forced to take action.

I have started the ball rolling and so far I have demanded that SOA purchase my two vehicles back from me (start high in your negotiations).

The reason why SOA is not aware of the problem is because we are not making big enough waves. (call back every week to find out where you stand too)

we are almost 30 strong now and just just nasioc
fog hat is offline   Reply With Quote
Old 03-03-2009, 12:31 PM   #45
KAT_Ayanami
Scooby Specialist
 
Member#: 155017
Join Date: Jul 2007
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2000 2.5RS
Blue Ridge Pearl

Default

Please people, STOP flooding this topic with comments and similar stuff!!!

There is another topic for that kind of stuff! Lets keep this clean for people to submit their information and updates!
KAT_Ayanami is offline   Reply With Quote
Old 03-03-2009, 12:52 PM   #46
hoobidty
Scooby Newbie
 
Member#: 189951
Join Date: Sep 2008
Chapter/Region: TXIC
Location: des moines, WA/Houston, TX
Vehicle:
2008 premium spt wrx
silver spark

Default

I drive an 08 wrx and for some reason at 2000 miles my engine started making a nasty clicking noise every second of my car running. I called gillman southwest where i bought it and I got it towed out to Gilllman. It sat in the shop for over a week and they told me they were replacing the engine completely.

The dude there didn't tell me anything about it beside "for some reason it's not getting any oil"

I wasn't driving hard at all and thought i was breaking my car in perfectly. And then i heard about this 09 problem and figured it might have something to do with it.

but yeah, subaru paid for everything and i wasn't charged a dime.

did i f-up by not askign them to straight out buy my car back?

the build date is 01/08
hoobidty is offline   Reply With Quote
Old 03-03-2009, 08:58 PM   #47
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - another new failure (jloney).
Tea cups is offline   Reply With Quote
Old 03-03-2009, 10:22 PM   #48
feint05
Scooby Specialist
 
Member#: 152984
Join Date: Jul 2007
Chapter/Region: SCIC
Location: san diego
Vehicle:
2004 jewbaru
jewbuilt, polish tuned

Default

Quote:
Originally Posted by Tea cups View Post
No one has been tracking the 08 WRX, but it doesn't appear there's anywhere near as many failures (reported anyway) as the 09 WRX.
more power.....more problems
feint05 is offline   Reply With Quote
Old 03-04-2009, 12:21 AM   #49
D3T3
Scooby Newbie
 
Member#: 199752
Join Date: Jan 2009
Chapter/Region: VIC
Vehicle:
2009 ImprezaWrxHB265
dark grey

Default

Damn i was planning to go on track.... now that i am not sure should i do it or not!
any suggestions?
mine was build 01/09 so i am not sure will mine have the same problem?
D3T3 is offline   Reply With Quote
Old 03-04-2009, 12:39 AM   #50
philly841
Scooby Newbie
 
Member#: 188911
Join Date: Sep 2008
Chapter/Region: BAIC
Default

tracked my stock 09 WRX right after first oil change at 3600 miles. drove it hard all day (mainly in 4k-redline in 3rd and 4th gear) and then drove it home. I'm at 7100 miles right now and have another track day scheduled in another 3 weekends.

I don't want to say I'm paranoid or confident I don't have the problem, but it seems like there's simply no good early warning signs, so if you want to track your car, track your car. If your engine is going to blow, there's nothing you can do about it. I think after a second hard track day, I'll feel relatively confident about my engine's condition.

And my build date is 07/08, so I have been somewhat holding my breath until I get past the last known mileage for defective motor.
philly841 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 201 07-12-2014 07:54 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 08:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.