Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-11-2009, 04:17 PM   #1
Pohenegamook
Scooby Specialist
 
Member#: 134262
Join Date: Dec 2006
Chapter/Region: International
Location: Lakalakalaka Lake
Vehicle:
9 조 ☼
Protective Buttress Face

Outback Sport Help with diagnosing my engine

06 Outback sport, 38K miles, no 'real' mods, did do a snorkusectomy (i know, I know - done before williaty's write up though)

The other day on the highway I had to accelerate quickly and the engine sounded funny, ever since then whenever I'm over ~4.5K rpm it still sounds funny. Hard to explain....it goes from the normal Rrrrrrrrrrrr sound to a waaaaaaaaaaaa sound almost like its over revving. Sounds a little raspy, almost like a heat shield is rattling. Checked the shields and poked around but saw nothing obviously loose. Plenty of oil...last changed ~2600 miles ago.

So any guesses? What else should I check?

I do have a tactrix cable - what data would be good to record to determine if my engine is dying?

I'll try to record the sound later and host is somewhere but that usually doesn't help with daignosis.


Thanks in advance for any comments/thoughts.
Pohenegamook is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 Impreza Wagon Can anyone help me diagnose Check Engine Code P103 Bank 1 Sensor 2 Alpental Normally Aspirated Powertrain 0 04-12-2010 02:39 AM
* Calling All Specialists & Gurus: Help Me Diagnose My Strange STi Engine Problem! * Red Rexx Factory 2.5L Turbo Powertrain 34 01-14-2009 02:06 PM
Diagnose my engine noise please [with video] zum Factory 2.0L Turbo Powertrain 6 07-15-2008 11:59 AM
Help diagnose my engine problem - ticking/rattling lowkey Mid Atlantic Impreza Club -- MAIC 9 08-13-2007 09:02 AM
Help me diagnose my engine problem! imprezive one Factory 2.0L Turbo Powertrain 3 08-27-2003 10:42 AM


All times are GMT -4. The time now is 03:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.