Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-14-2009, 08:25 PM   #126
Troganin
Scooby Newbie
 
Member#: 115770
Join Date: May 2006
Location: Buffalo, NY
Vehicle:
2007 2.5i Wagon
Black

Default

you have to click on what table you want to look at on the left side. then something will appear in the black.
* Registered users of the site do not see these ads.
Troganin is offline   Reply With Quote
Old 02-14-2009, 12:25 AM   #127
justboosted02
Scooby Specialist
 
Member#: 78285
Join Date: Dec 2004
Chapter/Region: NESIC
Location: CT
Vehicle:
2003 EVO
red and black

Default

what happened to the turboxs wideband support?

its not in the new version of romraider and i NEEDZ it
justboosted02 is offline   Reply With Quote
Old 02-21-2009, 01:16 PM   #128
enXiks
Scooby Specialist
 
Member#: 69363
Join Date: Aug 2004
Chapter/Region: SCIC
Location: West Covina, CA
Vehicle:
2004 WRX

Default

Where are you guys getting your Stage 1 roms from?
for 04 WRX?
enXiks is offline   Reply With Quote
Old 02-27-2009, 11:24 AM   #129
Tgui
Scooby Specialist
 
Member#: 44771
Join Date: Oct 2003
Default

Quote:
Originally Posted by justboosted02 View Post
what happened to the turboxs wideband support?

its not in the new version of romraider and i NEEDZ it
It was alpha quality in that it used features from another program I wrote a long time ago. Kascade tore it out when pulling out dead-ish code.
Tgui is offline   Reply With Quote
Old 02-27-2009, 04:25 PM   #130
mr.four
Scooby Newbie
 
Member#: 148479
Join Date: May 2007
Chapter/Region: SCIC
Location: Simi Valley, CA
Vehicle:
2002 WRX
PSM

Default

When flashing a map onto the ECU I...

-Opened EcuFlash
-Connected my cable
-Connected the Green Connectors
-Connected the Init connector
-Opened the map I was going to flash
-Clicked Write to ECU
-Turned Key to "ON"
-Clicked Okay
-Done...
-Disconnected the Green Connectors
-Disconnected the Init connector

Did I miss something or do something wrong here...?
mr.four is offline   Reply With Quote
Old 03-14-2009, 03:04 PM   #131
ezramoore
Scooby Newbie
 
Member#: 159597
Join Date: Sep 2007
Chapter/Region: NWIC
Location: Washington State
Vehicle:
2003 Impreza WRX
Sonic Yellow

Default

Just a HUGE heads up as I see this WAY too often: YOU NEED AN OFFSITE BACKUP OF YOUR STOCK MAP.

So email it to yourself if you have a webmail account...
ezramoore is offline   Reply With Quote
Old 04-02-2009, 02:54 PM   #132
sburck
Scooby Specialist
 
Member#: 191491
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
2011 Forester

Default

Thanks for the guide, I was wondering though what exactly is a test write and how do you do one?
sburck is offline   Reply With Quote
Old 04-02-2009, 04:34 PM   #133
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

A test write in Ecuflash is one of the selections includiing the usual read and write. It basically does everything in the flashing process except the actual flash, allowing you to discover problems beforehand.
Tea cups is offline   Reply With Quote
Old 04-08-2009, 11:55 AM   #134
Irishman
Scooby Specialist
 
Member#: 29933
Join Date: Nov 2002
Location: Kalamazoo, MI
Vehicle:
2004 STI
Silver/Silver

Default

My biggest fear is that it will erase or mess up and I will lose my protune when I get my ECU information. Has this ever happened? I only want to log.
Irishman is offline   Reply With Quote
Old 04-08-2009, 12:04 PM   #135
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by Irishman View Post
My biggest fear is that it will erase or mess up and I will lose my protune when I get my ECU information. Has this ever happened? I only want to log.
Logging has no risk whatsoever and will not change your tune.
Tea cups is offline   Reply With Quote
Old 04-08-2009, 12:33 PM   #136
Irishman
Scooby Specialist
 
Member#: 29933
Join Date: Nov 2002
Location: Kalamazoo, MI
Vehicle:
2004 STI
Silver/Silver

Default

Thanks for the quick reply. I am hoping to find my cable and contribute to the road dyno thread.
Irishman is offline   Reply With Quote
Old 04-24-2009, 01:02 PM   #137
ryrules1
Scooby Newbie
 
Member#: 202574
Join Date: Feb 2009
Default

Car: saab 92x linear
Engine: EJ253

I recently bought a tactrix cable and I started logging for using Romraider, driving around. I then desided to try and pull the ROM from the ECU, I put the car in test mode. (green connector). Then I opened ECUFlash, and yes I have the ECU defs installed. Then I hit read rom, and go this error message no madder which DBW setting I used.

[11:26:07.746] Using interface OpenPort 1.3 Universal TX45rBqS9d1ab7c956c5f7aae78bab98f7276a5dc3826586
[11:26:08.557] kernel get version
[11:26:08.938] SSM2 init
[11:26:09.088] SSM2 ECU ID is 3E 12 08 41 06
[11:26:09.188] Requesting Seed...
[11:26:09.238] Sending Key...
[11:26:09.879] interface close
[11:26:09.879] interface close

any ideas?

Last edited by ryrules1; 04-24-2009 at 01:35 PM. Reason: question not answered
ryrules1 is offline   Reply With Quote
Old 04-29-2009, 06:02 AM   #138
darkcrave
Scooby Specialist
 
Member#: 204753
Join Date: Mar 2009
Location: Central Valley, CA
Vehicle:
2002 wrx

Default

just one question, can i use the cable that came with my cobb AP and connect it to my computer to run romraider?
darkcrave is offline   Reply With Quote
Old 04-29-2009, 09:45 AM   #139
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by darkcrave View Post
just one question, can i use the cable that came with my cobb AP and connect it to my computer to run romraider?
If it is Accessport ver 1 cable, then you can log with RomRaider if you get a serial to USB converter (Belkin is a good one). However, that is it. You will not be able to flash your ECU (i.e. tune). AP ver 2 cable, you will not be able to log at all with RomRaider.
Tea cups is offline   Reply With Quote
Old 05-05-2009, 04:59 PM   #140
svxpert
Scooby Newbie
 
Member#: 11317
Join Date: Oct 2001
Location: east coast
Default

does anyone know how i can tell what tactrix cable i have? i searched but no results. i had originally bought one for a 2004 STi but after a year i have just located it in my garage. there is no stickers on it indicating what version it is so it could be 1.2 to a 2.0? thanks
svxpert is offline   Reply With Quote
Old 05-05-2009, 05:29 PM   #141
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

If it is a year old, it won't be the 2.0. It will show your cable's version in Ecuflash.
Tea cups is offline   Reply With Quote
Old 05-05-2009, 06:18 PM   #142
svxpert
Scooby Newbie
 
Member#: 11317
Join Date: Oct 2001
Location: east coast
Default

so you mean the 2.0 just came out in the last year?
svxpert is offline   Reply With Quote
Old 05-05-2009, 06:35 PM   #143
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Yes, not to mention it looks different than the previous cables. It has a detachable cable and a translucent cover with led lights.
Tea cups is offline   Reply With Quote
Old 05-15-2009, 09:16 PM   #144
Dubstar112
Scooby Specialist
 
Member#: 143149
Join Date: Mar 2007
Chapter/Region: Tri-State
Location: No evo 9, no sti swap wrx
Vehicle:
2006 gmc envoy
stealth

Default

I am a newbie, and Ive read as much as I can find out including this entire thread. I get this error:

[20:11:47.515] J2534 error [device not responding].
[20:11:47.515] unable to connect to vehicle interface.
[20:11:47.515] interface close
[20:13:56.812] J2534 error [device not responding].
[20:13:56.812] unable to connect to vehicle interface.
[20:13:56.812] interface close
[20:14:10.187] J2534 error [device not responding].
[20:14:10.187] unable to connect to vehicle interface.
[20:14:10.187] interface close


How do I know what com port to use?

Last edited by Dubstar112; 05-15-2009 at 10:07 PM.
Dubstar112 is offline   Reply With Quote
Old 05-15-2009, 10:19 PM   #145
Dubstar112
Scooby Specialist
 
Member#: 143149
Join Date: Mar 2007
Chapter/Region: Tri-State
Location: No evo 9, no sti swap wrx
Vehicle:
2006 gmc envoy
stealth

Default

woot got it. Just had to restart my laptop.
Dubstar112 is offline   Reply With Quote
Old 06-23-2009, 02:53 PM   #146
Ferraz
Scooby Specialist
 
Member#: 173553
Join Date: Mar 2008
Chapter/Region: International
Location: Sao Paulo
Vehicle:
1996 Civic VTi
Dark blue

Default

Where can I get the Ecuflash? The link not working!!!!
Ferraz is offline   Reply With Quote
Old 07-14-2009, 01:14 AM   #147
AraSh
Scooby Newbie
 
Member#: 211134
Join Date: May 2009
Chapter/Region: SWIC
Location: AZ
Vehicle:
2007 Impreza STi

Default

Quote:
Originally Posted by Tea cups View Post
Post the ecu id shown in the lower right hand corner when you are connected with the logger and I can check and see if your ROM revision is supported or not. For extended parameter support (such as feedback knock correction, etc.), I have to have a copy of the ROM (extracted with EcuFlash) in order to define them. Likely no one has uploaded yours before, especially since it is an AT. If it is not supported, then you'll have to pull it with Ecuflash and a tactrix cable and send it to me and I can add logger as well as tuning support.
I'm having the same exact problem. I don't see the parameters "feedback knock correction", etc... How can this be fixed? and what do you mean by saying "you have to have a copy of the ROM to define them"? is this different for every rom?

And I have a 2007 wrx tr if that matters.

Also was wondering, tea cups, are you the person writing the definitions for RomRaider?
AraSh is offline   Reply With Quote
Old 07-14-2009, 09:50 AM   #148
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by AraSh View Post
I'm having the same exact problem. I don't see the parameters "feedback knock correction", etc... How can this be fixed? and what do you mean by saying "you have to have a copy of the ROM to define them"? is this different for every rom?

And I have a 2007 wrx tr if that matters.

Also was wondering, tea cups, are you the person writing the definitions for RomRaider?
You have to be connected to your car's ECU in order for the extended parameters to appear as they are ECU specific. That is, you have to have the tactrix cable hooked up, romraider running, and your car's ignition on in order to view any extended parameters. If they still don't appear (make sure you can actually log), then that could mean either you have old definitions or your ECU is not supported. If your ECU is not supported, that means that no one has uploaded your specific ROM revision before for support to be added (there can be multiple revisions for a particular car, so it doesn't matter if there's already support for a USDM 07 WRX MT, there can be multiple "versions" for that car).

Yes, I do the defs for RomRaider (my screen name at romraider is merchgod).
Tea cups is offline   Reply With Quote
Old 07-14-2009, 12:21 PM   #149
AraSh
Scooby Newbie
 
Member#: 211134
Join Date: May 2009
Chapter/Region: SWIC
Location: AZ
Vehicle:
2007 Impreza STi

Default

Quote:
Originally Posted by Tea cups View Post
Post the ecu id shown in the lower right hand corner when you are connected with the logger and I can check and see if your ROM revision is supported or not. For extended parameter support (such as feedback knock correction, etc.), I have to have a copy of the ROM (extracted with EcuFlash) in order to define them. Likely no one has uploaded yours before, especially since it is an AT. If it is not supported, then you'll have to pull it with Ecuflash and a tactrix cable and send it to me and I can add logger as well as tuning support.
Quote:
Originally Posted by Tea cups View Post
You have to be connected to your car's ECU in order for the extended parameters to appear as they are ECU specific. That is, you have to have the tactrix cable hooked up, romraider running, and your car's ignition on in order to view any extended parameters. If they still don't appear (make sure you can actually log), then that could mean either you have old definitions or your ECU is not supported. If your ECU is not supported, that means that no one has uploaded your specific ROM revision before for support to be added (there can be multiple revisions for a particular car, so it doesn't matter if there's already support for a USDM 07 WRX MT, there can be multiple "versions" for that car).

Yes, I do the defs for RomRaider (my screen name at romraider is merchgod).
OK this makes sense. But still doesn't fix my problem. And the problem is that it is not supported because I did everything you mentioned (having everything connected and ignition on etc, AND it does actually log.)
I got a reflash at the dealership recently for "misfire" fix, so maybe thats why?

Anyway,

I have 2 questions:

1. Can I give you my ROM so you can update the def's for it?
2. If I "read from ecu" using ECUFlash, would it leave any marks on the ECU that it has been touched? I mean its not write to it its supposed to just "read" but still wanna make sure. Because I don't want the warranty to be denied with the car and ECU and everything

Thanks
AraSh is offline   Reply With Quote
Old 07-14-2009, 12:30 PM   #150
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Yes, you can either PM me the ROM at the romraider site (merchgod) or post it there. Make sure you do it fairly soon as the next update will be in about a month.

Reading doesn't change anything as far as the ROM is concerned. The fact that you pulled the ROM should not be detectable by the dealership as far as we know.
Tea cups is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
romraider/ecuflash? weaponstroop Open Source Reflashes 8 10-21-2008 11:04 AM
reading logs - FAQ or getting started guide? jmc9809 Newbies & FAQs 2 08-05-2005 07:40 PM
I want to get started racing! Where to start? wayne_rx Motorsports 27 12-23-2004 04:00 AM
Auto-Xing Newbe, How to get started? Ed_RS New England Impreza Club Forum -- NESIC 7 01-31-2001 12:34 PM
how to get started jjp New England Impreza Club Forum -- NESIC 5 11-09-2000 07:26 AM


All times are GMT -4. The time now is 10:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.