Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2002, 07:43 AM   #1
2000vfr800
Scooby Specialist
 
Member#: 15599
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Livonia, MI
Default Is anybody _NOT_ happy with the UTEC

It seems that the UTEC is a very nice piece of engine management. I am seriously considering getting it. But, I would just like to hear some complaints (other than not being able to get it) that people have.
* Registered users of the site do not see these ads.
2000vfr800 is offline   Reply With Quote
Old 10-03-2002, 09:02 AM   #2
WAFlowers
Scooby Specialist
 
Member#: 23337
Join Date: Aug 2002
Location: Clearwater, FL
Vehicle:
1997 Legacy GT Sedan
Black

Default

The silence is deafening!

Oh, wait a minute. You only posted less than 1.5 hours ago.
--
Bill
WAFlowers is offline   Reply With Quote
Old 10-03-2002, 09:03 AM   #3
desiwrx02
Scooby Specialist
 
Member#: 20168
Join Date: Jun 2002
Location: the D town, mich
Vehicle:
02 wrx
black and blue all over

Default

Youll have to wait a while on that one.
Hype combined with novelty and plain scarcity will give you that effect.
Ajay
desiwrx02 is offline   Reply With Quote
Old 10-03-2002, 09:44 AM   #4
jimb
Scooby Specialist
 
Member#: 9923
Join Date: Sep 2001
Vehicle:
2005 Legacy GT
RIP MBP WRX

Default

Still a bit early, I'm sure they'll be more info on the likes and dislikes when more of them hit the streets..

jb
jimb is offline   Reply With Quote
Old 10-03-2002, 09:48 AM   #5
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

I hate it, it's utter garbage!!!

*just a typical post-whore response! hehe*

Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Old 10-03-2002, 10:59 AM   #6
thyrodent
Scooby Newbie
 
Member#: 12440
Join Date: Nov 2001
Location: New Jersey
Vehicle:
2004 Impreza WRX STI
Black

Default

^
BLASPHEMER! (SP?)

typical post whore response to post whore post...
thyrodent is offline   Reply With Quote
Old 10-03-2002, 11:12 AM   #7
tolnep
Scooby Specialist
 
Member#: 18602
Join Date: May 2002
Location: Planet tolnep
Vehicle:
2005 Moller Skycar
glow in dark purple

Default

I read on an Austrailian board that the first bacth consisted of 20 units. Anyone have any idea how many are out there and running currently?
tolnep is offline   Reply With Quote
Old 10-03-2002, 11:34 AM   #8
mikaust
Scooby Specialist
 
Member#: 7468
Join Date: Jun 2001
Chapter/Region: MAIC
Vehicle:
2002

Default

Mine did not come with any stickers !!!! Whats up with that. Thanks Michael
mikaust is offline   Reply With Quote
Old 10-03-2002, 11:49 AM   #9
lgstucki
Scooby Newbie
 
Member#: 14980
Join Date: Feb 2002
Location: Salt Lake City, Utah
Vehicle:
2002 impreza wrx
silver

Default

Quote:
Originally posted by mikaust
Mine did not come with any stickers !!!! Whats up with that. Thanks Michael
Oh man, that really sucks!!! They just screwed you out of like 20 hp well 40 if they were to give you two. j/k
lgstucki is offline   Reply With Quote
Old 10-03-2002, 12:20 PM   #10
HOK
Scooby Specialist
 
Member#: 447
Join Date: Oct 1999
Location: Oh Canada
Vehicle:
1999 EJ22T222B&EVO
Are we racing yet?

Default

i'm not happy!!


cause it doesn't work with the RS 2.5...
HOK is offline   Reply With Quote
Old 10-03-2002, 12:38 PM   #11
rayder
Scooby Specialist
 
Member#: 14535
Join Date: Jan 2002
Location: SoCal
Vehicle:
02 Impreza WRX
Silver

Default

the UTEC sucks... everyone stop buying them! I want to stay a step ahead of the remaining people still running the unichip! lol!

i think the only people who will not like the UTEC will be competitors of TurboXS.
rayder is offline   Reply With Quote
Old 10-03-2002, 12:47 PM   #12
XSTransAm
Scooby Newbie
 
Member#: 17789
Join Date: Apr 2002
Location: morgantown wv, gaithersburg md
Vehicle:
2006 Yamaha R6
bikes are faster ;)

Default Stickers?

Mike, comon man your breakin my balls here.... how long have you been coming here and you still dont have a sticker??? lol j/p
Michael~txs btw, did you want the dyno charts on how much hp the stickers add...... I think you would be suprised
XSTransAm is offline   Reply With Quote
Old 10-03-2002, 01:34 PM   #13
Carlo
Scooby Newbie
 
Member#: 18376
Join Date: May 2002
Location: 367 WHP / 460 at the Crank!
Vehicle:
367 WHP!
460 HP at the crank!

Default

Quote:
Originally posted by rayder
the UTEC sucks... everyone stop buying them! I want to stay a step ahead of the remaining people still running the unichip! lol!

i think the only people who will not like the UTEC will be competitors of TurboXS.
This is pretty much what I was thinking too. I know some of the other well known tuners here on I-Club are also moving away from the Unichip to the Autronic, etc. but they are going to cost more.

What I really like about the UTEC is that it is developed specifically for the WRX by TurboXS. They went from idea to finished product while other companies like AEM are STILL in development of their product. It costs less then half the price of other "similar" products and actually comes with base setups that very closely match most of our cars!

Carlo
Carlo is offline   Reply With Quote
Old 10-03-2002, 02:54 PM   #14
WRXzard
Scooby Newbie
 
Member#: 14855
Join Date: Jan 2002
Default

I'M NOT HAPPY!!!!!!

Because, I DONT HAVE ONE!

YET
WRXzard is offline   Reply With Quote
Old 10-03-2002, 03:02 PM   #15
iceweazel
Scooby Specialist
 
Member#: 6816
Join Date: May 2001
Chapter/Region: MWSOC
Location: Cowlumbus, OH
Vehicle:
01 yeller wrx
triumph tiger,klr,cb900f

Default

What I'm wondering is:

Why pay so much more for a standardized cable port and the software license?

It was already user tunable with the right setup.
Having tuned a couple on my laptop, I know this for a fact.
Yes it was on race only cars. Didn't see the point for the
street at that time. Nor was it a useful ignition on a race-only vehicle.


Ed
iceweazel is offline   Reply With Quote
Old 10-03-2002, 03:24 PM   #16
rayder
Scooby Specialist
 
Member#: 14535
Join Date: Jan 2002
Location: SoCal
Vehicle:
02 Impreza WRX
Silver

Default

huh??
rayder is offline   Reply With Quote
Old 10-03-2002, 03:26 PM   #17
DarthChicken
Scooby Specialist
 
Member#: 9073
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Hillsboro, OR.
Vehicle:
2006 ariel atom
wrb/bbs gold frame

Default

Ok, I'll bite.

I got mine yesterday, and I'm used to my LINK. And I'm having some issues with the software.

The A/F ratio goes to 21.9 sometimes... yet I'm running SO rich its not even funny. Obviously outside the tolerance of whatever mathematics are being used to determine A/F ratio from the front o2 sensor.

The RPM number goes to "000" sometimes while your logging. Very strange.

When you get knock, and you look at your datalog and it says "ECU" instead of a number (even IF the ECU is determining timing, I'd like to know what that value was), its a little frustrating. I'd like to know what that timing value is, even if its controlled by the ECU.

Closed loop/open loop operation is good, and I probably don't want to mess with the timing in the closed loop section, but thats where I'm getting my knock. So, I've started adding fuel into those locations, because I can't control timing.

Why am I getting knock under low load you may ask? Because I'm running a 9:1 compression engine probably.

All in all I'm happy with it though. Just some minor teething pains
DarthChicken is offline   Reply With Quote
Old 10-03-2002, 04:33 PM   #18
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

Quote:
Originally posted by DarthChicken
Ok, I'll bite.

I got mine yesterday, and I'm used to my LINK. And I'm having some issues with the software.

The A/F ratio goes to 21.9 sometimes... yet I'm running SO rich its not even funny. Obviously outside the tolerance of whatever mathematics are being used to determine A/F ratio from the front o2 sensor.

The RPM number goes to "000" sometimes while your logging. Very strange.

When you get knock, and you look at your datalog and it says "ECU" instead of a number (even IF the ECU is determining timing, I'd like to know what that value was), its a little frustrating. I'd like to know what that timing value is, even if its controlled by the ECU.

Closed loop/open loop operation is good, and I probably don't want to mess with the timing in the closed loop section, but thats where I'm getting my knock. So, I've started adding fuel into those locations, because I can't control timing.

Why am I getting knock under low load you may ask? Because I'm running a 9:1 compression engine probably.

All in all I'm happy with it though. Just some minor teething pains
FYI... data log #1 should have both your UTEC adjusted, and ECU interpreted timing.

Make sure your dip switches are correct as well. U,D,D,D,D,U,U,U IIRC.

Also.. if you have a higher compression motor, there is no way you can run ECU timing in closed loop. Your going to knock away until the computer gets enough knock to build it's own table. Save your self the grief and set your parameters->special constants->TPS crossover % to 0

That way you can map timing at least on MAP. You can run normalish timing in the atmospheric, 2, 4 PSI categories and then run what is appropriate for your motor.

Hope that helps,
Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Old 10-03-2002, 05:01 PM   #19
DarthChicken
Scooby Specialist
 
Member#: 9073
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Hillsboro, OR.
Vehicle:
2006 ariel atom
wrb/bbs gold frame

Default

Yeah, I figured as much. I lowered it down to 45% and am building a table of timing right now. Its ok... I just go back to MAP based tuning, which is what I wanted to do anyway. Will move to 0% tonight - gonna get some help from Jeff Perrin tonight, he'll get me straightened out good!

Dip switches are set right, just checked. I've been using the "d" dataloger, sounds like I need to be using the "L" datalogger, choice #1 then, right? That would make it a LOT easier to build a timing map then, instead of going the delta dash route.

thnx Jorge!

(the car does pull like a freight train though, no doubt about that!)
DarthChicken is offline   Reply With Quote
Old 10-03-2002, 05:07 PM   #20
zyounker
Scooby Newbie
 
Member#: 9573
Join Date: Aug 2001
Location: Bloomington, IL
Vehicle:
2002 Impreza WRX
Silver

Default

One feature i think it is missing (correct me if i am wrong) is to watch cels and tell it to ignore certain cells and allow others.. Or maybe for it to just emulate the o2 sensor..


Other then that i think it will be a great product for a PnP piggyback/standalone..



I still think a standalone will be better in the long run if you are competent at tunning or have a competent shop nearby..


-Zach
zyounker is offline   Reply With Quote
Old 10-03-2002, 05:18 PM   #21
n2xlr8n
Scooby Specialist
 
Member#: 18960
Join Date: May 2002
Chapter/Region: South East
Location: Bama
Vehicle:
02 WRX MBP
It lives! ; )

Thumbs up Love mine...yes..yes I do

Took twenty minutes to install...
Took twenty minutes to read/comprehend the manual...
Took twenty minutes to fine tune the maps...
C'mon TXS, I'm on a busy schedule here, Jeez!
As far as "standalone"...it's been discussed...we won't go there.
n2xlr8n is offline   Reply With Quote
Old 10-03-2002, 06:19 PM   #22
nmyeti
Scooby Specialist
 
Member#: 4980
Join Date: Mar 2001
Location: Albuquerque, NM USA
Default Re: Love mine...yes..yes I do

Quote:
Originally posted by n2xlr8n
Took twenty minutes to install...
Took twenty minutes to read/comprehend the manual...
Took twenty minutes to fine tune the maps...
C'mon TXS, I'm on a busy schedule here, Jeez!
As far as "standalone"...it's been discussed...we won't go there.
Sorry man, we'll try harder next time.




-Nathan
nmyeti is offline   Reply With Quote
Old 10-03-2002, 07:08 PM   #23
Wombat North
Scooby Specialist
 
Member#: 21267
Join Date: Jul 2002
Location: Eats, roots and then leaves
Vehicle:
STI, EWG 8cm Green
UTEC/ECUtek/WI & SD tune

Default

I have a big problem now with the UTEC

My clutch slips under WOT in 4th and I don't drag.

The UTEC provides too much power on 92oct
Wombat North is offline   Reply With Quote
Old 10-03-2002, 07:13 PM   #24
thejean
Scooby Specialist
 
Member#: 17763
Join Date: Apr 2002
Chapter/Region: W. Canada
Location: Calgary, AB
Default

Quote:
Originally posted by Wombat North
I have a big problem now with the UTEC

My clutch slips under WOT in 4th and I don't drag.

The UTEC provides too much power on 92oct
Oh, boo hoo. my heart bleeds purple p1ss for you.

Me and my UTEC-less a$$ don't have to listen to this crap.

I'm leaving and I'm not coming back.

j/k you lucky I'm with envy.
thejean is offline   Reply With Quote
Old 10-03-2002, 07:44 PM   #25
n2xlr8n
Scooby Specialist
 
Member#: 18960
Join Date: May 2002
Chapter/Region: South East
Location: Bama
Vehicle:
02 WRX MBP
It lives! ; )

Default You guys kill me

Quote:
Originally posted by thejean


Oh, boo hoo. my heart bleeds purple p1ss for you.

Me and my UTEC-less a$$ don't have to listen to this crap.

I'm leaving and I'm not coming back.

j/k you lucky I'm with envy.
How long have you been waiting to use that?
I am devoid of clever HTML / forum humor....it took me 3 months to figure out "IIRC".
n2xlr8n is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what is the difference with revisions and versions with the UTEC ? billy boi Engine Management & Tuning 3 01-27-2005 01:06 PM
Who is not happy with a JUN replica bumper and how low does it sit? Kwyjibo Interior & Exterior Modification 16 12-17-2003 09:37 AM
Not happy with my UTEC Stage 1 times. progresr Proven Power Bragging 40 10-31-2003 12:10 PM
is anybody really happy with there cars? bender Vancouver Impreza Club Forum -- VIC 32 09-11-2003 04:31 PM
Not real happy with the brakes GPuglisi Newbies & FAQs 15 07-17-2003 12:37 PM


All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.