Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-10-2009, 12:12 PM   #1
moonzie
Scooby Specialist
 
Member#: 128537
Join Date: Oct 2006
Chapter/Region: MWSOC
Location: Bloomington, Indiana
Vehicle:
2004 Baja Turbo
Red/Silver

Default radiator leakage?

The other day I started to overheat on my way home so I carefully limped it home. Not that it means much but I took extra care to never get that needle in the red-zone but it got close. Low enough on coolant that air must have got sucked into the system.


It had been about 2 years since I flushed & filled my cooling system! It was kinda dirty. Flushed, ran some cleaner through and filled last week. Now I'm noticing a coolant smell sometimes when I get out of the trucklette. Upon inspection it looks like water/coolant is either sieping out at the top of the radiator where the metal fins crimp over the top, on the side closest to the fans.

When I was overheating (before the flush) I did notice there was a little bit of coolant splashed up on the upper radiator hose and the air intake, but I couldn't find any obvious leaks. I can run the engine idle at normal temp, and stand there forever watching under the hood but not see anything.

Suggestions? Does coolant evaporate after a few days or does it just sit around until heated? Could be caps, REALLY hoping my radiator isn't going out! It's kinda expensive.
moonzie is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: NoVA: Samco Radiator Hoses in Black and 4 No Tear Clamps for 02-07 WRX / STi. adjasont Engine/Power/Exhaust 5 11-27-2011 03:06 PM
WTB: wrx/sti Radiator ASAP !! 02NWbugeye NWIC Private Classifieds 8 07-08-2010 07:42 PM
WTT: Gimmick radiator hoses klorti Private 'Wanted' Classifieds 0 06-04-2010 07:49 PM
rear differential leakage Fred Normally Aspirated Powertrain 0 02-16-2001 09:06 PM
Headgasket leakage with 98 RS. colmanchan Technical Forum Archive 4 06-29-2000 06:56 AM


All times are GMT -4. The time now is 01:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.