Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-12-2008, 08:54 PM   #1
alphagoose
Scooby Newbie
 
Member#: 158302
Join Date: Sep 2007
Chapter/Region: NESIC
Vehicle:
2010 legacy gt

Default airbag light

anyone have their airbag light come on? today i left school and noticed it stayed on. the manual says bring it to the dealer... like everything else. or can i just reset the ecu and be ok? i really dont wanna have to go back to stock, yea i know its only stage 2 but the dealership will probably give me a hard time about it
* Registered users of the site do not see these ads.
alphagoose is offline   Reply With Quote
Old 03-12-2008, 09:16 PM   #2
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Just check the yellow connectors under your seats. Grab each one and smoosh the two sides of the connectors toward each other on the passenger and driver's seats and I'm placing 2:1 odds the light will go off and you will mentally thank someone from VA Beach with the username Unabomber.

Oh and this should go in the Electrical Forum...
Unabomber is offline   Reply With Quote
Old 03-12-2008, 09:25 PM   #3
alphagoose
Scooby Newbie
 
Member#: 158302
Join Date: Sep 2007
Chapter/Region: NESIC
Vehicle:
2010 legacy gt

Default

unabomber you are the man, how do you know so much. sorry for posting in the wrong area.
alphagoose is offline   Reply With Quote
Old 03-12-2008, 09:43 PM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Actually it's a Maintenance item-
Resetting the ECU does nothing for an airbag light/code. Airbag codes are set and stored in the airbag control module and you can't clear them by disconnecting the battery.
It is possible to read the code by using the diagnostic procedure in the service manual, whereby you plug the diagnostic connectors together and count the flashes of the airbag light. Alternately the code can be read by the dealer using their scanner. Once the code is known, the source of the problem can be identified.
Anyway if you're already done what Unabomber suggested and it worked, just file this info away for another time if it happens again.
Mulder is offline   Reply With Quote
Old 03-12-2008, 10:29 PM   #5
alphagoose
Scooby Newbie
 
Member#: 158302
Join Date: Sep 2007
Chapter/Region: NESIC
Vehicle:
2010 legacy gt

Default

yea connecting them worked, but thanks for the info mulder
alphagoose is offline   Reply With Quote
Old 04-30-2008, 05:02 PM   #6
Wrinkleboi
Top Scoob 006
 
Member#: 14424
Join Date: Jan 2002
Chapter/Region: South East
Location: Stuart, FL
Vehicle:
BugI w/ 07 STi Swap
www.TriStateTuners.com

Default

is there a reference somewhere that will tell me what each code means once i have identified the codes that are present?
Wrinkleboi is offline   Reply With Quote
Old 04-30-2008, 06:17 PM   #7
Wrinkleboi
Top Scoob 006
 
Member#: 14424
Join Date: Jan 2002
Chapter/Region: South East
Location: Stuart, FL
Vehicle:
BugI w/ 07 STi Swap
www.TriStateTuners.com

Default

i found it... my good buddy ken gilbert had it listed...

dont want to link to it and i cant manually type each one, but i'll list the ones that i have in case anyone else has the same in the future...

codes along with the possible causes listed

12
-main harness circuit is open or shorted
-module harness (passenger) circuit is open or shorted
-passenger airbag module is faulty
-airbag control module is faulty

31 + 32 (L+R)
-front sub sensor harness shorted or open
-subsensor is faulty
-airbag control module is faulty

41 + 42 (L+R)
-side airbag harness
-side airbag module
-airbag control module

51 + 52 (L+R)
-side airbag sensor
-side airbag harness
-airbag control module

71 + 72
(need to reference a newer service manual to get this answer)

anyone see a common denominator? i've got a spare airbag control module i'm going to try to swap in to see if that wipes out all my problems...
Wrinkleboi is offline   Reply With Quote
Old 02-17-2009, 01:55 PM   #8
benjero
Scooby Newbie
 
Member#: 203237
Join Date: Feb 2009
Chapter/Region: SCIC
Location: Los Angeles
Vehicle:
2004 Impreza WRX
Silver

Default

Thanks Unabomber, your solution worked for me too. Had me worried this morning since I've only had the car for a little over a week. Is there a logical explanation to this problem besides the fact that the wires got wiggled loose a bit? Is this something I should expect to happen again, and if so should I have it checked out? (i'm still under dealer warranty)
benjero is offline   Reply With Quote
Old 05-07-2009, 04:36 PM   #9
sevnseat
Scooby Newbie
 
Member#: 210746
Join Date: May 2009
Default

I had to register on this forum just to say thank you for this!
sevnseat is offline   Reply With Quote
Old 05-12-2009, 11:50 PM   #10
ihmp
Scooby Newbie
 
Member#: 211202
Join Date: May 2009
Chapter/Region: BAIC
Location: Oakland, CA
Vehicle:
2006 Saab 9-2x Aero
Midnight Black Mica - 32J

Talking

I also registered with NASIOC just to say: Thank you!
My 2006 9-2x was delivered from Connecticut today and the previous owner didn't disclose the airbag light. When I confronted him he told me it was like that when he bought it. The Saab dealer couldn't figure it out and told him there were no error codes.
So I googled, read this thread, and found a dangling airbag connector under the driver's seat. The light is out now! Thanks again Unabomber!
ihmp is offline   Reply With Quote
Old 06-11-2009, 03:07 PM   #11
FLIPN SCOOBY
Scooby Specialist
 
Member#: 177911
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Zompton
Vehicle:
' 04 T WRX FF
'10 SCHOOL BUS

Default

Unabomber you are the man. Mine went off today at lunch and like you said 2:1 odds. Sure enought it is. Thanks a lot.
FLIPN SCOOBY is offline   Reply With Quote
Old 06-21-2009, 03:02 AM   #12
psyber_0ptix
Scooby Guru
 
Member#: 60671
Join Date: Apr 2004
Chapter/Region: NESIC
Location: Fairfax, VA
Vehicle:
1992 Miata

Default

so what about a light that comes on a 99rs, with STi dash and 05 swap. no airbag seats?
psyber_0ptix is offline   Reply With Quote
Old 06-21-2009, 09:12 PM   #13
cthor
Scooby Newbie
 
Member#: 202584
Join Date: Feb 2009
Chapter/Region: MWSOC
Location: AR
Vehicle:
04 Impreza STi
Black

Default

Quote:
Originally Posted by psyber_0ptix View Post
so what about a light that comes on a 99rs, with STi dash and 05 swap. no airbag seats?
same here...i'd like to know about this too..
cthor is offline   Reply With Quote
Old 06-29-2009, 03:06 PM   #14
carolhurwitz
Scooby Newbie
 
Member#: 215582
Join Date: Jun 2009
Default airbag light on intermittently on '02 WRX

Just bought '02 WRX from used car dealer with airbag light on intermittently. Subaru service found code 42. In reading threads I see that it may mean mean faulty sensor or wiring on driver side, but am I wrong? This is my kid's car and I can't risk having him drive it with bad air bags. How do I locate the wires to check? what color might they be? exactly where would they be? Service guy says he can't do anything unless light comes on again. But I don't want my kid driving around with a faulty airbag system. Anyone with advice please weigh in- and thank you from a nervous mom
carolhurwitz is offline   Reply With Quote
Old 06-29-2009, 03:08 PM   #15
carolhurwitz
Scooby Newbie
 
Member#: 215582
Join Date: Jun 2009
Default

Hi unabomber- can you help me? I just bought '02 WRX from used car dealer with airbag light on intermittently. Subaru service found code 42. In reading threads I see that it may mean mean faulty sensor or wiring on driver side, but am I wrong? This is my kid's car and I can't risk having him drive it with bad air bags. How do I locate the wires to check? what color might they be? exactly where would they be? Service guy says he can't do anything unless light comes on again. But I don't want my kid driving around with a faulty airbag system. Anyone with advice please weigh in- and thank you from a nervous mom
carolhurwitz is offline   Reply With Quote
Old 06-29-2009, 10:27 PM   #16
eshaze
Scooby Newbie
 
Member#: 206828
Join Date: Mar 2009
Default

Change the clock spring under the steering wheel, this worked fine for me and solved the intermittent problem!
eshaze is offline   Reply With Quote
Old 06-30-2009, 11:19 AM   #17
psyber_0ptix
Scooby Guru
 
Member#: 60671
Join Date: Apr 2004
Chapter/Region: NESIC
Location: Fairfax, VA
Vehicle:
1992 Miata

Default

my light was on ever since i purchased the car from a 'reputable' subaru shop. they said it would cost $600 because the control module was fried because i installed a radio...

Turned out it was just a loose plug somewhere. It went away after making sure they were all tight. everything starts up and turns off after check like it should.
psyber_0ptix is offline   Reply With Quote
Old 07-08-2009, 02:11 PM   #18
slprsube04
Scooby Newbie
 
Member#: 147486
Join Date: Apr 2007
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2004 WRX
PSM

Default

Good call Unubomber! I work at a shop and Mitchell, alldata, and my Modis couldn't help me with this. I can't find this so called diag connector for the SRS. For some reson the drivers connector is loose even when fully connected. I think its a design flaw.
slprsube04 is offline   Reply With Quote
Old 08-11-2009, 09:28 AM   #19
TBone7281
Scooby Newbie
 
Member#: 148501
Join Date: May 2007
Location: Pittsburgh, PA
Vehicle:
2004 WRX
blue

Default

Quote:
Originally Posted by slprsube04 View Post
Good call Unubomber! I work at a shop and Mitchell, alldata, and my Modis couldn't help me with this. I can't find this so called diag connector for the SRS. For some reson the drivers connector is loose even when fully connected. I think its a design flaw.
Yeah, none of my connectors seemed to be loose, yet after seeing this thread I pushed them together anyway and magically the annoying ass red airbag light went away. Many thanks, Unabomber.
TBone7281 is offline   Reply With Quote
Old 08-27-2009, 11:56 PM   #20
xbox40
Scooby Newbie
 
Member#: 52904
Join Date: Jan 2004
Location: Bay area
Vehicle:
2004 WRX
silver

Default

Just want to say THANKS Unubomber!! Today the airbag came on on my way home, I thought I was going to have to visit the stealer tomorrow. After reading this thread and I pushed the connector together and the red light went away. You the man!!
xbox40 is offline   Reply With Quote
Old 08-28-2009, 10:32 PM   #21
technine
Scooby Newbie
 
Member#: 219993
Join Date: Aug 2009
Default

I'm new here so hello everyone. I have a 04 wrx for about a month now and did my first oil change today and after I drove it I found that the airbag light stayed on! I thought it was because of my fumbling around near the front end of the car, but it turns out that a loose softball I found on the ground last week was rolling around under the passenger seat and caused the connector to come out.

After reading this thread it checked under the seats and sure enough the passenger one was loose so I clicked it back and NO MORE AIRBAG LIGHT@!!!

Thanks Unabomber!!
technine is offline   Reply With Quote
Old 08-31-2009, 04:57 PM   #22
turboL
Scooby Specialist
 
Member#: 111735
Join Date: Apr 2006
Chapter/Region: South East
Location: Philly for now
Vehicle:
96 Legacy2.0GTSOLD
Bimmer Tech

Default

my light has been on since I swapped my legacy. Didnt bother me so i just ignored it. Figured I didnt plug something in. So today I look and see that its all plugged in. Come in here, see this thread. Go outside, disconnect and reconnect it all. No more light. Im in awe. lol. thanks bomber
turboL is offline   Reply With Quote
Old 09-18-2009, 11:34 AM   #23
mickey_t
Scooby Newbie
 
Member#: 224144
Join Date: Sep 2009
Default YESSS it does work

It worked for me too!!!

I'm new to the forum. I found it and this thread after I googled my problem of airbag light coming on.

I have a 04 WRX which is stock and has 80k miles up on it. The light came on out of the blue, so after reading this thread I checked the connectors under both driver and passengers seats and viola! after clicking the drivers one fully into place, the light went out and my sanity was restored.

Thank you so so much for the advice, as I'm sure the only other outcome would have been given the standard two day runaround from a dealer!!
mickey_t is offline   Reply With Quote
Old 01-11-2010, 03:44 AM   #24
AeroWRX
Scooby Newbie
 
Member#: 199026
Join Date: Jan 2009
Chapter/Region: SCIC
Location: Los Angeles
Vehicle:
2004 WRX Wagon
Silver

Default

My Air Bag light came on today too. Followed the advice from this thread and just pushed the yellow connectors under both driver and passenger seats. Turned on the car, and the light went off. YAY~~!~!!
AeroWRX is offline   Reply With Quote
Old 01-16-2010, 12:56 AM   #25
hater06
Scooby Specialist
 
Member#: 139699
Join Date: Feb 2007
Chapter/Region: Tri-State
Location: Queens, NY
Vehicle:
2011 WRX STi Limited
OBP

Default

this light came on for me yesterday... i just tried this with every yellow connector under the drivers side (x2) and passenger side (x1)... no dice... what else could a) make the airbag light on the dash turn on and stay on and b) not detect a passenger in my passenger seat ?
hater06 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Airbag light is on, aftermarket seats, 4 airbag cords? subierider Interior & Exterior Modification 7 10-26-2008 06:00 PM
Replacing airbag OE seats - airbag light on? fpan Interior & Exterior Modification 4 10-19-2008 11:06 PM
Airbag light having nothing to do with airbags? coloradosti Interior & Exterior Modification 2 06-27-2004 06:02 PM
('93-'01) airbag light on? ferretboy Impreza Forum 3 05-29-2001 11:39 PM


All times are GMT -4. The time now is 09:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.