Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-11-2009, 12:42 PM   #1
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default Am I in trouble?

I did my 30k service...well...30k miles ago. I am due for my 60k and have been seeing that the coolant conditioner is recomended for all models and all years. I did not put it in 30k miles ago. How bad was this oversight?

Edit....

Called SOA. They said that I do not need the conditioner....FWIW.

Last edited by kpalena; 07-11-2009 at 01:20 PM.
kpalena is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
am i in trouble??? legacydreamz Off-Topic 8 04-20-2007 10:50 PM
am i in trouble? Jeff Moses Tire & Wheel 7 02-11-2007 09:27 PM
TXS Stage 4 + UTEC + 50 Mile One Way Freeway Commute = Am I In Trouble????? xfactor834 Factory 2.0L Turbo Powertrain 4 10-14-2002 03:40 PM
Am i in trouble?? Future Subaru Driver1 Normally Aspirated Powertrain 10 09-28-2001 11:39 PM
Rosecroft Raceway (Maryland)Autocross this weekend. Hoo boy..am I in trouble? El Kabong General Forum Archive 3 05-06-2000 12:36 AM


All times are GMT -4. The time now is 09:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.