Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-04-2009, 12:35 PM   #351
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by peglegsteve View Post
Just got mine back. So far it feels the same as when it was brand new. Very happy so far!
Welp, I just got word that my new engine seized on start-up...

Soooo... Needless to say, Now I'm a little worried...
* Registered users of the site do not see these ads.
Celly is offline   Reply With Quote
Old 08-04-2009, 12:37 PM   #352
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by Celly View Post
Welp, I just got word that my new engine seized on start-up...

Soooo... Needless to say, Now I'm a little worried...
WTF? All the new engines are supposed to be brand spankin new, and problem free...
peglegsteve is offline   Reply With Quote
Old 08-04-2009, 12:48 PM   #353
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by peglegsteve View Post
WTF? All the new engines are supposed to be brand spankin new, and problem free...
Yeah... I dunno anymore... Sorta lost my will to support SOA on this..

We'll see tho, they are tearing it apart now, and should know what happened by tomorrow...
Celly is offline   Reply With Quote
Old 08-04-2009, 12:51 PM   #354
dlessor1
Scooby Newbie
 
Member#: 199804
Join Date: Jan 2009
Location: Nebraska
Vehicle:
2013 WRX Hatch
Black

Default

Quote:
Originally Posted by Celly View Post
Yeah... I dunno anymore... Sorta lost my will to support SOA on this..

We'll see tho, they are tearing it apart now, and should know what happened by tomorrow...
I think I will be purchasing an extended warranty right when I hit 35,000 miles now.....
dlessor1 is offline   Reply With Quote
Old 08-04-2009, 12:56 PM   #355
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by Celly View Post
Yeah... I dunno anymore... Sorta lost my will to support SOA on this..

We'll see tho, they are tearing it apart now, and should know what happened by tomorrow...
Thats crazy. Hopefully SOA gives you a free warranty, if not a whole new car. Do you have any lemon laws in your state? Here in MD, if you're without your car for 30 days or more, due to the same issue, even on multiple visits, your car is considered a lemon. Also, 4 visits to the shop for the same problem make it a lemon. You might want to check in to those laws...
peglegsteve is offline   Reply With Quote
Old 08-04-2009, 01:23 PM   #356
TunaRider
Scooby Newbie
 
Member#: 200713
Join Date: Jan 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2009 WRX
Dark Gray Metallic

Default

Quote:
Originally Posted by Bort View Post
^^^That info is in the first post of this thread.
I just read the entire first post and don't see it. I see where you can get the month and year it was built as we've all been doing, but there's nothing saying the EXACT date it was built (i.e. Sept 6th '08).
TunaRider is offline   Reply With Quote
Old 08-04-2009, 02:33 PM   #357
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by Celly View Post
Welp, I just got word that my new engine seized on start-up...

Soooo... Needless to say, Now I'm a little worried...
Oh the engine may very well have been fine. Keep in mind that service technicians are peforming the service (putting a new long block in); all I can say is that the local service technicians have my car all kinds of ****ed up.
AshJWilliams is offline   Reply With Quote
Old 08-04-2009, 05:16 PM   #358
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default Great......

Seeing Celly's comments on the new engine definately don't have me feelin' real comfortable about this. I believe I'll be requesting a comp'd 100k warranty for sure, one that's transferable due to the loss of value. Anyone will be able to look up, on here, or more over a carfax report, that these cars all have engine replacements. I am also worried about the local tech's putting in a whole new engine, so far so good with the local dealer though, so I'm hopeful their techs are genisus. On the flip side, the mfg f'd that up too....so can't be any worse. Just a shame for anyone, let alone a first time subbie owner. That confidence I had in that car is truly waining, if not gone. All I can do is expect the worst and hope for the best. By the way, Florida's lemon laws Celly are pretty clear and should be in your info packet you got when you bought the car, if you haven't got that covered already. Thanks and good luck peeps.
EVL1 is offline   Reply With Quote
Old 08-04-2009, 08:51 PM   #359
AngelgirlWRX
Scooby Newbie
 
Member#: 217520
Join Date: Jul 2009
Location: Northern CA
Vehicle:
2009 WRX
Dark grey

Default

Does anyone know how we can find out what the numbers are nationally for this engine issue?
AngelgirlWRX is offline   Reply With Quote
Old 08-04-2009, 08:55 PM   #360
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by AngelgirlWRX View Post
Does anyone know how we can find out what the numbers are nationally for this engine issue?
Sadly, I don't think we'll ever get ahold of this information. It'd be nice if we had an extremely friendly SOA rep who would share more info with us, but it seemed to take a long time just to figure out what was causing the bearing problems in the first place. Some people have said every single WRX built during the affected period will eventually fail, I just wonder if that's true, or being blown out of proportion.
peglegsteve is offline   Reply With Quote
Old 08-04-2009, 08:57 PM   #361
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by peglegsteve View Post
Sadly, I don't think we'll ever get ahold of this information. It'd be nice if we had an extremely friendly SOA rep who would share more info with us, but it seemed to take a long time just to figure out what was causing the bearing problems in the first place. Some people have said every single WRX built during the affected period will eventually fail, I just wonder if that's true, or being blown out of proportion.
So I had a conversation with a service technician at my dealer today. He indicated to me that basically all of the vehicles produced within the "bad" VIN range will eventually fail (and also again confirmed what we now know; a switch from lead based to silver based rod bearing was made for both cost and environmental concerns). Apparently he personally has done 6 engine swaps for 09 WRX in the past 3 months.
AshJWilliams is offline   Reply With Quote
Old 08-04-2009, 09:04 PM   #362
AngelgirlWRX
Scooby Newbie
 
Member#: 217520
Join Date: Jul 2009
Location: Northern CA
Vehicle:
2009 WRX
Dark grey

Default

Thanks for the info... does anyone know when Subaru learned that the ones with the bad build dates were all having problems? Mine was built 8/08 and sold to me 2/2/09; I'm thinking they must have known about it by then, so why were they still selling those particular cars?
AngelgirlWRX is offline   Reply With Quote
Old 08-04-2009, 09:07 PM   #363
AngelgirlWRX
Scooby Newbie
 
Member#: 217520
Join Date: Jul 2009
Location: Northern CA
Vehicle:
2009 WRX
Dark grey

Default

Celly,
This was the engine subaru replaced after your first engine had the bearing issue? Did they explain what caused this?
AngelgirlWRX is offline   Reply With Quote
Old 08-04-2009, 09:09 PM   #364
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by AngelgirlWRX View Post
Thanks for the info... does anyone know when Subaru learned that the ones with the bad build dates were all having problems? Mine was built 8/08 and sold to me 2/2/09; I'm thinking they must have known about it by then, so why were they still selling those particular cars?
In the other thread, the first post was 11/29/08. Poster heard internal engine problems, and states they had seen posts regarding 09 WRX problems before that post. So yes, it was known before that. I'm sure that's relatively close to when Subaru realized they had a big problem...
peglegsteve is offline   Reply With Quote
Old 08-04-2009, 09:33 PM   #365
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by AngelgirlWRX View Post
Celly,
This was the engine subaru replaced after your first engine had the bearing issue? Did they explain what caused this?
They had just finished replacing the engine. During startup of the New engine, it immediately seized. So, it's life wasn't in miles... It was apparently in seconds.

I should hopefully know more tomorrow.
Celly is offline   Reply With Quote
Old 08-05-2009, 07:24 AM   #366
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default

Quote:
Originally Posted by AngelgirlWRX View Post
Thanks for the info... does anyone know when Subaru learned that the ones with the bad build dates were all having problems? Mine was built 8/08 and sold to me 2/2/09; I'm thinking they must have known about it by then, so why were they still selling those particular cars?
I hear ya. Mine is the same build date, 08/08, and I bought it at the end of june 09. Thinking they had a pretty ggod idea this was a possibility. Not sure if I was intentionally dupped or if they really didn't know if this would happen or not. I am pretty sure I'll be asking some hard questions upon my next visit to the dealer. Problem is, I really want this car bad.....I hope they don't make me have to be a d**k about this. Fingers crossed.....
EVL1 is offline   Reply With Quote
Old 08-05-2009, 10:43 AM   #367
dlessor1
Scooby Newbie
 
Member#: 199804
Join Date: Jan 2009
Location: Nebraska
Vehicle:
2013 WRX Hatch
Black

Default

I just talked to a salesman in ********, KS. He was downright upset/rude when I brought up the issue of the engine failure. He said it was all because people were rodding their engines and putting bad oil in them. I just laughed and left the dealership right after that. Needless to say I bought a car from another dealership.
dlessor1 is offline   Reply With Quote
Old 08-05-2009, 10:58 AM   #368
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by dlessor1 View Post
I just talked to a salesman in ********, KS. He was downright upset/rude when I brought up the issue of the engine failure. He said it was all because people were rodding their engines and putting bad oil in them. I just laughed and left the dealership right after that. Needless to say I bought a car from another dealership.
Wow. Honesty is the best policy. When I asked my salesman about engine issues, he said he had only seen one WRX come back with engine problems. He said don't worry about it, enjoy the car, and if anything happens, warranty covers it anyway. He was up front with me, so I gave him my business.
peglegsteve is offline   Reply With Quote
Old 08-05-2009, 11:16 AM   #369
AngelgirlWRX
Scooby Newbie
 
Member#: 217520
Join Date: Jul 2009
Location: Northern CA
Vehicle:
2009 WRX
Dark grey

Default

Quote:
Originally Posted by dlessor1 View Post
I just talked to a salesman in ********, KS. He was downright upset/rude when I brought up the issue of the engine failure. He said it was all because people were rodding their engines and putting bad oil in them. I just laughed and left the dealership right after that. Needless to say I bought a car from another dealership.
What a jerk! Not all salesmen are created equal...
AngelgirlWRX is offline   Reply With Quote
Old 08-05-2009, 11:31 AM   #370
blackfang
Scooby Specialist
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

So far we have been lucky and haven't seen any bad ones here at our dealership. I have a few customers with ones that are early build dates with no issues and around 7-9,000 miles. So knock on wood.
blackfang is offline   Reply With Quote
Old 08-05-2009, 06:44 PM   #371
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default

Quote:
Originally Posted by blackfang View Post
So far we have been lucky and haven't seen any bad ones here at our dealership. I have a few customers with ones that are early build dates with no issues and around 7-9,000 miles. So knock on wood.
Keep knocking. Mine went at just under 8K. Waiting on it now...rocking the Yaris 4dr in it's place. Awesome.
EVL1 is offline   Reply With Quote
Old 08-05-2009, 10:41 PM   #372
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Well, two things happened today. I made a call early to SOA, to see about getting a warranty extension for my car. The young lady said she'd check with her manager, and call me back later on. Five minutes later, I had a 7 year and 100k mile warranty. Then, today, the car seemed to hesitate a bit around 3k RPM. I went on a very short drive with a Subaru tech after hours, and he said it doesn't feel right to him. Looks like I'm back to the dealer tomorrow to see whats goin on...
peglegsteve is offline   Reply With Quote
Old 08-06-2009, 07:38 AM   #373
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default

Quote:
Originally Posted by peglegsteve View Post
Well, two things happened today. I made a call early to SOA, to see about getting a warranty extension for my car. The young lady said she'd check with her manager, and call me back later on. Five minutes later, I had a 7 year and 100k mile warranty. Then, today, the car seemed to hesitate a bit around 3k RPM. I went on a very short drive with a Subaru tech after hours, and he said it doesn't feel right to him. Looks like I'm back to the dealer tomorrow to see whats goin on...
Very nice on SoA's part. I emailed them yesterday, plan on calling them today to see if I can get some remedy as well. Good luck with the follow-up today. I wonder if some of you are having problems with the 2nd engine because these guys are doing engine swaps and they may not be as clean as when the factory puts the engine in? I guess I'll be finding that out next week. I'll share my experience then. Later.
EVL1 is offline   Reply With Quote
Old 08-06-2009, 08:26 AM   #374
cmiller219
Scooby Specialist
 
Member#: 187179
Join Date: Aug 2008
Chapter/Region: HIIC
Location: Honolulu, HI
Vehicle:
4102 iTS
PWS

Default

i feel bad for all these people who are having problems i hope i dont my build date is 2/09
cmiller219 is online now   Reply With Quote
Old 08-06-2009, 09:29 AM   #375
WRBear
Scooby Specialist
 
Member#: 207171
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Fairfield County
Vehicle:
2009 Pain in my ass
World Rally Bruised

Default

Quote:
Originally Posted by cmiller219 View Post
i feel bad for all these people who are having problems i hope i dont my build date is 2/09
Don't worry about it. Just drive and enjoy
WRBear is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 200 04-09-2013 02:44 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 01:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.